Modify

Opened 5 years ago

Closed 3 years ago

#13466 closed defect (fixed)

Buffalo WBMR-HP-G300H build error in trunk

Reported by: d.buffa@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

make[4]: Entering directory `/home/daniele/dev/openwrt/trunk/package/platform/lantiq/ltq-tapi'
rm -f /home/daniele/dev/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.drv_tapi_installed
make[4]: [clean-staging] Error 123 (ignored)
make[4]: Leaving directory `/home/daniele/dev/openwrt/trunk/package/platform/lantiq/ltq-tapi'
rm -rf /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi
mkdir -p /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi/host /home/daniele/dev/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/packages /home/daniele/dev/openwrt/trunk/staging_dir/host/packages
install -d -m0755 /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi/usr/include/drv_tapi
cp -fpR --dereference /home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_tapi-3.13.0/include/* /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi/usr/include/drv_tapi
(cd /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi/usr/include/drv_tapi && ln -s . include && ln -s ../ifxos/ifx_types.h .)
find /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi -name '*.la' | xargs -r rm -f; 
if [ -d /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi ]; then (cd /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi; find ./ > /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi.files); 	SHELL= /home/daniele/dev/openwrt/trunk/staging_dir/host/bin/flock /home/daniele/dev/openwrt/trunk/tmp/.staging-dir.flock -c ' mv /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi.files /home/daniele/dev/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/packages/drv_tapi.list && cp -fpR /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi/* /home/daniele/dev/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/; '; fi
rm -rf /home/daniele/dev/openwrt/trunk/tmp/stage-drv_tapi
touch /home/daniele/dev/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.drv_tapi_installed
make[3]: Leaving directory `/home/daniele/dev/openwrt/trunk/package/platform/lantiq/ltq-tapi'
make[3]: Entering directory `/home/daniele/dev/openwrt/trunk/package/platform/lantiq/ltq-vmmc'
WARNING: skipping kmod-ltq-vmmc -- package not selected
rm -rf /home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_vmmc-1.9.0/coef /home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_vmmc-1.9.0/firmware
mkdir -p /home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_vmmc-1.9.0/coef /home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_vmmc-1.9.0/firmware
/bin/gtar -C /home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_vmmc-1.9.0/firmware -xvzf /home/daniele/dev/openwrt/trunk/dl/fw_voip_ifx.tar.gz
tar (child): /home/daniele/dev/openwrt/trunk/dl/fw_voip_ifx.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
/bin/gtar: Child returned status 2
/bin/gtar: Error is not recoverable: exiting now
make[3]: *** [/home/daniele/dev/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-lantiq_xway/drv_vmmc-1.9.0/.configured_] Error 2
make[3]: Leaving directory `/home/daniele/dev/openwrt/trunk/package/platform/lantiq/ltq-vmmc'
make[2]: *** [package/platform/lantiq/ltq-vmmc/compile] Error 2
make[2]: Leaving directory `/home/daniele/dev/openwrt/trunk'
make[1]: *** [/home/daniele/dev/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/daniele/dev/openwrt/trunk'
[daniele@danfedvm trunk]$ ./scripts/diffconfig.sh 
tmp/.config-package.in:37152:error: recursive dependency detected!
tmp/.config-package.in:37152:	symbol PACKAGE_strongswan-full depends on PACKAGE_strongswan-mod-mysql
tmp/.config-package.in:37836:	symbol PACKAGE_strongswan-mod-mysql is selected by PACKAGE_strongswan-full
tmp/.config-package.in:51923:error: recursive dependency detected!
tmp/.config-package.in:51923:	symbol PACKAGE_lcd4linux-custom is selected by PACKAGE_lcd4linux-tew673gru
tmp/.config-package.in:51987:	symbol PACKAGE_lcd4linux-tew673gru depends on LCD4LINUX_CUSTOM_NEEDS_libmysqlclient
feeds/packages/utils/lcd4linux/Config.in:24:	symbol LCD4LINUX_CUSTOM_NEEDS_libmysqlclient is selected by LCD4LINUX_CUSTOM_PLUGIN_mysql
feeds/packages/utils/lcd4linux/Config.in:434:	symbol LCD4LINUX_CUSTOM_PLUGIN_mysql depends on PACKAGE_lcd4linux-custom
tmp/.config-package.in:53793:error: recursive dependency detected!
tmp/.config-package.in:53793:	symbol PACKAGE_nprobe depends on NPROBE_MYSQL_SUPPORT
tmp/.config-package.in:53814:	symbol NPROBE_MYSQL_SUPPORT depends on PACKAGE_nprobe
tmp/.config-package.in:37152:error: recursive dependency detected!
tmp/.config-package.in:37152:	symbol PACKAGE_strongswan-full depends on PACKAGE_strongswan-mod-mysql
tmp/.config-package.in:37836:	symbol PACKAGE_strongswan-mod-mysql is selected by PACKAGE_strongswan-full
tmp/.config-package.in:51923:error: recursive dependency detected!
tmp/.config-package.in:51923:	symbol PACKAGE_lcd4linux-custom is selected by PACKAGE_lcd4linux-tew673gru
tmp/.config-package.in:51987:	symbol PACKAGE_lcd4linux-tew673gru depends on LCD4LINUX_CUSTOM_NEEDS_libmysqlclient
feeds/packages/utils/lcd4linux/Config.in:24:	symbol LCD4LINUX_CUSTOM_NEEDS_libmysqlclient is selected by LCD4LINUX_CUSTOM_PLUGIN_mysql
feeds/packages/utils/lcd4linux/Config.in:434:	symbol LCD4LINUX_CUSTOM_PLUGIN_mysql depends on PACKAGE_lcd4linux-custom
tmp/.config-package.in:53793:error: recursive dependency detected!
tmp/.config-package.in:53793:	symbol PACKAGE_nprobe depends on NPROBE_MYSQL_SUPPORT
tmp/.config-package.in:53814:	symbol NPROBE_MYSQL_SUPPORT depends on PACKAGE_nprobe
CONFIG_TARGET_lantiq=y
CONFIG_TARGET_lantiq_xway=y
CONFIG_TARGET_lantiq_xway_WBMRA=y
CONFIG_OPENVPN_openssl_ENABLE_DEF_AUTH=y
CONFIG_OPENVPN_openssl_ENABLE_FRAGMENT=y
CONFIG_OPENVPN_openssl_ENABLE_HTTP=y
CONFIG_OPENVPN_openssl_ENABLE_LZO=y
CONFIG_OPENVPN_openssl_ENABLE_MULTIHOME=y
CONFIG_OPENVPN_openssl_ENABLE_PF=y
CONFIG_OPENVPN_openssl_ENABLE_PORT_SHARE=y
CONFIG_OPENVPN_openssl_ENABLE_SERVER=y
CONFIG_OPENVPN_openssl_ENABLE_SOCKS=y
CONFIG_PACKAGE_asterisk-gui=y
CONFIG_PACKAGE_asterisk18=y
CONFIG_PACKAGE_asterisk18-app-authenticate=y
CONFIG_PACKAGE_asterisk18-app-disa=y
CONFIG_PACKAGE_asterisk18-app-exec=y
CONFIG_PACKAGE_asterisk18-app-record=y
CONFIG_PACKAGE_asterisk18-app-senddtmf=y
CONFIG_PACKAGE_asterisk18-app-setcallerid=y
CONFIG_PACKAGE_asterisk18-app-system=y
CONFIG_PACKAGE_asterisk18-chan-gtalk=y
CONFIG_PACKAGE_asterisk18-chan-local=y
CONFIG_PACKAGE_asterisk18-codec-a-mu=y
CONFIG_PACKAGE_asterisk18-codec-alaw=y
CONFIG_PACKAGE_asterisk18-func-channel=y
CONFIG_PACKAGE_asterisk18-func-cut=y
CONFIG_PACKAGE_asterisk18-res-clioriginate=y
CONFIG_PACKAGE_asterisk18-res-crypto=y
CONFIG_PACKAGE_ddns-scripts=y
CONFIG_PACKAGE_etherwake=y
CONFIG_PACKAGE_freifunk-p2pblock=y
CONFIG_PACKAGE_iptables-mod-conntrack-extra=y
CONFIG_PACKAGE_iptables-mod-filter=y
CONFIG_PACKAGE_iptables-mod-ipopt=y
CONFIG_PACKAGE_iptables-mod-ipp2p=y
CONFIG_PACKAGE_kmod-crypto-ecb=y
CONFIG_PACKAGE_kmod-crypto-sha1=y
CONFIG_PACKAGE_kmod-gre=y
CONFIG_PACKAGE_kmod-ifb=y
CONFIG_PACKAGE_kmod-ipt-compat-xtables=y
CONFIG_PACKAGE_kmod-ipt-conntrack-extra=y
CONFIG_PACKAGE_kmod-ipt-filter=y
CONFIG_PACKAGE_kmod-ipt-ipopt=y
CONFIG_PACKAGE_kmod-ipt-ipp2p=y
CONFIG_PACKAGE_kmod-lib-textsearch=y
CONFIG_PACKAGE_kmod-mppe=y
CONFIG_PACKAGE_kmod-sched-connmark=y
CONFIG_PACKAGE_kmod-sched-core=y
CONFIG_PACKAGE_kmod-tun=y
CONFIG_PACKAGE_l7-protocols=y
CONFIG_PACKAGE_libcyassl=y
CONFIG_PACKAGE_libgcrypt=y
CONFIG_PACKAGE_libgnutls=y
CONFIG_PACKAGE_libgpg-error=y
CONFIG_PACKAGE_libiksemel=y
CONFIG_PACKAGE_libiwinfo=y
CONFIG_PACKAGE_libiwinfo-lua=y
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_liblzo=y
CONFIG_PACKAGE_libncurses=y
CONFIG_PACKAGE_libnfnetlink=y
CONFIG_PACKAGE_libopenssl=y
CONFIG_PACKAGE_libpopt=y
CONFIG_PACKAGE_libtasn1=y
CONFIG_PACKAGE_libubus-lua=y
CONFIG_PACKAGE_libuci-lua=y
CONFIG_PACKAGE_libustream-cyassl=y
CONFIG_PACKAGE_lua=y
CONFIG_PACKAGE_luci=y
CONFIG_PACKAGE_luci-app-ddns=y
CONFIG_PACKAGE_luci-app-firewall=y
CONFIG_PACKAGE_luci-app-p2pblock=y
CONFIG_PACKAGE_luci-app-pbx=y
CONFIG_PACKAGE_luci-app-qos=y
CONFIG_PACKAGE_luci-app-upnp=y
CONFIG_PACKAGE_luci-app-wol=y
CONFIG_PACKAGE_luci-i18n-english=y
CONFIG_PACKAGE_luci-lib-core=y
CONFIG_PACKAGE_luci-lib-ipkg=y
CONFIG_PACKAGE_luci-lib-nixio=y
CONFIG_PACKAGE_luci-lib-sys=y
CONFIG_PACKAGE_luci-lib-web=y
CONFIG_PACKAGE_luci-mod-admin-core=y
CONFIG_PACKAGE_luci-mod-admin-full=y
CONFIG_PACKAGE_luci-proto-core=y
CONFIG_PACKAGE_luci-proto-ppp=y
CONFIG_PACKAGE_luci-sgi-cgi=y
CONFIG_PACKAGE_luci-ssl=y
CONFIG_PACKAGE_luci-theme-base=y
CONFIG_PACKAGE_luci-theme-bootstrap=y
CONFIG_PACKAGE_miniupnpd=y
CONFIG_PACKAGE_openvpn-openssl=y
CONFIG_PACKAGE_pptpd=y
CONFIG_PACKAGE_px5g=y
CONFIG_PACKAGE_qos-scripts=y
CONFIG_PACKAGE_tc=y
CONFIG_PACKAGE_terminfo=y
CONFIG_PACKAGE_uhttpd=y
CONFIG_PACKAGE_uhttpd-mod-ubus=y
CONFIG_PACKAGE_zlib=y

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by d.buffa@…

It is an asterisk related problem, if I remove it I'm able to build. But this issue was introduced with latest versions

comment:2 Changed 3 years ago by jogo

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.