Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13449 closed defect (invalid)

netifd can't assign ipv6 to a second wlan interface(ie a guest wlan).

Reported by: xinglp <xinglp@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

My config files below:

/etc/conifg/wireless

config wifi-iface 'guest'
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'xxxx-guest'
        option network 'wlan_guest'

/etc/config/network

config interface 'henet'
        option proto '6in4'
        option auto '1'
        option peeraddr 'xxxxxx'
        option ip6addr '2001:xxxx::2/64'
        option ip6prefix '2001:xxyxx::/64'
        option tunnelid 'xxxx'
        option username 'xxxx
        option password 'xxxxx'

# This interface has a 2001:xxx ipv6
config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

# This interface NOT has a 2001:xxx ipv6
config interface 'wlan_guest'
        option proto 'static'
        option ipaddr '192.168.200.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

The error log is:

xxxx - syslog: netifd: Failed to assign subprefix of size 65 for lan_guest

/etc/config/6relayd

config server 'default'
        option master 'wan6'
        list network 'lan'
        list network 'wlan_guest'
        option rd 'server'
        option dhcpv6 'server'
        option fallback_relay 'rd dhcpv6 ndp'
        option compat_ula '1'

There are also some changes in firewall dhcp upnpd, they all work fine, except IPV6.

Thanks.

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 5 years ago by anonymous

The ip6prefix on your henet is only a /64. It cannot be used on two interfaces. You need to get a routed /48 from henet and use this in ip6prefix. /64 is the minimum size and therefore cannot be split up anymore and thus only be used on one interface.

comment:2 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Configuration mistake

comment:3 in reply to: ↑ 1 Changed 5 years ago by xinglp <xinglp@…>

Replying to anonymous:

The ip6prefix on your henet is only a /64. It cannot be used on two interfaces. You need to get a routed /48 from henet and use this in ip6prefix. /64 is the minimum size and therefore cannot be split up anymore and thus only be used on one interface.

Thanks a lot :-)

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.