Modify

Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#13432 closed task (fixed)

Phicomm M1 (new platform)

Reported by: mbielowicz@… Owned by: hauke
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Hi
Today I ran OpenWRT Barrier Breaker on Phicomm M1 http://www.phicomm.com/en/products_dt.ehtml?id=115

========================
Decompressing...done

CFE version 5.100.138.9 based on BBP 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: Wed Dec 21 13:25:44 CST 2011 (zhaoyanming@wireless)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.
Boot partition size = 131072(0x20000)
Found an ST compatible serial flash with 64 64KB blocks; total size 4MB
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.100.138.9
CPU type 0x19749: 300MHz
Tot mem: 32768 KBytes

CFE mem: 0x80700000 - 0x807990C0 (626880)
Data: 0x8072EF10 - 0x80732130 (12832)
BSS: 0x80732130 - 0x807330C0 (3984)
Heap: 0x807330C0 - 0x807970C0 (409600)
Stack: 0x807970C0 - 0x807990C0 (8192)
Text: 0x80700000 - 0x8072EF04 (192260)

Device eth0: hwaddr D8-42-AC-8B-AA-5A, ipaddr 192.168.1.1, mask 255.255.255.0

gateway not set, nameserver not set

Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
Loading: Failed.
Could not load :: Timeout occured
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .. 3780 bytes read
Entry at 0x80001000
Closing network.
Starting program at 0x80001000
[ 0.000000] Linux version 3.6.11 (fnord@tschunk) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2012.12 r36461) ) #1 Sat Apr 27 04:11:51 UTC 2013
[ 0.000000] CPU revision is: 00019749 (MIPS 74Kc)
[ 0.000000] bcm47xx: using bcma bus
[ 0.000000] bcma: bus0: Found chip with id 0xD144, rev 0x01 and package 0x0B
[ 0.000000] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x27, class 0x0)
[ 0.000000] bcma: bus0: Core 3 found: MIPS 74K (manuf 0x4A7, id 0x82C, rev 0x05, class 0x0)
[ 0.000000] bus0: Found M25P32 serial flash (size: 4096KiB, blocksize: 0x10000, blocks: 64)
[ 0.000000] bcma: bus0: Early bus registered
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 02000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x01ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x01ffffff]
[ 0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
[ 0.000000] Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] ex_table already sorted, skipping sort
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 28916k/32768k available (2560k kernel code, 3852k reserved, 538k data, 168k init, 0k highmem)
[ 0.000000] NR_IRQS:128
[ 0.032000] Calibrating delay loop... 149.50 BogoMIPS (lpj=299008)
[ 0.032000] pid_max: default: 32768 minimum: 301
[ 0.032000] Mount-cache hash table entries: 512
[ 0.036000] NET: Registered protocol family 16
[ 0.064000] bio: create slab <bio-0> at 0
[ 0.072000] Switching to clocksource MIPS
[ 0.084000] NET: Registered protocol family 2
[ 0.084000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[ 0.084000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.084000] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.088000] TCP: reno registered
[ 0.088000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.088000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.088000] NET: Registered protocol family 1
[ 0.088000] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x1C, class 0x0)
[ 0.088000] bcma: bus0: Core 2 found: GBit MAC (manuf 0x4BF, id 0x82D, rev 0x03, class 0x0)
[ 0.088000] bcma: bus0: Core 4 found: SDR/DDR1 Memory Controller (manuf 0x4BF, id 0x835, rev 0x02, class 0x0)
[ 0.096000] can not parse nvram name sb/1/rxpo2g(null) with value 0xff got -34
[ 0.096000] can not parse nvram name sb/1/ag3(null) with value 0xff got -34
[ 0.132000] bcma: bus0: Bus registered
[ 0.136000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.136000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.140000] msgmni has been set to 56
[ 0.140000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.140000] io scheduler noop registered
[ 0.140000] io scheduler deadline registered (default)
[ 0.140000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.176000] serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 2) is a U6_16550A
[ 0.520000] console [ttyS0] enabled
[ 0.528000] bcm47xx_sflash: found serial flash: blocksize=64KB, numblocks=64, size=4096KB
[ 0.536000] bcm47xx_part: bootloader size: 131072
[ 0.544000] Found board: "Unknown Board"
[ 0.548000] bcm47xx_part: Looking for dual image
[ 0.552000] bcm47xx_part: TRX offset : 0
[ 0.556000] 4 bcm47xx partitions found on MTD device bcm47xx-sflash
[ 0.564000] Creating 4 MTD partitions on "bcm47xx-sflash":
[ 0.568000] 0x000000000000-0x000000020000 : "cfe"
[ 0.580000] 0x000000020000-0x0000003f0000 : "linux"
[ 0.588000] 0x000000123c00-0x0000003f0000 : "rootfs"
[ 0.592000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.612000] mtd: partition "rootfs" set to be root filesystem
[ 0.616000] mtd: partition "rootfs_data" created automatically, ofs=290000, len=160000
[ 0.624000] 0x000000290000-0x0000003f0000 : "rootfs_data"
[ 0.636000] 0x0000003f0000-0x000000400000 : "nvram"
[ 0.648000] bcm47xx-wdt bcm47xx-wdt.0: BCM47xx Watchdog Timer enabled (30 seconds)
[ 0.656000] TCP: cubic registered
[ 0.660000] NET: Registered protocol family 17
[ 0.664000] Bridge firewalling registered
[ 0.672000] 8021q: 802.1Q VLAN Support v1.8
[ 0.692000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 0.700000] Freeing unused kernel memory: 168k freed
[ 3.956000] diag: unknown board found, try legacy detect
[ 3.960000] diag: please open a ticket at https://dev.openwrt.org and attach the complete nvram
[ 3.972000] diag: Router model not detected.
[ 4.680000] bgmac bcma0:1: Found PHY addr: 30 (NOREGS)
[ 4.688000] bgmac bcma0:1: TX on ring 0x200 supports unaligned addressing but this feature is not implemented
[ 4.700000] bgmac bcma0:1: TX on ring 0x240 supports unaligned addressing but this feature is not implemented
[ 4.708000] bgmac bcma0:1: TX on ring 0x280 supports unaligned addressing but this feature is not implemented
[ 4.720000] bgmac bcma0:1: TX on ring 0x2C0 supports unaligned addressing but this feature is not implemented
[ 4.728000] bgmac bcma0:1: RX on ring 0x200 supports unaligned addressing but this feature is not implemented
[ 4.744000] bgmac bcma0:1: Support for Roboswitch not implemented
[ 4.800000] bgmac: Broadcom 47xx GBit MAC driver loaded
[ 5.036000] roboswitch: Probing device 'eth0'
[ 5.048000] roboswitch: found a 5325! at eth0
[ 5.164000] diag: unknown board found, try legacy detect
[ 5.168000] diag: please open a ticket at https://dev.openwrt.org and attach the complete nvram
[ 5.176000] diag: Router model not detected.

  • preinit -

Press the [f] key and hit [enter] to enter failsafe mode

  • regular preinit -

[ 9.172000] jffs2: notice: (341) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 6 of xref (0 dead, 2 orphan) found.
switching to jffs2

  • init -

Please press Enter to activate this console. [ 12.224000] NET: Registered protocol family 10
[ 12.468000] PPP generic driver version 2.4.2
[ 12.852000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 13.092000] NET: Registered protocol family 24
[ 13.136000] nf_conntrack version 0.5.0 (454 buckets, 1816 max)
[ 13.584000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 20.492000] device eth0.1 entered promiscuous mode
[ 20.496000] device eth0 entered promiscuous mode
[ 20.508000] br-lan: port 1(eth0.1) entered forwarding state
[ 20.512000] br-lan: port 1(eth0.1) entered forwarding state
[ 21.488000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[ 22.516000] br-lan: port 1(eth0.1) entered forwarding state

BusyBox v1.19.4 (2013-04-26 21:25:52 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

-----------------------------------------------------
BARRIER BREAKER (Bleeding Edge, r36461)
-----------------------------------------------------

  • 1/2 oz Galliano Pour all ingredients into
  • 4 oz cold Coffee an irish coffee mug filled
  • 1 1/2 oz Dark Rum with crushed ice. Stir.
  • 2 tsp. Creme de Cacao

-----------------------------------------------------

root@OpenWrt:/#
root@OpenWrt:/# ifconfig -a
br-lan Link encap:Ethernet HWaddr D8:42:AC:8B:AA:5A

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::da42:acff:fe8b:aa5a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:1194 (1.1 KiB)

eth0 Link encap:Ethernet HWaddr D8:42:AC:8B:AA:5A

inet6 addr: fe80::da42:acff:fe8b:aa5a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:4

eth0.1 Link encap:Ethernet HWaddr D8:42:AC:8B:AA:5A

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:1194 (1.1 KiB)

eth0.2 Link encap:Ethernet HWaddr D8:42:AC:8B:AA:5A

inet6 addr: fe80::da42:acff:fe8b:aa5a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:202 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:78222 (76.3 KiB)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4656 errors:0 dropped:0 overruns:0 frame:0
TX packets:4656 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:316608 (309.1 KiB) TX bytes:316608 (309.1 KiB)

root@OpenWrt:/#
root@OpenWrt:/# nvram show
boardnum=80
sb/1/rxpo2g=0xff
sb/1/antswitch=0x0
landevs=vlan1 wl0
sb/1/pa2gw0a0=0xfff5
sb/1/pa2gw0a1=0xFE83
sb/1/cck2gpo=0x0
sdram_ncdl=0x00000000
sb/1/macaddr=D8:42:AC:8B:AA:5B
sb/1/boardflags=0x710
sb/1/boardflags2=0x1000
sb/1/pa2gw1a0=0x1c00
sb/1/pa2gw1a1=0x159A
sb/1/stbcpo=0x0
wl_msglevel=0x1
sb/1/pa2gw2a0=0xfaf5
sb/1/pa2gw2a1=0xFAAE
sb/1/cddpo=0x0
sb/1/pdetrange2g=0x2
sb/1/devid=0x4329
sb/1/bw40po=0x0
sb/1/ccode=0
sdram_config=0x103
vlan1hwname=et0
sb/1/leddc=0xffff
sb/1/regrev=0
lan_netmask=255.255.255.0
sb/1/sromrev=8
vlan2ports=1 5
reset_gpio=21
et0macaddr=D8:42:AC:8B:AA:5A
antswctl2g=0x0
sb/1/ofdm2gpo=0x30000000
sb/1/opo=0x0
sb/1/tri2g=0xff
sdram_init=0x0000
sb/1/tssipos2g=0x1
et0phyaddr=30
boardflags=0x710
wandevs=vlan2
sb/1/temps_hysteresis=5
clkfreq=300,150,75
lan_ipaddr=192.168.1.1
wait_time=3
sb/1/aa2g=0x1
sb/1/bwduppo=0x0
boardtype=0x0590
sb/1/triso2g=0x5
sb/1/rssisav2g=0x7
pmon_ver=CFE 5.100.138.9
sb/1/bxa2g=0x3
sb/1/mcs2gpo7=0x5200
sb/1/rssismc2g=0xf
sb/1/mcs2gpo3=0x5200
sb/1/mcs2gpo4=0x0000
boot_wait=on
sb/1/mcs2gpo5=0x5200
sb/1/mcs2gpo6=0x0000
sb/1/temps_period=5
sb/1/mcs2gpo0=0x0000
sb/1/mcs2gpo1=0x5200
sb/1/mcs2gpo2=0x0000
boardrev=0x1104
opo=0x0
sb/1/rxchain=0x1
sb/1/ledbh3=11
sb/1/ledbh5=2
sb/1/ledbh6=10
sb/1/ledbh0=11
sb/1/ledbh1=11
sb/1/maxp2ga0=0x4C
sb/1/ledbh2=11
sb/1/maxp2ga1=0x4C
sb/1/antswctl2g=0x0
sdram_refresh=0x0000
vlan1ports=0 2 3 4 5*
boardflags2=0x1000
sb/1/txchain=0x1
xtalfreq=20000
sb/1/extpagain2g=0x2
vlan2hwname=et0
sb/1/rssismf2g=0xf
sb/1/ag0=0x2
sb/1/ag1=0x2
sb/1/ag2=0x2
sb/1/ag3=0xff
sb/1/itt2ga1=0x20
sb/1/tempthresh=120
sb/1/itt2ga0=0x20
et0mdcport=0
watchdog=0
root@OpenWrt:/#

More info at http://eko.one.pl/forum/viewtopic.php?id=5976 (Polish language)

Attachments (3)

Booting.txt (9.2 KB) - added by mbielowicz@… 5 years ago.
Booting process
Interfaces.txt (2.8 KB) - added by mbielowicz@… 5 years ago.
ifconfig output
NVRAM.txt (1.6 KB) - added by mbielowicz@… 5 years ago.
nvram show output

Download all attachments as: .zip

Change History (18)

Changed 5 years ago by mbielowicz@…

Booting process

Changed 5 years ago by mbielowicz@…

ifconfig output

Changed 5 years ago by mbielowicz@…

nvram show output

comment:1 Changed 5 years ago by anonymous

I have flashed http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-brcm47xx-squashfs.trx from Phicomm M1's GUI, and no ethernet connectivity after this, only serial console.

Error while pinging router from PC:
[ 334.528000] bgmac bcma0:1: Hardware reported transmission for empty TX ring slot 122! End of ring: 0

comment:2 Changed 4 years ago by anonymous

any news on this?

comment:3 Changed 4 years ago by Zajec

There isn't any real device-specific entry in the NVRAM :(

@Hauke: I'm afraid we have to use your new board*-based method for detecting this device. Extracted entries:
boardtype=0x0590
boardnum=80
boardrev=0x1104

@m80: the issue with ethernet is duplicate of /ticket/13066.html and will be fixed very soon.

comment:5 in reply to: ↑ 4 Changed 4 years ago by zibidik

Replying to Zajec:

New product page URL: http://en.phicomm.com/products_dt.ehtml?id=115&treeId=139

I am a beginner. I was so
inquisitively (and stupid) and i have flashed ​http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-brcm47xx-squashfs.trx from Phicomm M1's GUI too. :(

Now i have not ethernet and wireless connection with M1. I want install orginal firmware again. Is it possible? And how? Thank you. and sorry for my bad english.

comment:6 Changed 4 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to accepted

comment:7 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from accepted to closed

Hi, thanks for the information.

Board detection was added in r38009, someone has do prepare a patch with the gpio configuration if this device and send it to the mailing list.

The Ethernet problems should be fixed by now.

comment:8 follow-up: Changed 4 years ago by Zajec

@zibidik: I've just finished CFE howto wiki page, see http://wiki.openwrt.org/doc/techref/bootloader/cfe

You can also try installing original firmware using OpenWrt.

comment:9 in reply to: ↑ 8 Changed 4 years ago by zibidik

Replying to Zajec:

@zejac Thank you. I tried but it doesnt work.

I have no ethernet( TFTP)- connectivity...no pings...I have connectivity only with serial console.

I can not flash with CFE- TFTP methods. Are there any other options?

I dont know what I'm doing something wrong.

comment:10 Changed 4 years ago by darkside401@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi there,
i flashed the current snapshot on this device and it is working. I have Ethernet connectivity. But how do it get Wifi working? It simply does not show up. Do i need to install some kernel module as driver for it?

comment:11 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from reopened to closed

There is no driver in OpenWrt for the wifi core used in your device.

comment:12 Changed 3 years ago by anonymous

What is the correct image? openwrt-brcm47xx-mips74k-squashfs.trx from generic, legacy or mips74k?

comment:13 Changed 3 years ago by anonymous

Image is openwrt-brcm47xx-generic-squashfs.trx

BusyBox v1.22.1 (2014-10-27 10:43:12 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r43076)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:~#
root@OpenWrt:~# dmesg
[    0.000000] Linux version 3.14.18 (openwrt@gb-13) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r43076) ) #1 Mon Oct 27 10:56:08 UTC 2014
[    0.000000] CPU0 revision is: 00019749 (MIPS 74Kc)
[    0.000000] bcm47xx: using bcma bus
[    0.000000] bcma: bus0: Found chip with id 53572, rev 0x01 and package 0x0B
[    0.000000] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x27, class 0x0)
[    0.000000] bcma: bus0: Core 3 found: MIPS 74K (manuf 0x4A7, id 0x82C, rev 0x05, class 0x0)
[    0.000000] bcma: bus0: Found rev 9 PMU (capabilities 0x28982A09)
[    0.000000] bcma: bus0: Found serial flash
[    0.000000] bcma: bus0: Found M25P32 serial flash (size: 4096KiB, blocksize: 0x10000, blocks: 64)
[    0.000000] bcma: bus0: Early bus registered
[    0.000000] MIPS: machine is Phicomm M1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 80312600, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8192 pages, LIFO batch:0
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 28780K/32768K available (2601K kernel code, 118K rwdata, 504K rodata, 156K init, 230K bss, 3988K reserved)
[    0.000000] NR_IRQS:128
[    0.000000] Setting up vectored interrupts
[    0.070000] Calibrating delay loop... 149.91 BogoMIPS (lpj=749568)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.070000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] NET: Registered protocol family 16
[    0.100000] bio: create slab <bio-0> at 0
[    0.120000] Switched to clocksource MIPS
[    0.130000] NET: Registered protocol family 2
[    0.130000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.130000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.130000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.130000] TCP: reno registered
[    0.130000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.130000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.130000] NET: Registered protocol family 1
[    0.130000] PCI: CLS 0 bytes, default 32
[    0.140000] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x1C, class 0x0)
[    0.140000] bcma: bus0: Core 2 found: GBit MAC (manuf 0x4BF, id 0x82D, rev 0x03, class 0x0)
[    0.140000] bcma: bus0: Core 4 found: SDR/DDR1 Memory Controller (manuf 0x4BF, id 0x835, rev 0x02, class 0x0)
[    0.140000] can not parse nvram name sb/1/rxpo2g(null) with value 0xff got -34
[    0.140000] can not parse nvram name sb/1/ag3(null) with value 0xff got -34
[    0.170000] bcma: bus0: Using SPROM revision 8 provided by platform.
[    0.170000] bcma: bus0: PMU resource config unknown or not needed for device 0xD144
[    0.170000] bcma: bus0: Workarounds unknown or not needed for device 0xD144
[    0.170000] bcma: bus0: Initializing MIPS core...
[    0.170000] bcma: bus0: set_irq: core 0x0812, irq 3 => 3
[    0.170000] bcma: bus0: set_irq: core 0x082d, irq 4 => 4
[    0.170000] bcma: bus0: set_irq: core 0x0800, irq 2 => 2
[    0.170000] bcma: bus0: IRQ reconfiguration done
[    0.170000] bcma: core 0x0800, irq : 2(S)* 3  4  5  6  D  I
[    0.170000] bcma: core 0x082c, irq : 2(S)  3  4  5  6  D  I*
[    0.170000] bcma: core 0x0812, irq : 2(S)  3* 4  5  6  D  I
[    0.170000] bcma: core 0x082d, irq : 2(S)  3  4* 5  6  D  I
[    0.170000] bcma: core 0x0835, irq : 2(S)  3  4  5  6  D* I
[    0.180000] bcma: bus0: Bus registered
[    0.190000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.190000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.190000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.190000] msgmni has been set to 56
[    0.190000] io scheduler noop registered
[    0.190000] io scheduler deadline registered (default)
[    0.190000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.230000] serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 2, base_baud = 1250000) is a U6_16550A
[    0.580000] console [ttyS0] enabled
[    0.610000] 6 bcm47xxpart partitions found on MTD device bcm47xxsflash
[    0.610000] Creating 6 MTD partitions on "bcm47xxsflash":
[    0.620000] 0x000000000000-0x000000020000 : "boot"
[    0.630000] 0x000000020000-0x0000003f0000 : "firmware"
[    0.640000] 0x00000002001c-0x00000002090c : "loader"
[    0.650000] 0x00000002090c-0x00000013fc00 : "linux"
[    0.650000] mtd: partition "linux" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.670000] 0x00000013fc00-0x0000003f0000 : "rootfs"
[    0.680000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.690000] mtd: device 4 (rootfs) set to be root filesystem
[    0.700000] 1 squashfs-split partitions found on MTD device rootfs
[    0.710000] 0x000000340000-0x0000003f0000 : "rootfs_data"
[    0.720000] 0x0000003f0000-0x000000400000 : "nvram"
[    0.730000] libphy: Fixed MDIO Bus: probed
[    0.740000] bcm47xx-wdt bcm47xx-wdt.0: BCM47xx Watchdog Timer enabled (30 seconds)
[    0.750000] GPIO_WDT: failed to register misc device
[    0.760000] TCP: cubic registered
[    0.760000] NET: Registered protocol family 17
[    0.760000] Bridge firewalling registered
[    0.770000] 8021q: 802.1Q VLAN Support v1.8
[    0.790000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.800000] Freeing unused kernel memory: 156K (80329000 - 80350000)
[    5.680000] pps_core: LinuxPPS API ver. 1 registered
[    5.690000] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    5.700000] PTP clock support registered
[    5.720000] bgmac bcma0:2: Found PHY addr: 30 (NOREGS)
[    5.730000] bgmac bcma0:2: Support for Roboswitch not implemented
[    5.740000] libphy: bgmac mii bus: probed
[    5.830000] b53_common: found switch: BCM5325, rev 4
[    5.840000] bgmac: Broadcom 47xx GBit MAC driver loaded
[    7.780000] random: mktemp urandom read with 56 bits of entropy available
[   17.570000] NET: Registered protocol family 10
[   17.590000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   17.620000] Loading modules backported from Linux version master-2014-10-08-0-g0275925
[   17.630000] Backport generated by backports.git backports-20140905-1-gde42785
[   17.640000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   17.680000] nf_conntrack version 0.5.0 (452 buckets, 1808 max)
[   17.770000] xt_time: kernel timezone is -0000
[   17.830000] cfg80211: Calling CRDA to update world regulatory domain
[   17.830000] cfg80211: World regulatory domain updated:
[   17.840000] cfg80211:  DFS Master region: unset
[   17.840000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   17.850000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   17.860000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   17.870000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   17.880000] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[   17.890000] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   17.900000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   17.900000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   17.910000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   18.060000] PPP generic driver version 2.4.2
[   18.070000] NET: Registered protocol family 24
[   18.120000] b43-phy0: Broadcom 53572 WLAN found (core revision 28)
[   18.130000] b43-phy0: Found PHY: Analog 9, Type 4 (N), Revision 17
[   18.140000] b43-phy0 ERROR: FOUND UNSUPPORTED RADIO (Manuf 0x17F, ID 0x2057, Revision 13, Version 0)
[   18.150000] b43: probe of bcma0:1 failed with error -122
[   18.150000] Broadcom 43xx driver loaded [ Features: PNL ]
[   18.170000] Broadcom 43xx-legacy driver loaded [ Features: PLD ]
[   26.430000] random: nonblocking pool is initialized
[   29.170000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   29.170000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   29.180000] jffs2_build_filesystem(): erasing all blocks after the end marker...
[   35.910000] device eth0.1 entered promiscuous mode
[   35.920000] device eth0 entered promiscuous mode
[   35.930000] br-lan: port 1(eth0.1) entered forwarding state
[   35.930000] br-lan: port 1(eth0.1) entered forwarding state
[   37.930000] br-lan: port 1(eth0.1) entered forwarding state
[   40.610000] done.
[   40.610000] jffs2: notice: (761) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
root@OpenWrt:~#
root@OpenWrt:~# ifconfig -a
br-lan    Link encap:Ethernet  HWaddr D8:42:AC:8B:AA:5A
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::da42:acff:fe8b:aa5a/64 Scope:Link
          inet6 addr: fda7:ec0f:f689::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2369 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2328 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:168406 (164.4 KiB)  TX bytes:756435 (738.7 KiB)

eth0      Link encap:Ethernet  HWaddr D8:42:AC:8B:AA:5A
          inet6 addr: fe80::da42:acff:fe8b:aa5a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr D8:42:AC:8B:AA:5A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2369 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2305 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:168406 (164.4 KiB)  TX bytes:754177 (736.5 KiB)

eth0.2    Link encap:Ethernet  HWaddr D8:42:AC:8B:AA:5A
          inet6 addr: fe80::da42:acff:fe8b:aa5a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:276 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:89721 (87.6 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6072 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6072 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:413496 (403.8 KiB)  TX bytes:413496 (403.8 KiB)

root@OpenWrt:~# nvram show
boardnum=80
sb/1/rxpo2g=0xff
sb/1/antswitch=0x0
landevs=vlan1 wl0
sb/1/pa2gw0a0=0xfff5
sb/1/pa2gw0a1=0xFE83
sb/1/cck2gpo=0x0
sdram_ncdl=0x00000000
sb/1/macaddr=D8:42:AC:8B:AA:5B
sb/1/boardflags=0x710
sb/1/boardflags2=0x1000
sb/1/pa2gw1a0=0x1c00
sb/1/pa2gw1a1=0x159A
sb/1/stbcpo=0x0
wl_msglevel=0x1
sb/1/pa2gw2a0=0xfaf5
sb/1/pa2gw2a1=0xFAAE
sb/1/cddpo=0x0
sb/1/pdetrange2g=0x2
sb/1/devid=0x4329
sb/1/bw40po=0x0
sb/1/ccode=0
sdram_config=0x103
vlan1hwname=et0
sb/1/leddc=0xffff
sb/1/regrev=0
lan_netmask=255.255.255.0
sb/1/sromrev=8
vlan2ports=1 5
reset_gpio=21
et0macaddr=D8:42:AC:8B:AA:5A
antswctl2g=0x0
sb/1/ofdm2gpo=0x30000000
sb/1/opo=0x0
sb/1/tri2g=0xff
sdram_init=0x0000
sb/1/tssipos2g=0x1
et0phyaddr=30
boardflags=0x710
wandevs=vlan2
sb/1/temps_hysteresis=5
clkfreq=300,150,75
lan_ipaddr=192.168.1.1
wait_time=3
sb/1/aa2g=0x1
sb/1/bwduppo=0x0
boardtype=0x0590
sb/1/triso2g=0x5
sb/1/rssisav2g=0x7
pmon_ver=CFE 5.100.138.9
sb/1/bxa2g=0x3
sb/1/mcs2gpo7=0x5200
sb/1/rssismc2g=0xf
sb/1/mcs2gpo3=0x5200
sb/1/mcs2gpo4=0x0000
boot_wait=on
sb/1/mcs2gpo5=0x5200
sb/1/mcs2gpo6=0x0000
sb/1/temps_period=5
sb/1/mcs2gpo0=0x0000
sb/1/mcs2gpo1=0x5200
sb/1/mcs2gpo2=0x0000
boardrev=0x1104
opo=0x0
sb/1/rxchain=0x1
sb/1/ledbh3=11
sb/1/ledbh5=2
sb/1/ledbh6=10
sb/1/ledbh0=11
sb/1/ledbh1=11
sb/1/maxp2ga0=0x4C
sb/1/ledbh2=11
sb/1/maxp2ga1=0x4C
sb/1/antswctl2g=0x0
sdram_refresh=0x0000
vlan1ports=0 2 3 4 5*
boardflags2=0x1000
sb/1/txchain=0x1
xtalfreq=20000
sb/1/extpagain2g=0x2
vlan2hwname=et0
sb/1/rssismf2g=0xf
sb/1/ag0=0x2
sb/1/ag1=0x2
sb/1/ag2=0x2
sb/1/ag3=0xff
sb/1/itt2ga1=0x20
sb/1/tempthresh=120
sb/1/itt2ga0=0x20
et0mdcport=0
watchdog=0

comment:14 Changed 3 years ago by hauke

You should better use the mips74k image, but generic will also work but a little bit slower.

comment:15 Changed 3 years ago by anonymous

Hi,

2 weaks ago, I also flashed openwrt-brcm47xx-generic-squashfs.trx.

I have no ping or something else over lan. On serial console I get the following output:

Decompressing...done


CFE version 5.100.138.9 based on BBP 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: Wed Dec 21 13:25:44 CST 2011 (zhaoyanming@wireless)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.
Boot partition size = 131072(0x20000)
Found an ST compatible serial flash with 64 64KB blocks; total size 4MB
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.100.138.9
CPU type 0x19749: 300MHz
Tot mem: 32768 KBytes

CFE mem:    0x80700000 - 0x807990C0 (626880)
Data:       0x8072EF10 - 0x80732130 (12832)
BSS:        0x80732130 - 0x807330C0 (3984)
Heap:       0x807330C0 - 0x807970C0 (409600)
Stack:      0x807970C0 - 0x807990C0 (8192)
Text:       0x80700000 - 0x8072EF04 (192260)

Device eth0:  hwaddr D8-42-AC-8B-9B-52, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
Loading: Failed.
Could not load :: Timeout occured
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .. 3712 bytes read
Entry at 0x80001000
Closing network.
Starting program at 0x80001000

It's nearly exat the same as in the first comment. Only the 4th last line is different: he reads only 7312 bytes and not 3780 bytes.

But after this shown block, the output is stopping. What can I do to get a working lan port/image?
I use minicom in terminal and only modify the configuration from serial port to

/dev/ttyS0

and

Hardware Flow Control : No

Have I done anything wrong, do I need some other configuration? What shall I do to rescue?

Thanks for any help!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.