Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13419 closed defect (duplicate)

OpenWRT does not recognize partitions over a position on big disks

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

Hello,

I'm using my router as a NAS by pluging an 1.5TB USB disk to its USB port. However, dmesg warns that its partition is over the EOD. See the log:

[  173.870000] sd 1:0:0:0: [sdb] No Caching mode page present
[  173.870000] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[  180.330000]  sdb: sdb1 sdb2 < sdb5 >
[  180.340000] sdb: partition table partially beyond EOD, enabling native capacity
[  180.350000] sd 1:0:0:0: [sdb] No Caching mode page present
[  180.360000] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[  180.370000]  sdb: sdb1 sdb2 < sdb5 >
[  180.370000] sdb: partition table partially beyond EOD, truncated
[  180.380000] sd 1:0:0:0: [sdb] No Caching mode page present
[  180.390000] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[  180.400000] sd 1:0:0:0: [sdb] Attached SCSI disk

And /proc/partitions shows:

   8       16 1464452096 sdb
   8       17   62926573 sdb1
   8       18          1 sdb2
   8       21 1073744406 sdb5

On an ubuntu 12.10, I got it correcly:

   8       80 1464452096 sdf
   8       81   62926573 sdf1
   8       82          1 sdf2
   8       85 1073744406 sdf5
   8       86    4192933 sdf6

With no dmesg warnings. I also tested with more partitions but nothing after the big sda5 is shown.

I tracked the msg to block/partition-generic.c:452 but now I need to check where the state->access_beyond_eod comes from.

Maybe this is a 32-bit problem?

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #13420

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.