Modify

Opened 5 years ago

Last modified 4 years ago

#13390 new defect

rtl8366s switch initialization problem on dir-825

Reported by: ecc@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

I recently upgraded from trunk r24030 to Attitude Adjustment 12.09 and found that my switch configuration no longer worked correctly.

Here is the configuration. Port 3 carries trusted local traffice on VLAN 1 (interface eth0.1), and untrusted traffic from WiFi APs on VLAN 10 (interface eth0.10).

config interface lan
	option proto static
	option ifname eth0.1
	option ipaddr w.x.y.z
	option netmask 255.255.255.0

config interface wlan
	option proto static
	option ifname eth0.10
	option ipaddr a.b.c.d
	option netmask 255.255.255.0

config interface wan
	option proto dhcp
	option ifname eth1

config switch
	option name rtl8366s
	option reset 1
	option enable_vlan 1

config switch_vlan
	option device rtl8366s
	option vlan 1
	option ports '0 1 2 3t 5t'

config switch_vlan
	option device rtl8366s
	option vlan 10
	option ports '3t 5t'

I've verified with wireshark that all the packets arriving on port 3 are appropriately VLAN-tagged with id 1 or 10. But on power-up, only interface eth0.1 (and eth1) receive any traffic. Interface eth0.10 receives no packets until I change the pvid of port 3 to anything other than 1. Then it works fine, and continues to work even if I reset port 3's pvid to 1 (which is what it is initialized to on power-up).

So I suspect a bug in the rtl8366s initialization, but maybe I'm missing something and it was working previously due to dumb luck.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by ecc@…

Oops, component should be "kernel".

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.