Modify

Opened 5 years ago

Closed 5 years ago

#13377 closed enhancement (not_a_bug)

Increase ramips_ESW Gigabit driver

Reported by: fclql@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

The RTL8211CL chips to develop the port 5

#define RTL8211_PHY_ADDR 0x1F
#define CONFIG_P5_MAC_TO_PHY_MODE 1
printk("Setting up RTL8211CL PHY...");
	*(unsigned long *)(0xb0000060) &= ~(1 << 9); //set RGMII to Normal mode
        *(unsigned long *)(0xb01100C8) &= ~(1<<29); //disable port 5 auto-polling
        *(unsigned long *)(0xb01100C8) |= 0x3fff; //force 1000M full duplex
        *(unsigned long *)(0xb01100C8) &= ~(0xf<<20); //rxclk_skew, txclk_skew = 0

              rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x0, 0xA9A0); /*Reset PHY*/
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x0, 0x03E1); /*SoftReset PHY*/
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x0, 0x3100); /*Auto negotiation*/
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x4, 0x03E1);
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x12, 0x6400);
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x1F, 0x0);

printk("done.\n");

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by blogic

  • Resolution set to not_a_bug
  • Status changed from new to closed

not a bug ... dont report this a 3rd time please

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.