Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13352 closed defect (duplicate)

AR8327 switch driver does not support tagged and untagged on same port

Reported by: chrisrenzhen@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: VLAN Hybrid support Cc:

Description

the problem involves all the devices using ar8327(wdr4300 wdr4310 etc.),a lot of people in forum are facing this problem

as far as i know the router wzr-hp-g300nh(not v2), wdr1043nd which use rtl8366rb can achieve the feature of tagged and untagged on same port.

we belive ar8327 is a advanced switch and should support this feature.that's why i believe it as a driver problem

for my own experience.my isp need untagged traffic for internet and vlan43 tagged traffic for IPTV.
the fact is that current ar8327 switch driver does not allow tagged and untagged frame on the same port.
for example config in /network
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'

option ifname 'eth0.2'
option proto 'pppoe'
xxxxxxxxxxxx

config switch_vlan

option device 'eth0'
option vlan '1'
option ports '0t 2 3 5'

config switch

option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'eth0'
option vlan '2'
option ports '0t 1'

config switch_vlan

option device 'eth0'
option vlan '43'
option ports '1t 4'

# swconfig dev eth0 show

Global attributes:

enable_vlan: 1

Port 0:

pvid: 0
link: port:0 link:up speed:1000baseT full-duplex txflow rxflow

Port 1:

pvid: 2
link: port:2 link:down

Port 2:

pvid: 1
link: port:2 link:down

Port 3:

pvid: 1
link: port:3 link:down

Port 4:

pvid: 43
link: port:5 link:up speed:100baseT full-duplex auto

Port 5:

pvid: 1
link: port:3 link:down

Port 6:

mib: Port 6 MIB counters
pvid: 0
link: port:6 link:down

VLAN 1:

vid: 1
ports: 0t 1 2 5

VLAN 2:

vid: 2
ports: 0t 1t

VLAN 43:

vid: 43
ports: 1t 4

to make it in short,that is, port 1 is not allowed to be used as untagged and tagged.if you insist config like that,the untagged port is forced to be tagged,which makes the eth0.2 is also tagged and no traffic for internet,only trafic for iptv (with real test)

"my iptv service only need bridge in router,the iptv box will lauch pppoe client and get ip from isp.so i leave the bridge within switch and it works"

also tested with vid1 for wan port by assigning port1 to vlan1 and makes eth0.1 as wan,assgning 2 3 5 for vlan2, makes eth0.2 as lan.
the same result,no internet only iptv from port 4

i think it need special rewrite of switch driver

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 5 years ago by chrisrenzhen@…

both ar8327 and ar8327n are involved

those are from datasheet of ar8327

The AR8327 switch supports many VLAN options including IEEE 802.1Q and port-based VLANs. The
AR8327 supports 4096 IEEE 802.1Q VLAN groups and 4K VLAN table entries, and the AR8327 device
checks VLAN port membership from the VLAN ID, extracted from the tag header of the frame. Table
2-18 shows the AR8327-supported 802.1Q modes. The port-based VLAN is enabled according to the
user-defined PORT VID value. The AR8327 supports optional discards of tagged, untagged frames,
and priority tagged frames. The AR8327 also supports untagging of the VLAN ID for packets going
out on untagged ports on a per-port basis.

that's why i think driver can implement this feature

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.