Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13329 closed defect (duplicate)

snapshot fails to boot on rt-n10+, NULL dereference in ralink_mux_mask

Reported by: openwrt@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

Full boot log:

U-Boot 1.1.3 (Jul 26 2010 - 14:43:11)
                                     
Board: Ralink APSoC DRAM:  32 MB
relocate_code Pointer at: 81b7c000
                                  
 Set info->start[0]=BF000000
flash_protect ON: from 0xBF000000 to 0xBF022FBB
protect on 0                                   
protect on 1
protect on 2
flash_protect ON: from 0xBF030000 to 0xBF03FFFF
protect on 3                                   
*** Warning - bad CRC, using default environment
                                                
============================================ 
Ralink UBoot Version: 3.2                    
-------------------------------------------- 
ASIC 3052_MP2 (Port5<->Phy)                  
DRAM COMPONENT: 256Mbits   
DRAM BUS: 16BIT          
Total memory: 32 MBytes
Date:Jul 26 2010  Time:14:43:11
============================================ 
icache: sets:128, ways:4, linesz:32 ,total:16384
dcache: sets:128, ways:4, linesz:32 ,total:16384 
                                                 
 ##### The CPU freq = 320 MHZ #### 
                                   
SDRAM bus set to 16 bit 
 SDRAM size =32 Mbytes  
                      
Please choose the operation: 
   1: Load system code to SDRAM via TFTP. 
   2: Load system code then write to Flash via TFTP. 
   3: Boot system code via Flash (default).          
   4: Entr boot command line interface.    
   9: Load Boot Loader code then write to Flash via TFTP.                                               0 
                                                                                                         
3: System Boot system code via Flash.
                                     
 eth_register  
Eth0 (10/100-M)
 enetvar=ethaddr,Eth addr:00:0C:43:09:26:BB
                                           
 eth_current->name = Eth0 (10/100-M)
                                    
verify is 1
## load addr bf050000 ...
print img header         
   Magic:	[00000000]
   CRC:		[00000000]
   Image Name:            
   Created:      1970-01-01   0:00:00 UTC
                                         
 System Control Status = 0x00400000 
   Image Type:   Invalid CPU Invalid OS Invalid Image (uncompressed)
   Data Size:    0 Bytes =  0 kB                                    
   Load Address: 00000000       
   Entry Point:  00000000
Bad Magic Number , 00000000 
## Booting image at bf050000 ...
sizeof image_header_t is 64     
print img header           
   Magic:	[27051956]
   CRC:		[d13059c1]
   Image Name:   MIPS OpenWrt Linux-3.8.6
   Created:      2013-04-08   9:48:06 UTC
                                         
 System Control Status = 0x00400000 
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    988050 Bytes = 964.9 kB                  
   Load Address: 80000000               
   Entry Point:  80000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd                           
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 32                         
                                 
Starting kernel ...
                   
[    0.000000] Linux version 3.8.6 (fnord@tschunk) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2012.12 r36267) ) #1 Mon Apr 8 09:46:42 UTC 2013
[    0.000000] SoC Type: Ralink RT3350 id:1 rev:2
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)
[    0.000000] memory window: 0x0, min: 2MB, max: 64MB
[    0.000000] memory detected: 32MB
[    0.000000] MIPS: machine is Asus RT-N10+
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: mtdparts=1f000000.cfi:192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,3776k@0x50000(firmware) rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Writing ErrCtl register=000037ba
[    0.000000] Readback ErrCtl register=000037ba
[    0.000000] Memory: 29364k/32768k available (2174k kernel code, 3404k reserved, 519k data, 184k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:128
[    0.000000] CPU Clock: 320MHz
[    0.000000] Calibrating delay loop... 212.58 BogoMIPS (lpj=1062912)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.120000] CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 8000c38c, ra == 8000c5cc
[    0.130000] Oops[#1]:
[    0.130000] Cpu 0
[    0.130000] $ 0   : 00000000 00000072 ffffffea 80263505
[    0.130000] $ 4   : 00000001 00000000 00000000 fffffffc
[    0.130000] $ 8   : 00000000 0000002e 8180a000 00000000
[    0.130000] $12   : 0000000e 8026911c 00000001 00000007
[    0.130000] $16   : 00000000 802926ec 8100123c 802926ec
[    0.130000] $20   : 810012c4 802484a0 80248470 802a2210
[    0.130000] $24   : 0000000e 8003e71c                  
[    0.130000] $28   : 81820000 81821e40 80289178 8000c5cc
[    0.130000] Hi    : 00000000
[    0.130000] Lo    : 07270e00
[    0.130000] epc   : 8000c38c ralink_mux_mask+0x0/0x54
[    0.130000]     Not tainted
[    0.130000] ra    : 8000c5cc ralink_pinmux+0x1ec/0x240
[    0.130000] Status: 11008403    KERNEL EXL IE 
[    0.130000] Cause : 80800008
[    0.130000] BadVA : 00000000
[    0.130000] PrId  : 0001964c (MIPS 24KEc)
[    0.130000] Modules linked in:
[    0.130000] Process swapper (pid: 1, threadinfo=81820000, task=8181c000, tls=00000000)
[    0.130000] Stack : 8024887c 0000001c 80266e5c 0000001f 00000001 810002f4 802c366c 802a44c8
        802d0000 00000000 802d0000 802d0000 0000001f 802a457c 802d0000 802d0000
        802c3668 810426e6 810426db 8000bbd0 00000000 802b18a0 80248398 0000000c
        00000003 00000003 802c366c 802ca85c 802c3648 802c366c 802ca860 802c3648
        00000003 802d0000 802d0000 802a2a48 8c8c9898 4ece440d 498018d9 0000001f
        ...
[    0.130000] Call Trace:
[    0.130000] [<8000c38c>] ralink_mux_mask+0x0/0x54
[    0.130000] [<8000c5cc>] ralink_pinmux+0x1ec/0x240
[    0.130000] [<802a457c>] plat_of_setup+0xb4/0xcc
[    0.130000] [<8000bbd0>] do_one_initcall+0xf0/0x1b8
[    0.130000] [<802a2a48>] kernel_init_freeable+0x13c/0x220
[    0.130000] [<80008b04>] kernel_init+0x10/0x10c
[    0.130000] [<80004870>] ret_from_kernel_thread+0x10/0x18
[    0.130000] 
[    0.130000] 
Code: 24040002  0800359d  00000000 <080030f4> 8ca20000  90460000  90610000  24420001  14260004 
[    0.140000] ---[ end trace 5dfc45af2fffac64 ]---
[    0.140000] Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
[    0.140000] 

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Cody P Schafer <openwrt@…>

Looks like I've added a duplicate of Ticket 13322, sorry. How often are the snapshot binaries refreshed?

comment:2 Changed 5 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed
Last edited 5 years ago by juhosg (previous) (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.