Modify

Opened 5 years ago

Closed 5 years ago

#13327 closed defect (duplicate)

USBIP: compilation failed with gcc version 4.8

Reported by: ppvazquezfer@… Owned by: developers
Priority: low Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: usbip gcc Cc:

Description

This is the output:

OpenWrt-libtool: link: mips-openwrt-linux-uclibc-gcc -Wall -Werror -Wextra -std=gnu99 -I/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/usr/include/glib-2.0 -I/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/usr/lib/glib-2.0/include -Wno-implicit-function-declaration -o .libs/usbipd usbipd.o usbip_network.o  -L/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/usr/lib -L/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/lib -L/home/pepe/trunk/staging_dir/toolchain-mips_gcc-4.8.0_uClibc-0.9.33.2/usr/lib -L/home/pepe/trunk/staging_dir/toolchain-mips_gcc-4.8.0_uClibc-0.9.33.2/lib -L/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/usr/lib/libiconv-stub/lib -L/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/usr/lib/libintl-stub/lib ../libsrc/.libs/libusbip.so -lglib-2.0 -lwrap -lsysfs
make[6]: Leaving directory `/home/pepe/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx/usbip-1.1.1/src'
make[6]: Entering directory `/home/pepe/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx/usbip-1.1.1'
make[6]: *** No rule to make target `doc/usbip_bind_driver.8', needed by `all-am'.  Stop.
make[6]: Leaving directory `/home/pepe/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx/usbip-1.1.1'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/pepe/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx/usbip-1.1.1'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/pepe/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx/usbip-1.1.1'
make[3]: *** [/home/pepe/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-brcm63xx/usbip-1.1.1/.built] Error 2
make[3]: Leaving directory `/home/pepe/trunk/feeds/packages/net/usbip'
make[2]: *** [package/feeds/packages/usbip/compile] Error 2
make[2]: Leaving directory `/home/pepe/trunk'
make[1]: *** [/home/pepe/trunk/staging_dir/target-mips_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/pepe/trunk'
make: *** [world] Error 2

I think this is the most relevant information about the error.
Maybe the usbip package has some errors, but i'm not sure.

Attachments (0)

Change History (3)

comment:1 follow-up: Changed 5 years ago by duvi

The answer is in ticket #12889

comment:2 in reply to: ↑ 1 Changed 5 years ago by ppvazquezfer@…

Replying to duvi:

The answer is in ticket #12889

A lot of thanks. The problem is the package, not GCC. Also with 4.7.2 the same error.

This ticket must be closed with a duplicate reason.

comment:3 Changed 5 years ago by cyrus

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.