Modify

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#13325 closed defect (invalid)

ralink LED is invalid

Reported by: fclql@… Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

The 3.8.3 Kernel period LED is normal, but it's not the latest

Add Ralink RTL8211 the PHY driver module 1000 MB Interface

#define RTL8211_PHY_ADDR 0x1F
#define CONFIG_P5_MAC_TO_PHY_MODE 1
printk("Setting up RTL8211CL PHY...");
	*(unsigned long *)(0xb0000060) &= ~(1 << 9); //set RGMII to Normal mode
        *(unsigned long *)(0xb01100C8) &= ~(1<<29); //disable port 5 auto-polling
        *(unsigned long *)(0xb01100C8) |= 0x3fff; //force 1000M full duplex
        *(unsigned long *)(0xb01100C8) &= ~(0xf<<20); //rxclk_skew, txclk_skew = 0

              rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x0, 0xA9A0); /*Reset PHY*/
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x0, 0x03E1); /*SoftReset PHY*/
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x0, 0x3100); /*Auto negotiation*/
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x4, 0x03E1);
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x12, 0x6400);
		rt305x_mii_write(esw,RTL8211_PHY_ADDR, 0x1F, 0x0);

printk("done.\n");

Attachments (0)

Change History (2)

comment:1 follow-up: Changed 5 years ago by blogic

  • Resolution set to invalid
  • Status changed from new to closed

this is a feature request and not a bug

comment:2 in reply to: ↑ 1 Changed 3 years ago by fclql@…

Replying to blogic:

this is a feature request and not a bug

There are ways to achieve it?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.