Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13314 closed defect (wontfix)

"/usr/sbin/nas is already running" on multiple ssid for broadcom

Reported by: hubert.mis@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Backfire 10.03
Keywords: broadcom wifi nas Cc:

Description

Hello,
I've just built backfire from svn for my new WRT54GL, target system: Broadcom BCM947xx/953xx [2.4]. I have configured three ssids for my network, each bridged to other eth0 vlan:
wl0 bridged to eth0.3
wl0.1 bridged to eth0.4
wl0.2 bridged to eth0.2

wl0 and wl0.1 was working fine but I could not connect to wl0.2. I found an interesting entry in logs: "/usr/sbin/nas is already running". Than I realized that nas daemon was running for wl0 and wl0.1 but not for wl0.2.

Script /lib/wifi/broadcom.sh, that starts nas daemon, uses "start-stop-daemon" and this program prevented one of daemons to start. I modified the script (added -p pidfile argument to "start-stop-daemon") what resolved the issue.

I hope it could help anyone with similar problem. I think you could also modify the script in svn :)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by hauke

  • Resolution set to wontfix
  • Status changed from new to closed

Backfire 10.03 with the BCM947xx/953xx [2.4] target is not supported any more. Please try something more recent.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.