Modify

Opened 5 years ago

Closed 5 years ago

#13308 closed defect (fixed)

r36225 does not build on ar71xx (of_i2c.ko is missing)

Reported by: risa2000 Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Building image-builder for ar71xx (TL-WR1043ND) gives error when building package "kernel"

mkdir -p /home/risa/openwrt/openwrt/bin/ar71xx/packages /home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/packages/ipkg-ar71xx/kmod-i2c-core/CONTROL /home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/pkginfo
NOTICE: module '/home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.8.6/drivers/i2c/i2c-core.ko' is built-in.
ERROR: module '/home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.8.6/drivers/of/of_i2c.ko' is missing.
make[3]: *** [/home/risa/openwrt/openwrt/bin/ar71xx/packages/kmod-i2c-core_3.8.6-1_ar71xx.ipk] Error 1
make[3]: Leaving directory `/home/risa/openwrt/openwrt/package/kernel'
make[2]: *** [package/kernel/compile] Error 2
make[2]: Leaving directory `/home/risa/openwrt/openwrt'
make[1]: *** [/home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/risa/openwrt/openwrt'
make: *** [world] Error 2

It seems that r36179 could be the cause of the problem. Removing of_i2c from I2C_CORE_MODULES fixes the build.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by juhosg

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker (trunk)
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r36227.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.