Modify

Opened 5 years ago

Last modified 5 years ago

#13276 reopened defect

sta and adhoc mode can't set the channel

Reported by: baolin.mail@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: can't set the channel Cc:

Description

The current version:Trunk 36144 ,sta and adhoc mode can't set the channel
root@OpenWrt:/etc/config# iw dev wlan0 set channel 1
command failed: Device or resource busy (-16)

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

The channel is controlled by wpa-supplicant on the sta vif.

Last edited 5 years ago by jow (previous) (diff)

comment:2 Changed 5 years ago by anonymous

Registered: 2010-06-11
Posts: 15

I have added the wpa_supplicant in my system

root@OpenWrt:/etc/config# cat wireless
config wifi-device radio0

option type mac80211
option channel 11
option hwmode 11ng
option path 'pci0000:00/0000:00:12.0'
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface

option device radio0
option network lan
option mode sta
option ssid OpenWrt
option encryption none
option wds 1

root@OpenWrt:/etc/config# wifi
command failed: Device or resource busy (-16)
root@OpenWrt:/etc/config# wpa_supplicant -v
wpa_supplicant v2.1-devel
Copyright (c) 2003-2013, Jouni Malinen <j@…> and contributors
root@OpenWrt:/etc/config#

comment:3 Changed 5 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:4 Changed 5 years ago by nbd

  • Resolution set to too_vague
  • Status changed from reopened to closed

No idea what you're trying to say here, pasting your config and a few lines without a proper problem description is useless.

comment:5 Changed 5 years ago by anonymous

I was trying to describe, when I was using the STA mode, can't set the channel, I try to use "iw dev wlan0 set the channel 1" and UCI configuration(/lib/wifi/mac80211 398 line with the same command: [ -n "$fixed" -a -n "$channel" ] && iw dev "$ifname" set channel "$channel") will have a same mistake command failed: Device or resource busy (16),Above is my use environment, if can you can try

comment:6 Changed 5 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by anonymous

In adhoc mode below have the same results

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.