Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13254 closed enhancement (obsolete)

upgrade ahcp scripts to netifd/procd

Reported by: kerneis@… Owned by: kerneis
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: ahcp Cc: jch@…, boutier@…, ch.dequeker@…

Description

17:54 < kerneis> nbd: no, actually, it was useful: https://dev.openwrt.org/browser/packages/ipv6/ahcpd/files/ahcpd.init#L71 — I'll revert your removal and add a comment to explain what happens
17:55 < nbd> kerneis: it won't even work anymore
17:55 < nbd> (not compatible with netifd)
17:56 < nbd> also, it doesn't make any sense to have a fake proto that is processed by an init script
17:56 < nbd> better to either explicitly list interfaces in the ahcp config (and setting them to proto none or something else that works in the network config)
17:56 < nbd> or add an option enable_ahcp 1
17:57 < nbd> bbl
17:57 < kerneis> the problem is, ahcp is really a daemon
17:57 < kerneis> you need to have a single one running for all your interfaces
17:57 < nbd> right, so list the interfaces in the ahcp config, port the init script to procd
17:58 < nbd> and make it call the init script with reload on an ifup event
17:58 < kerneis> ok
17:58 < nbd> procd will detect if the generated command line changed
17:58 < nbd> and restart it if necessary
17:59 < kerneis> procd is an alternative to start-stop-daemon?
17:59 < nbd> you can use the dropbear init script as reference
17:59 < nbd> yes
17:59 < nbd> we're going to replace the use of start-stop-daemon with procd
17:59 < kerneis> i'll copy/paste this log to a bug report and do this some time next week, thanks
18:00 < nbd> because it handles multi-instance stuff better and it can be used to gracefully handle such config reload issues

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by kerneis

  • Owner changed from developers to kerneis
  • Status changed from new to accepted

comment:2 Changed 5 years ago by blogic

  • Resolution set to wontfix
  • Status changed from accepted to closed

this is just silly

comment:3 Changed 5 years ago by kerneis

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Would you care to elaborate?

Ahcpd needs to be restarted when the interfaces it is managing go up/down, and more generally the way ahcpd-managed interfaces are defined needs to be given more thought (since the current script which parses "proto=ahcp" seems to be broken, or deprecated).

Maybe the proposed solution (using netifd/procd) is not appropriate. If you think alternative solutions, for instance a hotplug script, would be better suited, it would be nice to at least mention them. But in any case, I find a bit rude the way you have closed this ticket (which has been opened and accepted by the maintainer of the package).

By the way, if procd's aim is to become the next daemon manager for openwrt, it most certainly needs testing; again, I fail to understand how updating more packages to use it qualifies as "silly".

comment:4 Changed 5 years ago by kerneis

  • Resolution set to obsolete
  • Status changed from reopened to closed

Ahcp packaging will be moved to the "routing" repository on github. Closing to clean up openwrt.org database (but the bug itself is not solved).

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.