Modify

Opened 5 years ago

Closed 3 years ago

#13252 closed defect (fixed)

uboot-envtools compile problem with gcc-4.8.0

Reported by: eric@… Owned by: florian
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

After upgrading from gcc-4.7.0 to gcc-4.8.0 (also upgrading mpfr, gmp, and mpc), I get this error:

Package uboot-envtools is missing dependencies for the following libraries:
libc.so.6

Naurally, my build system has libc.so.6 (though as far as I can tell, the OpenWRT image gets libc.so.0 instead, from uclibc)

Reverting to earlier versions allows the compile to finish without error, as does compiling using gcc-2.6.3 on an Ubuntu system.

I've been unable to easily untangle the workings of the dependency system - I see no mention of libc.so.6 under package/boot/uboot-envtools. If someone can tell me how to a) find the dependency list for uboot-envtools and b) manually invoke the dependency check, I'm happy to poke at it some more.

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by anonymous

Upon further testing, reverting to gcc-4.7.0 does not help - not sure why it worked once.

I'd still appreciate help debugging the dependencies; I'm making progress understanding it, but don;t have a lot of time to devote to it.

comment:2 Changed 5 years ago by anonymous

Solved - the problem was make-3.82, presumably combined with an update of the uboot-envtools code. Downgrading to make-3.81 fixed the problem.

comment:3 Changed 5 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 Changed 5 years ago by oxc

Why was this closed? Shouldn't openwrt/uboot build with make-3.82?

comment:5 Changed 5 years ago by openwrt@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Unfortunately this still fails when using make-3.82.

Is there a reason why this should not be fixed?

comment:6 Changed 5 years ago by florian

  • Owner changed from developers to florian
  • Status changed from reopened to assigned

This should certainly be fixed, but having an upstream solution to backport would be even better.

comment:7 Changed 5 years ago by anonymous

I see, thanks.

I would happily file an upstream bug, but the U-Boot web page does not seem to allow (or encourage) bug submissions without a patch. Unfortunately, I'm not able to create such a patch.

comment:8 Changed 3 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

This has been fixed by an u-boot update.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.