Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13230 closed defect (no_response)

After some time (from hours to weeks) wifi-connected devices rx speed drops to <1 Mbps.

Reported by: Mateusz Kramarczyk <kramarczyk@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: WiFi TL-WR1043ND TP-LINK AA Cc:

Description

Hi,
I have wireless AP running od TP-LINK TL-WR1043NV v1.8 and I'm experiencing weird issue. After some time wifi speed of devices connected to the AP drops do 1Mbps and the real speed even less than that (I tested both G and N devices). The time of running without slowing down seems to be random (sometimes it is hours sometimes it is weeks). The workaround is to restart WiFi on the router. Nothing suspicious in the logs. I can provide any logs you request. OpenWrt is AA RC1.

BusyBox v1.19.4 (2012-11-18 02:19:39 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (12.09-rc1, r34185)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# dmesg 
[    0.000000] Linux version 3.3.8 (blogic@Debian-60-squeeze-64-minimal) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Sun Nov 18 04:31:55 UTC 2012
[    0.000000] MyLoader: sysp=aaaaaaa2, boardp=a2aaaaa2, parts=aaaaaaaa
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9132 rev 2
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00002000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00002000
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 802ef060, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8128 pages, LIFO batch:0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=TL-WR1043ND console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 29008k/32768k available (2209k kernel code, 3760k reserved, 412k data, 212k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.090000] gpiochip_add: registered GPIOs 0 to 21 on device: ath79
[    0.100000] MIPS: machine is TP-LINK TL-WR1043ND
[    0.360000] bio: create slab <bio-0> at 0
[    0.370000] Switching to clocksource MIPS
[    0.380000] NET: Registered protocol family 2
[    0.380000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.380000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.390000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.390000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.400000] TCP reno registered
[    0.400000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.410000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.420000] NET: Registered protocol family 1
[    0.420000] PCI: CLS 0 bytes, default 32
[    0.440000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.440000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.450000] msgmni has been set to 56
[    0.460000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
[    0.470000] io scheduler noop registered
[    0.470000] io scheduler deadline registered (default)
[    0.470000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.510000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.510000] console [ttyS0] enabled, bootconsole disabled
[    0.530000] m25p80 spi0.0: found s25sl064a, expected m25p80
[    0.530000] m25p80 spi0.0: s25sl064a (8192 Kbytes)
[    0.540000] 5 tp-link partitions found on MTD device spi0.0
[    0.540000] Creating 5 MTD partitions on "spi0.0":
[    0.550000] 0x000000000000-0x000000020000 : "u-boot"
[    0.560000] 0x000000020000-0x00000010b800 : "kernel"
[    0.560000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.580000] 0x00000010b800-0x0000007f0000 : "rootfs"
[    0.580000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.590000] mtd: partition "rootfs" set to be root filesystem
[    0.600000] mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=510000 
[    0.610000] 0x0000002e0000-0x0000007f0000 : "rootfs_data"
[    0.620000] 0x0000007f0000-0x000000800000 : "art"
[    0.620000] 0x000000020000-0x0000007f0000 : "firmware"
[    0.630000] Realtek RTL8366RB ethernet switch driver version 0.2.3
[    0.750000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[    0.750000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[    0.930000] rtl8366rb: probed
[    0.940000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[    1.240000] TCP cubic registered
[    1.250000] NET: Registered protocol family 17
[    1.250000] Bridge firewalling registered
[    1.260000] 8021q: 802.1Q VLAN Support v1.8
[    1.260000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    1.270000] Freeing unused kernel memory: 212k freed
[    3.060000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[    3.060000] eth0: link up (1000Mbps/Full duplex)
[    3.090000] Registered led device: tp-link:green:usb
[    3.090000] Registered led device: tp-link:green:system
[    3.090000] Registered led device: tp-link:green:qss
[    3.090000] Registered led device: tp-link:green:wlan
[    6.400000] JFFS2 notice: (438) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 12 of xref (0 dead, 2 orphan) found.
[    7.030000] SCSI subsystem initialized
[    7.200000] usbcore: registered new interface driver usbfs
[    7.210000] usbcore: registered new interface driver hub
[    7.220000] usbcore: registered new device driver usb
[    7.760000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    7.760000] ehci-platform ehci-platform: Generic Platform EHCI Controller
[    7.770000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    7.810000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    7.830000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    7.830000] hub 1-0:1.0: USB hub found
[    7.840000] hub 1-0:1.0: 1 port detected
[    7.850000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    7.910000] Initializing USB Mass Storage driver...
[    7.920000] usbcore: registered new interface driver usb-storage
[    7.920000] USB Mass Storage support registered.
[    8.160000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[    8.310000] scsi0 : usb-storage 1-1:1.0
[    9.310000] scsi 0:0:0:0: Direct-Access     Mass     Storage Device        PQ: 0 ANSI: 0 CCS
[    9.330000] sd 0:0:0:0: [sda] 7744511 512-byte logical blocks: (3.96 GB/3.69 GiB)
[    9.330000] sd 0:0:0:0: [sda] Write Protect is off
[    9.340000] sd 0:0:0:0: [sda] Mode Sense: 03 00 00 00
[    9.340000] sd 0:0:0:0: [sda] No Caching mode page present
[    9.350000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[    9.350000] sd 0:0:0:0: [sda] No Caching mode page present
[    9.360000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[    9.370000]  sda: sda1 sda2 sda3 sda4
[    9.380000] sd 0:0:0:0: [sda] No Caching mode page present
[    9.390000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[    9.400000] sd 0:0:0:0: [sda] Attached SCSI removable disk
[   28.470000] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   28.820000] eth0: link down
[   29.530000] Compat-drivers backport release: compat-drivers-2012-09-04-2-gddac993
[   29.540000] Backport based on wireless-testing.git master-2012-09-07
[   29.540000] compat.git: wireless-testing.git
[   29.590000] cfg80211: Calling CRDA to update world regulatory domain
[   29.600000] cfg80211: World regulatory domain updated:
[   29.600000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   29.610000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   29.620000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   29.630000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   29.640000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   29.640000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   30.020000] ath: EEPROM regdomain: 0x0
[   30.020000] ath: EEPROM indicates default country code should be used
[   30.020000] ath: doing EEPROM country->regdmn map search
[   30.020000] ath: country maps to regdmn code: 0x3a
[   30.020000] ath: Country alpha2 being used: US
[   30.020000] ath: Regpair used: 0x3a
[   30.030000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   30.030000] ieee80211 phy0: Atheros AR9100 MAC/BB Rev:7 AR2133 RF Rev:a2 mem=0xb80c0000, irq=2
[   30.040000] cfg80211: Calling CRDA for country: US
[   30.050000] cfg80211: Regulatory domain changed to country: US
[   30.050000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   30.060000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[   30.070000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[   30.080000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   30.080000] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   30.090000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   30.100000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[   30.250000] isofs: Unknown symbol zlib_inflateInit2 (err 0)
[   30.250000] isofs: Unknown symbol zlib_inflate (err 0)
[   30.260000] isofs: Unknown symbol zlib_inflate_workspacesize (err 0)
[   30.260000] isofs: Unknown symbol zlib_inflateEnd (err 0)
[   30.350000] PPP generic driver version 2.4.2
[   30.440000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   30.590000] NET: Registered protocol family 24
[   30.660000] nf_conntrack version 0.5.0 (456 buckets, 1824 max)
[   31.030000] usbcore: registered new interface driver usbserial
[   31.030000] USB Serial support registered for generic
[   31.040000] usbcore: registered new interface driver usbserial_generic
[   31.050000] usbserial: USB Serial Driver core
[   31.110000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[   33.380000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[   33.690000] eth0: link up (1000Mbps/Full duplex)
[   33.690000] device eth0.1 entered promiscuous mode
[   33.700000] device eth0 entered promiscuous mode
[   33.710000] br-lan: port 1(eth0.1) entered forwarding state
[   33.710000] br-lan: port 1(eth0.1) entered forwarding state
[   35.060000] cfg80211: Calling CRDA for country: PL
[   35.060000] cfg80211: Regulatory domain changed to country: PL
[   35.070000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   35.080000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   35.080000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   35.090000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   35.100000] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[   35.710000] br-lan: port 1(eth0.1) entered forwarding state
[   37.360000] device wlan0 entered promiscuous mode
[   39.550000] br-lan: port 2(wlan0) entered forwarding state
[   39.550000] br-lan: port 2(wlan0) entered forwarding state
[   41.550000] br-lan: port 2(wlan0) entered forwarding state
[   49.490000] Adding 884160k swap on /dev/sda4.  Priority:-1 extents:1 across:884160k 
[143473.010000] device wlan0 left promiscuous mode
[143473.010000] br-lan: port 2(wlan0) entered disabled state
[143488.020000] device wlan0 entered promiscuous mode
[143490.430000] br-lan: port 2(wlan0) entered forwarding state
[143490.440000] br-lan: port 2(wlan0) entered forwarding state
[143492.440000] br-lan: port 2(wlan0) entered forwarding state

root@OpenWrt:~# logread 
Mar 23 15:43:47 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:43:47 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:43:51 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:43:51 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:43:55 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:43:55 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:43:59 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:43:59 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:03 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:03 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:07 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:07 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:11 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:11 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:15 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:15 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:19 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:19 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:23 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:23 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:27 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:27 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:30 OpenWrt daemon.info hostapd: wlan0: STA 00:1b:77:bc:6f:e3 WPA: group key handshake completed (RSN)
Mar 23 15:44:31 OpenWrt daemon.info hostapd: wlan0: STA 00:21:00:64:09:5e WPA: group key handshake completed (RSN)
Mar 23 15:44:31 OpenWrt daemon.info hostapd: wlan0: STA f8:7b:7a:91:76:90 WPA: group key handshake completed (RSN)
Mar 23 15:44:31 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:31 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:35 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:35 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:39 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:39 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:43 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:43 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:47 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:47 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:51 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:51 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:44:55 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:44:56 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:00 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:00 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:04 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:04 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:08 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:08 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:12 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:12 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:16 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:16 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:19 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:19 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:23 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:23 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:26 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:26 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:30 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:30 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:34 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:34 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:38 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:38 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:42 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:42 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:46 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:46 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:50 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:50 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:54 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:54 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:45:58 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:45:58 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:01 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:01 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:05 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:05 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:09 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:10 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:14 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:14 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:18 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:18 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:22 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:22 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:26 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:26 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:30 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:30 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:34 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:34 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:38 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:38 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:42 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:42 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:45 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:45 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:49 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:49 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:53 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:53 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:46:57 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:46:57 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:00 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:00 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:04 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:04 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:08 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:08 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:12 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:12 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:16 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:16 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:20 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:20 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:24 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:24 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:29 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:29 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:32 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:32 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:36 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:36 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:40 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:40 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:44 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:44 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:48 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:48 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:52 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:52 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:47:56 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:47:56 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:00 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:00 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:04 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:04 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:08 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:08 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:12 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:12 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:16 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:16 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:20 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:20 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:24 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:24 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:24 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:28 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: authenticated
Mar 23 15:48:28 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 IEEE 802.11: associated (aid 1)
Mar 23 15:48:28 OpenWrt daemon.info hostapd: wlan0: STA e4:b0:21:3c:36:70 WPA: pairwise key handshake completed (RSN)
Mar 23 15:48:29 OpenWrt daemon.info dnsmasq-dhcp[2407]: DHCPDISCOVER(br-lan) e4:b0:21:3c:36:70 
Mar 23 15:48:29 OpenWrt daemon.info dnsmasq-dhcp[2407]: DHCPOFFER(br-lan) 192.168.47.42 e4:b0:21:3c:36:70 
Mar 23 15:48:29 OpenWrt daemon.info dnsmasq-dhcp[2407]: DHCPREQUEST(br-lan) 192.168.47.42 e4:b0:21:3c:36:70 
Mar 23 15:48:29 OpenWrt daemon.info dnsmasq-dhcp[2407]: DHCPACK(br-lan) 192.168.47.42 e4:b0:21:3c:36:70 iga-phone-wifi
Mar 23 15:49:09 OpenWrt authpriv.info dropbear[14477]: Exit (root): Exited normally
Mar 23 15:49:26 OpenWrt authpriv.info dropbear[28719]: Child connection from 192.168.47.20:4587
Mar 23 15:49:36 OpenWrt authpriv.notice dropbear[28719]: Password auth succeeded for 'root' from 192.168.47.20:4587

root@OpenWrt:~# cat /etc/config/wireless 
config wifi-device 'radio0'
option type 'mac80211'
option macaddr 'f8:d1:11:39:33:78'
option hwmode '11ng'
list ht_capab 'SHORT-GI-40'
list ht_capab 'DSSS_CCK-40'
option channel '9'
option txpower '20'
option htmode 'HT40-'
option country 'PL'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk2+ccmp'
option key 'xxxxxxxxxxxx'
option ssid 'xxxxxxxxxxxx'

root@OpenWrt:~# cat /etc/config/network 
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.47.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config switch
option name 'rtl8366rb'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'rtl8366rb'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan
option device 'rtl8366rb'
option vlan '2'
option ports '0 5t'

config interface 'wan2'
option proto '3g'
option auto '0'
option device '/dev/ttyUSB0'
option service 'umts'
option apn 'xxxxxxxxxxxx'
option pincode 'xxxxxxxxxxx'
option defaultroute '0'

root@OpenWrt:~# cat /etc/config/system 

config system
option hostname 'OpenWrt'
option zonename 'Europe/Warsaw'
option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'
option conloglevel '8'
option cronloglevel '8'

config timeserver 'ntp'
list server 'ntp.task.gda.pl'
list server '0.openwrt.pool.ntp.org'
list server '1.openwrt.pool.ntp.org'
list server '2.openwrt.pool.ntp.org'
list server '3.openwrt.pool.ntp.org'

config led 'led_usb'
option name 'USB'
option sysfs 'tp-link:green:usb'
option trigger 'usbdev'
option dev '1-1'
option interval '50'

config led 'led_wlan'
option name 'WLAN'
option sysfs 'tp-link:green:wlan'
option trigger 'phy0tpt'

root@OpenWrt:~# exit

Attachments (1)

bad.txt (316.6 KB) - added by Mateusz Kramarczyk <kramarczyk@…> 5 years ago.
Logs after issue is reproduced.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by anonymous

Here's the link to the discussion on forum: https://forum.openwrt.org/viewtopic.php?id=42539

Changed 5 years ago by Mateusz Kramarczyk <kramarczyk@…>

Logs after issue is reproduced.

comment:2 Changed 5 years ago by valent.turkovic@…

Did anybody fix wifi dropout [1] issue with their wr1043nd when running ddwrt or openwrt? I'm still having issue and really pissed off...

I posted to this bug report [2] also on ddwrt tracker but still no news from any of the developers.

It looks like same bug [3] is also present in openwrt firware, I can confirm that I had same issues with openwrt.

Is there any workaround?

[1] http://www.dd-wrt.com/phpBB2/viewtopic.php?p=747935
[2] http://www.dd-wrt.com/dd-wrtv2/bugtracker/view.php?id=4388
[3] /ticket/9654.html

comment:3 Changed 5 years ago by nbd

please try latest trunk or AA branch.

comment:4 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:5 Changed 5 years ago by TL-WR1043ND_Sad_User

Still have the same issue but using a v1.10 model and latest version of AA.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.