Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13227 closed defect (fixed)

Broken WGT634U binary image

Reported by: KillaB Owned by: hauke
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc: hauke

Description

Using CFE to TFTP load openwrt-wgt634u-squashfs.bin, the following error occurs:

CFE version 1.0.34 for BCM95365R (32bit,SP,LE)
Build Date: Tue Feb 24 03:21:41 CST 2004 (root@jackylinux)
Copyright (C) 2000,2001,2002 Broadcom Corporation.

Add MAC client version(DNI).
Initializing Arena.
Initializing Devices.
et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
CPU type 0x29007: 200MHz
Total memory: 0x2000000 bytes (32MB)

Total memory used by CFE:  0x81BB1280 - 0x82000000 (4517248)
Initialized Data:          0x81BB1280 - 0x81BB3E90 (11280)
BSS Area:                  0x81BB3E90 - 0x81BB45D0 (1856)
Local Heap:                0x81BB45D0 - 0x81FB45D0 (4194304)
Stack Area:                0x81FB45D0 - 0x81FB65D0 (8192)
Text (code) segment:       0x81FB65E0 - 0x81FFFFB0 (301520)
Boot area (physical):      0x01B70000 - 0x01BB0000
Relocation Factor:         I:E23B65E0 - D:01BB0280

configure vlans
*****************************************************************
*********************** VLAN Driver initial  ********************
*****************************************************************
Process LAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add LAN port

Process WAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add WAN port
SUCCESS: enable ports  success
configure vlans...done
Device eth0:  hwaddr 00-0F-B5-36-50-4F, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Loader:elf Filesys:raw Dev:flash0.os File: Options:(null)
***************************
****  MAC Client V1.0  ****
***************************
et0macaddr value :flag =0 value=00-0f-b5-36-50-4f
et1macaddr value :flag =0 value=00-0f-b5-36-50-50
MAC exist at least one
system ethernet mac exist and not default....
Skip mac client process.....
Loading: 0x80001000/3768 Entry at 0x80001000
Closing network.
et0: link down
Starting program at 0x80001000
**Exception 8: EPC=81FB6154, Cause=00000008, VAddr=30520270
                RA=80001500, PRID=00029007

        0  ($00) = 00000000     AT ($01) = 00000000
        v0 ($02) = 30520000     v1 ($03) = 00000000
        a0 ($04) = 81FB6150     a1 ($05) = 81FB60C8
        a2 ($06) = 80000010     a3 ($07) = 80400000
        t0 ($08) = 80400000     t1 ($09) = 81FB60C8
        t2 ($10) = 80400000     t3 ($11) = 00000000
        t4 ($12) = 00000000     t5 ($13) = 00000000
        t6 ($14) = 00000000     t7 ($15) = 00000000
        s0 ($16) = 3E992C82     s1 ($17) = 81FB6150
        s2 ($18) = 80330000     s3 ($19) = 2328A0A1
        s4 ($20) = 00002000     s5 ($21) = 80330000
        s6 ($22) = 81FCE640     s7 ($23) = 80400000
        t8 ($24) = FFFFFFC8     t9 ($25) = 804005C4
        k0 ($26) = 81BB45B0     k1 ($27) = 81FCE640
        gp ($28) = 81BB9280     sp ($29) = 81FB60E8
        fp ($30) = FFFF7E4C     ra ($31) = 80001500

This is reproducible with the latest snapshot and 12.09-rc1 images. The TRX I loaded previously worked great, but of course comes with b43 drivers, etc.....I wanted the correct profile and therefore tried the binary image instead.

Attempted to load 10.03.1 to get back to a bootable state, only to find that that image suffers from a kernel panic. Ended up landing on 8.09.2, not testing any other images in between.

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by KillaB

In the off chance of this being a build-bot issue, I decided to compile locally.
Sure enough it is. Now booting successfully.

CFE version 1.0.34 for BCM95365R (32bit,SP,LE)
Build Date: Tue Feb 24 03:21:41 CST 2004 (root@jackylinux)
Copyright (C) 2000,2001,2002 Broadcom Corporation.

Add MAC client version(DNI).
Initializing Arena.
Initializing Devices.
et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
CPU type 0x29007: 200MHz
Total memory: 0x2000000 bytes (32MB)

Total memory used by CFE:  0x81BB1280 - 0x82000000 (4517248)
Initialized Data:          0x81BB1280 - 0x81BB3E90 (11280)
BSS Area:                  0x81BB3E90 - 0x81BB45D0 (1856)
Local Heap:                0x81BB45D0 - 0x81FB45D0 (4194304)
Stack Area:                0x81FB45D0 - 0x81FB65D0 (8192)
Text (code) segment:       0x81FB65E0 - 0x81FFFFB0 (301520)
Boot area (physical):      0x01B70000 - 0x01BB0000
Relocation Factor:         I:E23B65E0 - D:01BB0280

configure vlans
*****************************************************************
*********************** VLAN Driver initial  ********************
*****************************************************************
Process LAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add LAN port

Process WAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add WAN port
SUCCESS: enable ports  success
configure vlans...done
Device eth0:  hwaddr 00-0F-B5-36-50-4F, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Loader:elf Filesys:raw Dev:flash0.os File: Options:(null)
***************************
****  MAC Client V1.0  ****
***************************
et0macaddr value :flag =0 value=00-0f-b5-36-50-4f
et1macaddr value :flag =0 value=00-0f-b5-36-50-50
MAC exist at least one
system ethernet mac exist and not default....
Skip mac client process.....
Loading: 0x80000000/7876 Entry at 0x80001000
Closing network.
et0: link down
Starting program at 0x80001000
[    0.000000] Linux version 3.6.11 (anon@desktop) (gcc version 4.6.4 20121210 (prerelease) (Linaro GCC 4.6-2012.12) ) #1 Fri Mar 22 16:42:07 PDT 2013
[    0.000000] CPU revision is: 00029007 (Broadcom BMIPS3300)
[    0.000000] bcm47xx: using ssb bus
[    0.000000] ssb: Found chip with id 0x5365, rev 0x01 and package 0x00
[    0.000000] ssb: chipcommon status is 0x0
[    0.000000] ssb: Initializing MIPS core...

comment:2 Changed 5 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

if this is a buildbot problem that would be very strange. The openwrt-wgt634u-squashfs.bin image has the same content as the openwrt-brcm47xx-squashfs.trx image, it just has some additional header to load on the wgt634u.

So you loaded this http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-wgt634u-squashfs.bin file and this doe snot boot, but if you build your own image the openwrt-wgt634u-squashfs.bin boots?

What changes have you done to the source code or to the default configuration for your local image?

Does using the prebuild image builder work for you?

comment:3 Changed 5 years ago by KillaB

Correct, the downloaded snapshot .bin image from the day the ticket was opened failed on two separate WGT634U's. After building from clean trunk source checkout (no modifications), my bin worked as expected.

The only other variable was that I used a Windows PC and Solarwinds TFTP to load the first two images and Ubuntu TFTPd-HPA to load the working image. I will try loading a build-bot image using the TFTPd-HPA service on another router as soon as I get a chance early next week.

comment:4 Changed 5 years ago by KillaB

Just tested the latest snapshot binary on a separate unit without issue.
I guess we can chalk this up to a bad cable or tftp server.

Sorry for the misreport.

comment:5 Changed 5 years ago by KillaB

Actually, the buildbot image doesn't seem to include usb or ath5k packages like expected. b43 is also included.

comment:6 Changed 5 years ago by hauke

  • Resolution set to fixed
  • Status changed from assigned to closed

The images build by the buildbot do all contain the same image they just have different headers to make it possible to flash them through the default firmware. You have to used the image builder to generate a image with a different set of packages.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.