Modify

Opened 5 years ago

Closed 2 years ago

#13225 closed enhancement (fixed)

Feature request: enable IPv6 support for QoS

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09 Beta
Keywords: qos ipv6 Cc:

Description

Please enable IPv6 (using ip6tables) for qos-scripts.

Attachments (0)

Change History (13)

comment:1 Changed 5 years ago by fclql@…

IPV4 the QOS normal use

comment:2 Changed 5 years ago by anonymous

It appears that a patch has already been proposed on the developer mailing list:
http://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg17779.html

comment:3 Changed 5 years ago by anonymous

That patch is incomplete: In the firewall, when you use a dsthost or srchost option, it is only applied to ipv4 or ipv6 depending on the address. In the patched qos-scripts, all dsthost and srchost options are applied to both ipv4 and ipv6, which surely results in errors.

comment:4 follow-up: Changed 5 years ago by anonymous

I'm guessing qos isn't a feature that's widely used by openwrt devs and end users.

comment:5 in reply to: ↑ 4 Changed 5 years ago by anonymous

Replying to anonymous:

I'm guessing qos isn't a feature that's widely used by openwrt devs and end users.

For me, it is one of the most important features of OpenWRT and I rely on it since I use VoIP. Currently, I take the output of iptables-save, extract all mangle rules, remove the incorrect rules (see my previous comment) and pipe them to ip6tables-restore, but obviously, applying the UCI config directly would be better.

comment:6 follow-ups: Changed 4 years ago by mazixoom@…

Tried both patches (http://patchwork.openwrt.org/patch/3871/ and http://patchwork.openwrt.org/patch/3872/)on the latest BB snapshot (23-Feb-2014) and both times qos-scripts had problems with bad bash substitution in lines 421-423 of the generate.sh file and could not start.

zcecc22's script(https://github.com/zcecc22/qos-nxt) works for both ipv6 and ipv6 but qos-scripts' results are far better (in both latency and bandwidth) and also has the ability for bandwidth control, for example in a guest interface.

If there is any fix for making qos-scripts working with any of those two patches I'd be most thankful.

comment:7 in reply to: ↑ 6 Changed 4 years ago by fclql

Replying to mazixoom@…:

Tried both patches (http://patchwork.openwrt.org/patch/3871/ and http://patchwork.openwrt.org/patch/3872/)on the latest BB snapshot (23-Feb-2014) and both times qos-scripts had problems with bad bash substitution in lines 421-423 of the generate.sh file and could not start.

zcecc22's script(https://github.com/zcecc22/qos-nxt) works for both ipv6 and ipv6 but qos-scripts' results are far better (in both latency and bandwidth) and also has the ability for bandwidth control, for example in a guest interface.

If there is any fix for making qos-scripts working with any of those two patches I'd be most thankful.

Support ip segment speed limit it?
Ip default speed limit function is not supported openwrt

comment:8 in reply to: ↑ 6 Changed 4 years ago by mazixoom@…

After much frustation, the error was (as suspected) me.
Instead of deleting the existing lines in generate.sh and tcrules.awk, I was just commenting them out, thus making qos-scripts unable to start.

qos-scripts now work flawlessly.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:10 Changed 3 years ago by anonymous

This would be a great feature for me because I have room mates....

I can confirm that QOS when setup from luci (the only way I know how) works great on IPv4, but has no effect on IPv6 at all.

comment:11 Changed 3 years ago by anonymous

This would be a great feature for me because I have room mates....

I can confirm that QOS when setup from luci (the only way I know how) works great on IPv4, but has no effect on IPv6 at all.

comment:12 Changed 2 years ago by mamarley

IPv6 support was just added in https://git.openwrt.org/?p=openwrt.git;a=commit;h=1f2b408c0478592f7c1fa4bb8654ad1210f639be. The code is a cleaned up version of the two patches linked above. It should be released with DD, but if you feel like it, you can just copy the tcrules.awk and generate.sh from trunk to CC (or probably even BB) and it will work.

comment:13 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.