Modify

Opened 5 years ago

Closed 5 years ago

#13222 closed defect (wontfix)

Can't get Multiple SSID working on OpenWRT

Reported by: jeremy@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

I am trying to setup guest Chilli open hotspot
in addition to my existing wpa2 encrypted hotspot bridged to my lan.

So I added a new virtual wifi interface:

# cat /etc/config/wireless
config wifi-device 'radio0'

option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'ssb0:3'
option txpower '20'
option country 'US'
option disabled '0'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option isolate '1'
option ssid 'private'
option encryption 'psk2'
option key 'XXXXXXXXXXXXXXX'
option disabled '0'

config wifi-iface

option device 'radio0'
option mode 'ap'
option isolate '1'
option ssid 'HOTSPOT'
option encryption 'none'
option network 'hotspot'
option disabled '0'

Now when I restart wifi:

Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 00:1c:10:5b:c2:07 and ssid "private"
Could not set interface wlan0-1 flags (UP): Device or resource busy
Failed to add BSS (BSSID=02:1c:10:5b:c2:08)
Interface initialization failed
wlan0: Unable to setup interface.
Failed to remove BSS interface wlan0-1
Failed to start hostapd for phy0

This is a WRT54G-TM core revision 9 (supports Multiple SSID):

Linksys WRT54G/GS/GL
OpenWrt Barrier Breaker r36092 / LuCI 0.11 Branch (0.11+svn9425)
# uname -a
Linux OpenWrt 3.6.11 #1 Wed Mar 20 01:30:38 UTC 2013 mips GNU/Linux

I'm using 03/20/2013 trunk:
http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages

I have an identical WRT54G-TM running DD-WRT-v24-sp2 with Multiple SSID
working, but I would like to get OpenWRT working on router.

Attachments (1)

Kernel.log (22.4 KB) - added by jeremy@… 5 years ago.
Kernel Log (not sure if this will be helpful or not)

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by jeremy@…

Kernel Log (not sure if this will be helpful or not)

comment:1 Changed 5 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

b43 does not (and probably never will) support multi-ssid. Build a custom image with broadcom-wl or revert to 10.03.1 brcm-2.4.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.