Modify

Opened 5 years ago

Closed 3 years ago

#13208 closed defect (moved_to_github)

Attitude Adjustment 12.09-rc1 on x86, php5-mod-gd

Reported by: tipsntrix@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

php-cgi phpinfo.php

php-cgi: symbol 'iconv_open': can't resolve symbol in lib '/usr/lib/php/gd.so'.
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/gd.so' - (null) in Unknown on line 0
Status: 404 Not Found
X-Powered-By: PHP/5.4.5
Content-type: text/html

No input file specified.

packages:
base-files - 117-r34185
busybox - 1.19.4-5
digitemp - 3.6.0-5
digitemp-usb - 3.6.0-5
dnsmasq - 2.62-2
dropbear - 2011.54-2
firewall - 2-53
glib2 - 2.26.1-3
gnokii - 0.6.21-3
grub - 0.97-3
hotplug2 - 1.0-beta-4
htop - 1.0.1-1
iptables - 1.4.10-4
jshn - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
kernel - 3.3.8-1-fa7af62e0ef1d529ecb7f7efccc706c3
kmod-3c59x - 3.3.8-1
kmod-8139too - 3.3.8-1
kmod-e100 - 3.3.8-1
kmod-e1000 - 3.3.8-1
kmod-hid - 3.3.8-1
kmod-input-core - 3.3.8-1
kmod-input-evdev - 3.3.8-1
kmod-ipt-conntrack - 3.3.8-1
kmod-ipt-core - 3.3.8-1
kmod-ipt-nat - 3.3.8-1
kmod-ipt-nathelper - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-libphy - 3.3.8-1
kmod-natsemi - 3.3.8-1
kmod-ne2k-pci - 3.3.8-1
kmod-nls-base - 3.3.8-1
kmod-pcnet32 - 3.3.8-1
kmod-ppp - 3.3.8-1
kmod-pppoe - 3.3.8-1
kmod-pppox - 3.3.8-1
kmod-r8169 - 3.3.8-1
kmod-scsi-core - 3.3.8-1
kmod-sis900 - 3.3.8-1
kmod-tg3 - 3.3.8-1
kmod-tun - 3.3.8-1
kmod-usb-core - 3.3.8-1
kmod-usb-hid - 3.3.8-1
kmod-usb-serial - 3.3.8-1
kmod-usb-serial-ftdi - 3.3.8-1
kmod-usb-serial-option - 3.3.8-1
kmod-usb-serial-wwan - 3.3.8-1
kmod-usb-storage - 3.3.8-1
kmod-usb-storage-extras - 3.3.8-1
kmod-via-rhine - 3.3.8-1
kmod-via-velocity - 3.3.8-1
libblobmsg-json - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
libc - 0.9.33.2-1
libcurl - 7.23.1-1
libevent2 - 2.0.19-1
libgcc - 4.6-linaro-1
libiconv - 7
libip4tc - 1.4.10-4
libiwinfo - 36
libiwinfo-lua - 36
libjpeg - 6b-1
libjson - 0.9-2
liblua - 5.1.4-8
liblzo - 2.06-1
libminiupnpc - 1.6-1
libncurses - 5.7-5
libnl-tiny - 0.1-3
libopenssl - 1.0.1c-1
libpcre - 8.11-2
libpng - 1.2.46-2
libpthread - 0.9.33.2-1
librpc - 0.9.32-rc2-0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
librt - 0.9.33.2-1
libsqlite3 - 3071201-1
libubox - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
libubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libubus-lua - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libuci - 2012-03-28.1-1
libuci-lua - 2012-03-28.1-1
libusb - 0.1.12-3
libusb-1.0 - 1.0.9-1
libxml2 - 2.7.8-2
libxtables - 1.4.10-4
lua - 5.1.4-8
luci - 0.11+svn9422-1
luci-app-firewall - 0.11+svn9422-1
luci-app-ntpc - 0.11+svn9422-1
luci-app-samba - 0.11+svn9422-1
luci-app-transmission - 0.11+svn9422-1
luci-i18n-english - 0.11+svn9422-1
luci-i18n-polish - 0.11+svn9422-1
luci-lib-core - 0.11+svn9422-1
luci-lib-ipkg - 0.11+svn9422-1
luci-lib-lmo - 0.11+svn9422-1
luci-lib-nixio - 0.11+svn9422-1
luci-lib-sys - 0.11+svn9422-1
luci-lib-web - 0.11+svn9422-1
luci-mod-admin-core - 0.11+svn9422-1
luci-mod-admin-full - 0.11+svn9422-1
luci-proto-core - 0.11+svn9422-1
luci-proto-ppp - 0.11+svn9422-1
luci-sgi-cgi - 0.11+svn9422-1
luci-theme-base - 0.11+svn9422-1
luci-theme-openwrt - 0.11+svn9422-1
mc - 4.7.5.3-2
mini-snmpd - 1.2b-7
mtd - 18.1
nano - 2.2.6-1
netifd - 2012-10-19-a9fd870450e82f31cba681651656276dfc1c39ac
ntpclient - 2007_365-4
openvpn - 2.2.2-2
opkg - 618-2
oscam - 8334-1
php5 - 5.4.5-3
php5-cgi - 5.4.5-3
php5-fastcgi - 5.4.5-3
php5-mod-ctype - 5.4.5-3
php5-mod-dom - 5.4.5-3
php5-mod-gd - 5.4.5-3
php5-mod-hash - 5.4.5-3
php5-mod-iconv - 5.4.5-3
php5-mod-json - 5.4.5-3
php5-mod-mbstring - 5.4.5-3
php5-mod-pdo - 5.4.5-3
php5-mod-pdo-sqlite - 5.4.5-3
php5-mod-session - 5.4.5-3
php5-mod-simplexml - 5.4.5-3
php5-mod-sqlite3 - 5.4.5-3
php5-mod-xml - 5.4.5-3
php5-mod-zip - 5.4.5-3
ppp - 2.4.5-7
ppp-mod-pppoe - 2.4.5-7
samba36-server - 3.6.5-2
terminfo - 5.7-5
transmission-daemon - 2.71-1
ubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
ubusd - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
uci - 2012-03-28.1-1
udev - 173-1
uhttpd - 2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd
zlib - 1.2.7-1
zoneinfo-core - 2011n-1

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by anonymous

Confirmed on my Alix2 with attitude_adjustment/12.09-rc1/x86/alix2/packages. I have tried to install libgd package. Also tried to strace what was going on.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:3 Changed 4 years ago by nan4k7@…

Same problem here...

comment:4 Changed 3 years ago by mhei

  • Resolution set to wontfix
  • Status changed from new to closed

For problem was recently fixed in trunk, please upgrade your installation.

comment:5 Changed 3 years ago by gbi

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Bug is still in the x86 version of Barrier Breaker:

php-cli -v

php-cli: symbol 'iconv_open': can't resolve symbol in lib '/usr/lib/php/gd.so'.
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/gd.so' - (null) in Unknown on line 0
PHP 5.4.27 (cli) (built: Sep 24 2014 05:14:28)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies

comment:6 Changed 3 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from reopened to closed

php5 is maintained here: https://github.com/openwrt/packages

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.