Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13193 closed defect (fixed)

BB build failure for r36083

Reported by: dani@… Owned by: florian
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:


hello, just updated trunk this morning and tried to compile for dlin k dir-825 (which worked fine a day ago) and it breaks at:

ERROR: module '/home/dani/OpenWrt/rtl8366/trunk/build_dir/target-mips_r2_uClibc-' is missing.
make[3]: * /home/dani/OpenWrt/rtl8366/trunk/bin/ar71xx/packages/kmod-sound-core_3.8.3-1_ar71xx.ipk Error 1

looking with make menuconfig i can see it has alsa-lib selected as module which pulls other stuff.. anything changed in the last commits..? thanks!

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

Whoops, I will take care of that, thanks!

comment:2 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r36091

comment:3 Changed 5 years ago by dani@…

i still get:


. /home/dani/OpenWrt/rtl8366/trunk/include/; export modules=; add_module() { priority="$1"; mods="$2"; boot="$3"; shift 3; for mod in $mods; do if [ -e /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-$mod.ko ]; then mkdir -p /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; echo "$mod" >> /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-$priority-zram; fi; done; if [ -e /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-$priority-zram ]; then if [ "$boot" = "1" ]; then mkdir -p /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; ln -s ../modules.d/$priority-zram /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; fi; modules="${modules:+$modules }$priority-zram"; fi; }; add_module "20" "zsmalloc zram" ""; if [ -n "$modules" ]; then mkdir -p /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; mkdir -p /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; echo "#!/bin/sh" > /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; echo "[ -z \"\$IPKG_INSTROOT\" ]
exit 0" >> /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; echo ". /lib/" >> /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; echo "load_modules $modules" >> /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; chmod 0755 /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; fi

SHELL= /home/dani/OpenWrt/rtl8366/trunk/staging_dir/host/bin/flock /home/dani/OpenWrt/rtl8366/trunk/tmp/.root-copy.flock -c 'cp -fpR /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc- /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-'
rm -rf /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-
touch /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-
if [ -f /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc- ]; then rm -f /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc- /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-; fi; echo "kmod-zram" >> /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-
WARNING: skipping kmod-pcmcia-rsrc -- package not selected
mkdir -p /home/dani/OpenWrt/rtl8366/trunk/bin/ar71xx/packages /home/dani/OpenWrt/rtl8366/trunk/build_dir/target-mips_r2_uClibc- /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc-
ERROR: module '/home/dani/OpenWrt/rtl8366/trunk/build_dir/target-mips_r2_uClibc-' is missing.
make[3]: * /home/dani/OpenWrt/rtl8366/trunk/bin/ar71xx/packages/kmod-sound-core_3.8.3-1_ar71xx.ipk Error 1
make[3]: Leaving directory `/home/dani/OpenWrt/rtl8366/trunk/package/kernel'
* [package/kernel/compile] Error 2
make[2]: Leaving directory `/home/dani/OpenWrt/rtl8366/trunk'
make[1]: * /home/dani/OpenWrt/rtl8366/trunk/staging_dir/target-mips_r2_uClibc- Error 2
make[1]: Leaving directory `/home/dani/OpenWrt/rtl8366/trunk'
* [world] Error 2

i really do not recall having CONFIG_PACKAGE_kmod-sound-core locked as (M) few commits ago.. these days and everything worked okay..

comment:4 Changed 5 years ago by florian

You need to clean the linux kernel sources first: make target/linux/clean

comment:5 Changed 5 years ago by dani@…

thanks for the hint - i will confirm in few minutes.
i still don't get why i need to compile kmod-sound-core for my dlink dir825.. i needed minidlna and i enabled libffmpeg-mini for it.. maybe that pulled alsa libs and kmod-sound-core..

comment:6 Changed 5 years ago by anonymous

worked, thanks florian !

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.