Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13156 closed defect (fixed)

ar71xx: wr741nd v4 AP defect (trunk)

Reported by: musti@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc: juhosg

Description

Used the snapshot from 11th March 2013, for wr741nd v4. Enabled wifi in the config and rebooted. No other changes made.

The error has been observed as well in r35112.

SSID is visible, but clients can not connect to it, can not connect error is returned. ad-hoc works fine.

Attachments (0)

Change History (14)

comment:1 Changed 5 years ago by musti@…

The error is still present in the latest trunk. This is becoming critical, can not use openwrt with wr741nd routers in AP mode.

comment:2 Changed 5 years ago by k@…

Just to clarify, this does not happen on v2, it has only been observed on v4.

comment:3 Changed 5 years ago by nbd

please try latest trunk

comment:4 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:5 Changed 5 years ago by musti@…

I am sorry, been very busy lately. Have performed tests with trunk and stable AA 12.09. It turns out wifi performance with trunk [36828] is severely degraded, please see the tests on http://dev.wlan-si.net/ticket/1096

comment:6 Changed 5 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by nbd

please test revision [36822] to see if there is any difference.

comment:8 Changed 5 years ago by nbd

or even better: try r36859, just committed some fixes

comment:9 Changed 5 years ago by musti@…

It appears the problem has been resolved with r36859, confirmed with http://dev.wlan-si.net/ticket/1096#comment:5

However there is another one. Wifi connection on some wr741nd routers dies after a few days, this happens on less then 1% of 100+ nodes I am running, depends on the location or the specific hardware router.

The symptoms are simply: no active connections in iw wlan0 station dump, either mesh or AP. The SSID as far as I was able to determine is visible but unable to connect. There is nothing in the logread or dmesg outputs that can be associated with this.

I was unable to find thus far the source of this error and it is rather impossible to test for it, because it can not be artificially induced. Guessing it is due to other networks present.

comment:10 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

For debugging this issue, once you have an affected router in such a stuck state, please tell me what exact wifi chip it is using, and give me the output of following files in /sys/kernel/debug/ieee80211/phy0/ath9k:
base_eeprom
modal_eeprom
misc
interrupt
recv
xmit
reset
queues

Note that you can't simply tar all files in that directory, because accessing things like eeprom or regdump can occasioanlly crash the device, so please stick to this list.

Thanks

comment:11 Changed 5 years ago by musti@…

Ok, will submit these files.

Here you can see graphically the difference between the trunk prior to your fix to AA 12.09. Will do the same for the latest trunk. http://dev.wlan-si.net/ticket/1096#comment:9

comment:12 Changed 5 years ago by mmitar@…

CCing.

comment:13 Changed 5 years ago by musti@…

comment:14 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.