Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13142 closed defect (invalid)

TL-WR741ND v4 / switch

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

The ports numbered 1,2,3,4 are identified as 2,3,4,1 in release aa-rc1.

Switch "eth0" (AR7240/AR9330 built-in switch), Hw rev 4.20

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

As discussed in several other tickets, this is a wontfix as the internal port numbering commonly diverges from the case labels.
Since it wildly varies from model to model it is not possible to programmatically solve it.

comment:2 Changed 5 years ago by anonymous

How about a port remapping tool (script) with defaults for known models?
That would be a wide solution. Similiar things have been done for acpi problems on desktop and laptop machines. There, too, was a wide variety of bugs.

comment:3 Changed 5 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

wontfix is not a solution, especially, if the problem is well known and exists on many devices.

comment:4 Changed 5 years ago by anonymous

what the fuck is wrong with you stupid people. this is free firmware, nobody is forcing you to use it. if they wontfix it, then it won't be fixed. don't like it, don't use it!

comment:5 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

"wontfix" means no developer is going to invest time to solve the particular problem, thefore it is a valid ticket solution. You will not force us to implement a particular solution by reopening the ticket.

comment:6 Changed 5 years ago by anonymous

Try LED configuration I fixed with that.

comment:7 Changed 5 years ago by Nilfred <nilfred@…>

What about:

uci set network.@switch[0].map='0 2 3 4 1'

like

network.@switch_vlan[0].ports=0 1 2 3 4

It will not hurt anybody :)
Only useful for LuCI presentation like an alias for the port, so better to use labels:

uci set network.@switch[0].map='CPU LAN2 LAN3 LAN4 LAN1'

Then user can change on demand like

uci set network.@switch[0].map='CPU LAN2 WAN3 WAN2 LAN1'

Worth move to "features paradise"? Everybody like cosmetics like this :)
Definitely not a bug.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.