Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13136 closed defect (duplicate)

asterisk 1.8 hangs with 100% CPU usage when hostname (not IP) is used in sip.conf

Reported by: iiordanov@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: asterisk18 hang host ip sip.conf unregistered Cc:

Description

I'm the developer of the luci-app-pbx and luci-app-pbx-voicemail packages. I decided to update them for 12.09 and came across a serious bug in Asterisk 1.8.

Steps to reproduce:

  • Installed a pre-built 12.09 release (12.09-rc1).
  • Installed a pre-built asterisk18 package with opkg.
  • Edited sip.conf and added a sip peer and a registration statement in the right places. Here is an example of what I added. The bug was reproduced with a Betamax (freecall) account, and with a freephoneline, so it's not related to the particular VOIP provider.

; The registration statement:
register => myfreecallusername:myfreecallpassword@freecall/default

; The peer definition:
[freecall]
defaultuser = myfreecallusername
type = peer
secret = myfreecallpassword
insecure = port,invite
host = sip.freecall.com
authuser = myfreecallusername

  • Restarted asterisk

What happens:

  • Asteriks hangs with 100% CPU usage, apparently never completing the sip module load. The peers sit in an "Unregistered" state when "sip show status" is executed on the CLI.

How to work around the issue:

  • Instead of specifying a hostname, one must specify an IP address for "host" in the peer definition, e.g.:

Instead of:

host = sip.freecall.com

specify:

host = 77.72.169.134

This makes the problem go away, asterisk doesn't hang, the peers register, etc.

Thanks!

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by m.sedeshev@…

Is there anybody who decided the problem.

comment:2 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

seems to be a duplicate of #11929

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.