Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13113 closed defect (fixed)

FTP TLS encryption no longer working

Reported by: alphasparc@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Previously Pure-ftpd-tls on AA worked on Beta however in the latest release r35817 it fails with error
Fatal error: gnutls_record_recv: A TLS fatal alert has been received
The exact same config of pure-ftpd-tls worked on beta but failed in the latest release.
I suspect that it was due to openssl bricking the function

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

It's a bug in openssl 1.0.1d. Was fixed in 1.0.1e, which is already in trunk. Needs backporting to AA.

comment:2 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

was backported in r36088

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.