Modify

Opened 5 years ago

Last modified 20 months ago

#13023 reopened defect

Netgear WNDR3700v4 Support

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: wndr3700v4, wndr4300 Cc:

Description

There is early WNDR4300 support (although no snapshot builds available?). WNDR3700v4 has an identical PCB, with the main difference being 2x2 on the 5 GHz band instead of 3x3 seen in the WNDR4300. Samew 128MB RAM and 128MB NAND Flash.

It should be pretty simple to build a profile for WNDR3700v4.

Netgear GPL source: http://www.downloads.netgear.com/files/GPL/WNDR3700v4-V1.0.1.32_gpl_src.zip
Forum thread: https://forum.openwrt.org/viewtopic.php?id=41094
Wiki page on WNDR4300: http://wiki.openwrt.org/toh/netgear/wndr4300

Boot log from DD-WRT forum is attached.

Still unclear about the impact of NAND flash if anyone wants to make that more explicit.

Attachments (1)

wndr3700v4_ttyUSB0.txt (27.4 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by anonymous

comment:1 Changed 5 years ago by anonymous

is there any guru working on to support WNDR4300 completely?

comment:2 Changed 5 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

comment:3 Changed 5 years ago by anonymous

where can i find a build ?

comment:4 Changed 3 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

Hello, can one of the developers from OpenWRT give some sort of a clear answer if Netgear WNDR3700v4 supported at all or in some sort of shape or form by OpenWRT project?
Does the latest Barrier Braker Build runs on the Atheros AR9344 CPU?
Does the 5GHz band wifi radio works?

It seems there is a lot of confusion and tickets opened in regard of WNDR3700v4 just get closed with out any explanation, or comment....

One of the strange inconsistencies is that, WNDR3700V4 has a CPU: Atheros AR9344

Meanwhile on OpenWRT site under downloads there is a firmware available marked "...wndr3700v4..." with the reference to CPU - AR71XX. What dose that mean? Does that it mean this firmware can be installed even tho that CPUs do not match?
Here's the link to the firmware:

http://downloads.openwrt.org/barrier_br … actory.img

Can someone from OpenWRT explain if this firmware can be installed on WNDR3700v4 or this is just a wrong name in regards to the Netgear router model number, or a wrong CPU architecture... ?

Any clarification would be much appreciated.

Thank you.

comment:5 Changed 3 years ago by anonymous

The link to the the firmware in question is:

http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/nand/openwrt-ar71xx-nand-wndr3700v4-ubi-factory.img

Can some one explain and answer the previous post?
Thanks.

comment:6 Changed 3 years ago by anonymous

Yes, it should work. AR9344 and both radios are supported on this router as well as many others with similar chipsets (TP-Link WDR3600/4300, WD N750, D-Link DIR-835, etc.). AR9344 is the same core architecture as AR71xx, so no problem there, and as a build target is the same. The challenge for this router was getting NAND flash support working, which is now supported.

comment:7 Changed 2 years ago by anonymous

Netgear 3700v4 5g radio is still not working on the latest Barrier Braker built,

comment:8 Changed 2 years ago by nbd

how about you try chaos calmer instead?

comment:9 Changed 2 years ago by anonymous

I did. I got " OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45)" upgraded. It's the same result. Someone said it's a bug on the memory address to cause the 5G radio disappear.

comment:10 Changed 2 years ago by anonymous

I found something good on this website. I follow the trick to reboot my router. On the second rebooted the 5G shows up, it works.

https://liangsun.org/posts/switch-netgear-wndr4300-from-dd-wrt-to-open-wrt/

5G radio

Wait the 5G radio not working?

Here is the solution.

Sometimes the 5G wifi interface (a separate AR9580 chip attached on PCIe) will completely disappear, because the PCIE_RC strap bit gets stuck at ‘0’. This can be checked by running “devmem 0x180600b0” and looking at bit 6:

  • GOOD: 0x002F055A
  • BAD: 0x002F051A

On OpenWRT this causes the kernel to completely ignore the PCIe interface and everything attached to it, so only the onchip 2.4GHz radio will work. On the original firmware it may cause the unit to get stuck in a reboot loop.

If this happens, just power the unit off for about 30 seconds. In fact it might be a good idea to power cycle the unit before OpenWRT’s initial boot. See this thread for more information.

comment:11 Changed 20 months ago by anonymous

root@OpenWrt:~# devmem 0x180600b0
0x002F051A

dousn't work on

comment:12 Changed 20 months ago by anonymous

Czy nie można tego jakoś dodać do /etc/uci-defaults aby po pierwszym właśnie starcie wykonywał coś w ten deseń (wzorowałem się na /etc/uci-defaults/02-networks):
#!/bin/sh

[ -e /etc/config/wireless ] && exit 0

CZYTAM_PAMIEC=devmem 0x180600b0

case "$CZYTAM_PAMIEC" in

"0x002F055A") echo "radio1 jest ok" ;;
"0x002F051A") echo "radio1 jest nieobecne - wykonuje reboot" && reboot ;;
*) echo "nie wykonano skryptu"

esac

uci commit wireless

exit 0

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.