Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13021 closed defect (fixed)

Replace strongswan 5.0.0 with >=5.0.1

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

With StongSwan 5.0 pluto daemon has been made obsolete. The IKEv1 handling was migrated into a unified charon daemon. This way some bugs were introduced that were fixed in 5.0.1/5.0.2

One example where the daemon builds wrong security associations (SAs) was fixed by: http://git.strongswan.org/?p=strongswan.git;a=commitdiff;h=777bcdc0 Therefore tunnels cannot be established by simply pinging hosts in the remote VPN network.

To provide users a stable IPsec implementation in OpenWRT please switch to the newer StrongSwan version for the upcoming attitude adjustment release.

Thanks in advance.

Markus

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by luka

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.