Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13007 closed defect (duplicate)

SubversionException: 24 - Can't open file '/var/svn/openwrt/db/revs/25599': Too many open files

Reported by: slbond86@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Как воспроизвести

При выполнении операции GET по /changeset/33895/trunk, Trac выдает внутреннюю ошибку.

(просьба предоставить дополнительные подробности здесь)

Параметры запроса:

{'format': u'zip',
 'new': u'33895',
 'new_path': u'/trunk',
 'old': u'33895',
 'old_path': u'/'}

User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.70 Safari/537.17

Системная информация

Системная информация недоступна

Включенные плагины

Информация о плагинах недоступна

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 350, in process_request
    self._render_zip(req, filename, repos, data)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 769, in _render_zip
    old_path=data['old_path'], old_rev=data['old_rev']):
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/cache.py", line 400, in get_changes
    ignore_ancestry)
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 647, in get_changes
    key=key))
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 699, in _get_changes
    new_rev)
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 481, in get_node
    return SubversionNode(path, rev, self, self.pool)
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 731, in __init__
    node_type = fs.check_path(self.root, self._scoped_path_utf8, pool)
  File "/usr/lib/python2.7/dist-packages/libsvn/fs.py", line 455, in svn_fs_check_path
    return _fs.svn_fs_check_path(*args)
SubversionException: 24 - Can't open file '/var/svn/openwrt/db/revs/25599': Too many open files

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

Temporary server load problem. Not a real Openwrt bug.
Duplicate of: #12467, #12499, #12606, #12608, #12640, #12699, #12998

comment:2 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.