Modify

Opened 5 years ago

Closed 5 years ago

#12984 closed defect (no_response)

Can't configure Barrier Breaker for static IPv6 and PPPoE

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc: cyrus@…

Description

Hi,

Not sure a ticket is best to report this but I do not know the forums at all, so let's try...

Currently I am using AA-rc1 and my IPv6 is very similar (accept_ra was needed for me and is not in the example) to the one described in the "Native IPv6 access" part of the Ipv6 HowTo on Backfire and later.

/etc/config/network (only lan and wan parts) :

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6addr '2001:7a8:b4c5:1::1/64'

config interface 'wan'
    option ifname 'eth0.2'
    option _orig_ifname 'eth0.2'
    option _orig_bridge 'false'
    option proto 'pppoe'
    option username 'damien.wyart@adslc.nerim.nerim'
    option password 'db63ec30'
    option accept_ra '1'
    option ipv6 '1'
    option mtu '1452'

The LAN distribution of adresses is done with radvd (again from the HowTo page). Here is the main part of the config file :

config interface
    option interface    'lan'
    option AdvSendAdvert    1
    option AdvManagedFlag   0
    option AdvOtherConfigFlag 0
    list client     ''
    option ignore       0

config prefix
    option interface    'lan'
    option prefix       '2001:7a8:b4c5:1::/64'
    option AdvOnLink    1
    option AdvAutonomous    1
    option AdvRouterAddr    0
    option ignore       0

Out of curiosity, I wanted to have a look at the recent IPv6-related evolutions in Barrier Breaker, but I was not able to find a working configuration...

The new ipv6-support package seems to only support DHCPv6 on WAN (which I do not have, default GW is sent by RA).

Without this package, accept_ra doesn't seem supported any more, and the recent "ip6slaac" seems to be targeted at pure static configuration (which pppoe is not). Would it be possible to extend this setting to ppp(oe) ? Why was it limited to static only ?

Do you have some advice for a setting like mine to get Ipv6 working without too much complexity ?

I tried to play a bit manually with accept_ra in /proc/sys/net/ipv6 but this did not seem to make a difference, the default route never appeared in the routing table.

Many thanks in advance.

Attachments (0)

Change History (17)

comment:1 Changed 5 years ago by anonymous

Notice that wan doen't have a global IPv6 adress as the HowTo places it on lan (and then you can tune ip6tables to make ports reachable on it from wan, so this seems reasonable).

Is the new setup in BB targeted at having a global Ipv6 adress on wan side ?

comment:2 Changed 5 years ago by cyrus

Please nevertheless add a wan6 interface like this:

config interface wan6
    option proto dhcpv6
    option ifname @wan
    option reqprefix no

Only add the last option (reqprefix=no) if you are absolutely certain that your ISP / the upstream router doesn't provide a DHCPv6 server.
This option this will allow IPv6 configuration without DHCPv6 (using RA only) and will configure addresses, routes and if-provided DNS-servers from RAs.

Btw. you don't need to add radvd anymore, if you have installed ipv6-support you automatically got our new RA-server 6relayd which is enabled by default on LAN (so you might run into conflicts having both).

Note: You might need to comment out or remove the option option fallback_relay 'rd dhcpv6 ndp' in /etc/config/6relayd, otherwise this might lead to some unexpected behaviour in your specific setup.

comment:3 Changed 5 years ago by cyrus

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 5 years ago by anonymous

Reporter might want to change his PPPoE username and/or password...

(sorry for the comment noise)

comment:5 Changed 5 years ago by anonymous

Many thanks for your explanations, will try this quickly...

comment:6 Changed 5 years ago by anonymous

oops, you are right, copy/pasted too quickly with credentials...

comment:7 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfortunately this did not work :-( The ipv6 routing table never gets a defaut route for ::0...

After reading a bit the doc from the FAI, they explain ipv6 defaut route can be set statically like this :

route add -A inet6 ::/0 pppoe-wan

When typed by hand when network is up this works ok and ipv6 connectivity is fine (as in AA)
so I added this in /etc/config/network :

config 'route6'
        option 'interface' 'pppoe-wan'
        option 'target' '::/0'

but this did not work... Maybe a timing problem ? This is a static route but "on top" of pppoe, so pppoe link might not be up yet when the route is added and this fails.

So for now only way of getting a fully working config is to add the route manually ; I will check if there is some way to add it in a script when pppoe is up.

Do you have other suggestions ?

Thanks

comment:8 Changed 5 years ago by anonymous

created a /etc/hotplug.d/iface/10-ipv6-default-route file with this content :

case "$ACTION" in
        ifup)
                /sbin/route add -A inet6 ::/0 pppoe-wan
        ;;
esac

and it works : the route gets automatically set up.

So for the working part I would say its ok, but if you want help on understanding why "reqprefix no" method did not work, I can try to give more debug info...

comment:9 Changed 5 years ago by jow

As for your route section, the interface must be set to "wan", not pppoe-wan - the interface option in the route section always refers to the logical iface.

comment:10 Changed 5 years ago by anonymous

Thanks, this works with this modification, I removed my /etc/hotplug.d/iface/10-ipv6-default-route which is not needed any more.

Seems evident now that you said it as /etc/config/network only contains logical names.

comment:11 Changed 5 years ago by cyrus

I'll put the other bug on my todo.

comment:12 Changed 5 years ago by anonymous

Do you have some idea of where the problem might come from or do you need to debug it from scratch ?

comment:13 Changed 5 years ago by cyrus

Hmm I just setup a VM with OpenWrt connected to an interface where I only send RAs (but no DHCPv6-server).

Interface was configured as:
config interface wan6

option ifname eth2
option proto dhcpv6

When not setting "option reqprefix no" the interface - as expected - did not come up. When adding "option reqprefix no" to the config the interface successfully came up without a DHCPv6-transaction (solely from the RAs).

comment:14 Changed 5 years ago by cyrus

  • Cc cyrus@… added

comment:15 Changed 5 years ago by anonymous

On my side interface comes up and has a LL address, but no route to send traffic to wan.

Is that part (default route) also ok on your side ?

Are there some other tests I could do ? Not sure how to capture ICMPv6 traffic on pppoe-wan while connected via ssh from lan ; how to force restart of pppoe-wan interface only? Can tshark be used on a pppoe interface ?

Do you have some additional suggestions ?

What is sure is that AA with "accept_ra" was working (got an IPv6 wan default route) and BB "reqprefix no" method did not (for now static route through pppoe device works, not sure which method is preferrable)

comment:16 Changed 5 years ago by nbd

please try latest trunk

comment:17 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.