Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12979 closed defect (fixed)

eth1 (wan) broken / ar71xx

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: eth eth1 switch internet ppp pppoe pppd wan vlan Cc:

Description

Today I upgraded my WZR-HP-AG300H from r351xx to r35532. Everything worked fine except for a PPPoE wan connection. After running "logread" I saw that the ppp-daemon can't discover any modem on eth1. So I ran "ifconfig" which indicated a tx- and rx-packet-count of 0 - even though the ppp daemon should have send some, and I'm also sure there should be some RXs from ARP-packets as the modem can function as router too, if not yet connected via PPPoE.
Then I re-flashed the older r351xx version to get it working again - and, of course, forgot to make logs. But they weren't interesting anyways. logread just showed the repeated tries of pppd and dmesg repeated "eth1: link not ready" for each pppd-loop.

Now, which patch broke my internet? ;)
I don't really have the skill to know which patch could be responsible, but r35518 looks strange to me... I might be totally wrong, though.

It probably won't help much, but here is at least my network-config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'xxx'
	option password 'xxx'
	option ipv6 '1'
	option keepalive '3 5'

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0 1 2 3 4'

Thanks a lot!

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by anonymous

'make dirclean' may help

comment:2 Changed 5 years ago by anonymous

I have done that before compiling.
{{
make dirclean; svn up; ./scripts/feeds update -a; ./scripts/feeds install -a; make defconfig; make menuconfig; nice -n 19 make world V=99
}}

Does it (still) work for anybody else with the latest trunk version?
Then I could assume something went wrong while compiling.

comment:3 Changed 5 years ago by anonymous

maybe 'distclean' will help?
start from zero

comment:4 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in r35549, make sure you clean the kernel tree after updating.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.