Modify

Opened 5 years ago

Closed 4 years ago

#12960 closed task (invalid)

Multiple SSID's and assign each of them a vlan

Reported by: andreboom1@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: Cc:

Description

Afternoon,
I am trying to set up 3 ssids and each with their own vlan.

I got a TPLink WR1043ND (Firmware version: OpenWrt Barrier Breaker r35470 / LuCI Trunk (trunk+svn9664))

PS: It might sound silly but i don't know which version i have to fill in in the drop down menu on your website. For this reason I provided the above information.

Kernel version: 3.7.5

I got the following configuration in /etc/config/network:

        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface vlan10
  option ifname  eth0.10
  option type     bridge
  option proto    static
  option ipaddr   192.168.10.1
  option netmask  255.255.255.0

 config interface vlan20
  option ifname  eth0.20
  option type     bridge
  option proto    static
  option ipaddr   192.168.20.1
  option netmask  255.255.255.0

 config interface vlan30
  option ifname  eth0.30
  option type     bridge
  option proto    static
  option ipaddr   192.168.30.1
  option netmask  255.255.255.0

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

I also get a lease as I configured /etc/config/dhcp as it should be.

However, I want port 3 to trunk all the vlan traffic to a switch. All the other physical ports won't be used. How can I set it up in such away that vlan10 and vlan30 can communicate with eachother and that vlan20 can only access the internet.

For additional information, I got the following settings in /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11ng'
        option path 'platform/ath9k'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option hidden '0'
        option encryption 'none'
        option isolate '0'
        option bgscan '0'
        option wds '0'
        option macfilter 'none'
        option ssid 'Intern'
        option network 'vlan10'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option hidden '0'
        option encryption 'none'
        option isolate '0'
        option bgscan '0'
        option wds '0'
        option macfilter 'none'
        option ssid 'Gasten'
        option network 'vlan20'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option hidden '0'
        option encryption 'none'
        option isolate '0'
        option bgscan '0'
        option wds '0'
        option macfilter 'none'
        option ssid 'Cameras'
        option network 'vlan30'

Right now when I connect to each SSID, I get a lease with the correct network 192.168.10.* or 192.168.20.* or 192.168.30.* but I can't connect to the internet when I am on a wireless SSID.

In short:
How can I make sure that all traffic will be routed through port 3 to a switch that is connected to it and prevent vlan20 from connecting to the other VLAN's?

Setup is:
TPLinkWR1043ND --> Switch --> modem --> internet

I know it is a log of information, but any help will be greatly appreciated.

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Use the forum for support questions.

comment:2 follow-up: Changed 5 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I already figured it out, pretty rude to close it.. without comment...
However, what I forgot was to assign it to the correct firewall -zone ( i did this in the web gui under Network --> interfaces --> select the interface --> firwall settings --> add it to the firewall group.

comment:3 Changed 5 years ago by anonymous

sorry,

My deepest appologize I am sorry for being rude, I didn't see ur comment.
Once again please accept my appoligees, sorry again...

comment:4 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:5 in reply to: ↑ 2 Changed 4 years ago by banglang.huang@…

Replying to anonymous:

I already figured it out, pretty rude to close it.. without comment...
However, what I forgot was to assign it to the correct firewall -zone ( i did this in the web gui under Network --> interfaces --> select the interface --> firwall settings --> add it to the firewall group.

Could you please show me the finally snapshot of /etc/config/network? thanks.

comment:6 Changed 4 years ago by debakanta.biswal@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi,
How to route all SSID Data traffic, tagged with respective VLANs through one port (Say Port2)
I have a configuration where my AP's WAN interface(Port2) is connected to the L3 Switch. Its on a VLAN network 101.
Now I want to create 2 SSIDs whose traffic be tagged: One tagged with 1001, other untagged. Now i want both of them to be active and working, through the WAN interface(Port2).

Looking for a quick response.
Thanks in advance.

comment:7 Changed 4 years ago by nbd

  • Resolution set to invalid
  • Status changed from reopened to closed

please don't open tickets for support requests, ask in the forum instead.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.