Modify

Opened 5 years ago

Closed 4 years ago

#12931 closed defect (not_a_bug)

Cisco E3000 VLAN configuration issue

Reported by: d.buffa@… Owned by: hauke
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

I tried to config my cisco to have port 2, 3 and 4 "bridged" with wan, and only port 1 for lan. I have to replace an old router also configured in this way. I used luci to do it (image in attachment)

After reboot the router is not responding anymore, due of a problem with modified nework config file. First

config switch 'eth0'
        option enable '1'

config switch_vlan 'eth0_0'
        option device 'eth0'
        option vlan '0'
        option ports '1 2 3 4 8*'

config switch_vlan 'eth0_1'
        option device 'eth0'
        option vlan '1'
        option ports '0 8'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

After

config switch 'eth0'
        option enable '1'

config switch_vlan 'eth0_0'
        option device 'eth0'
        option vlan '0'
        option ports '1'

config switch_vlan 'eth0_1'
        option device 'eth0'
        option vlan '1'
        option ports '0 2 3 4'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

I obtained what i want manually edit this, but I hope in a working luci...

Thanks
Daniele.

Attachments (1)

switch.png (10.4 KB) - added by d.buffa@… 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by d.buffa@…

comment:1 Changed 4 years ago by Zajec

You have totally removed port 8, which is probably CPU port. That way Linux installed on the router doesn't receive any packets.

comment:2 Changed 4 years ago by Zajec

Also you should *not* use VLAN ID 0, it's reserved value:

http://en.wikipedia.org/wiki/IEEE_802.1Q

"The reserved value 0x000 indicates that the frame does not belong to any VLAN;"

comment:3 Changed 4 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to accepted

We probably need a migration script, which migrates old switch configurations to new ones.

Using vlan id 0, is not good, but should work.

comment:4 Changed 4 years ago by hauke

  • Resolution set to not_a_bug
  • Status changed from accepted to closed

Port 8 is the port from the switch to the CPU, if you remove it from all the switch configurations, you can not access the device.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.