Modify

Opened 5 years ago

Closed 5 years ago

#12930 closed defect (fixed)

Cisco E3000 kernel panic error after factory default reset

Reported by: d.buffa@… Owned by: hauke
Priority: highest Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

I would report a kernel panic error on my E3000 after factory default reset. I used r35445, this is the log

CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: Mon Nov  8 16:22:24 CST 2010 (lzh@team2-complier)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.

No DPN
This is a Parallel Flash
Boot partition size = 262144(0x40000)
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.10.56.51
CPU type 0x19740: 480MHz
Tot mem: 65536 KBytes

CFE mem:    0x80700000 - 0x8079DAC0 (645824)
Data:       0x80732A20 - 0x80737080 (18016)
BSS:        0x80737080 - 0x80737AC0 (2624)
Heap:       0x80737AC0 - 0x8079BAC0 (409600)
Stack:      0x8079BAC0 - 0x8079DAC0 (8192)
Text:       0x80700000 - 0x80732A1C (207388)

Boot version: v4.2
The boot is CFE

mac_init(): Find mac [C0:C1:C0:98:D4:3E] in location 0
Nothing...
country_init(): Find country code in location 0
The country is same
Device eth0:  hwaddr C0-C1-C0-98-D4-3E, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Check CRC of image1
  Header CRC:    0xB4F984F1
  Calculate CRC: 0xB4F984F1
Image 1 is OK
Try to load image 1.
Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
Loading: Failed.
Could not load :: Timeout occured
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .. 3780 bytes read
Entry at 0x80001000
Closing network.
Starting program at 0x80001000
[    0.000000] Linux version 3.6.11 (daniele@danfedvm.localdomain) (gcc version 4.6.4 20121210 (prerelease) (Linaro GCC 4.6-2012.12) ) #1 Fri Feb 1 23:28:47 CET 2013
[    0.000000] CPU revision is: 00019740 (MIPS 74Kc)
[    0.000000] bcm47xx: using bcma bus
[    0.000000] bcma: bus0: Found chip with id 0x4716, rev 0x01 and package 0x0A
[    0.000000] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x1F, class 0x0)
[    0.000000] bcma: bus0: Core 3 found: MIPS 74K (manuf 0x4A7, id 0x82C, rev 0x01, class 0x0)
[    0.000000] bcma: bus0: Early bus registered
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 61572k/65536k available (2415k kernel code, 3964k reserved, 520k data, 164k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.032000] Calibrating delay loop... 239.10 BogoMIPS (lpj=478208)
[    0.032000] pid_max: default: 32768 minimum: 301
[    0.032000] Mount-cache hash table entries: 512
[    0.032000] NET: Registered protocol family 16
[    0.052000] bio: create slab <bio-0> at 0
[    0.056000] Switching to clocksource MIPS
[    0.064000] NET: Registered protocol family 2
[    0.064000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.064000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.064000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.064000] TCP: reno registered
[    0.064000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.064000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.064000] NET: Registered protocol family 1
[    0.068000] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x11, class 0x0)
[    0.068000] bcma: bus0: Core 2 found: GBit MAC (manuf 0x4BF, id 0x82D, rev 0x00, class 0x0)
[    0.068000] bcma: bus0: Core 4 found: USB 2.0 Host (manuf 0x4BF, id 0x819, rev 0x04, class 0x0)
[    0.068000] bcma: bus0: Core 5 found: PCIe (manuf 0x4BF, id 0x820, rev 0x0E, class 0x0)
[    0.068000] bcma: bus0: Core 6 found: DDR1/DDR2 Memory Controller (manuf 0x4BF, id 0x82E, rev 0x01, class 0x0)
[    0.068000] bcma: bus0: Core 7 found: Internal Memory (manuf 0x4BF, id 0x80E, rev 0x07, class 0x0)
[    0.068000] bcma: bus0: Core 8 found: I2S (manuf 0x4BF, id 0x834, rev 0x00, class 0x0)
[    0.112000] bcma: bus0: Moved i2s interrupt to oob line 7 instead of 8
[    0.112000] bcma: bus0: PCIEcore in host mode found
[    0.288000] PCI host bridge to bus 0000:00
[    0.288000] pci_bus 0000:00: root bus resource [mem 0x08000000-0x0bffffff]
[    0.288000] pci_bus 0000:00: root bus resource [io  0x0100-0x07ff]
[    0.288000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.288000] bcma: PCI: Fixing up bridge 0000:00:00.0
[    0.288000] bcma: PCI: Fixing up device 0000:00:00.0
[    0.288000] bcma: PCI: Fixing up bridge 0000:00:00.1
[    0.288000] bcma: PCI: Fixing up device 0000:00:00.1
[    0.288000] bcma: PCI: Fixing up addresses 0000:00:01.0
[    0.288000] pci 0000:00:01.0: BAR 0: assigned [mem 0x08000000-0x08003fff 64bit]
[    0.288000] PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
[    0.288000] bcma: PCI: Fixing up device 0000:00:01.0
[    0.312000] ssb: Found chip with id 0x4322, rev 0x01 and package 0x0A
[    0.332000] ssb: chipcommon status is 0x68040
[    0.332000] ssb: SPROM offset is 0x1000
[    0.340000] ssb: WARNING: Using fallback SPROM failed (err -2)
[    0.340000] ssb: WARNING: Invalid SPROM CRC (corrupt SPROM)
[    0.340000] ssb: Unsupported SPROM revision 255 detected. Will extract v1
[    0.392000] ssb: Sonics Silicon Backplane found on PCI device 0000:00:01.0
[    0.396000] bcma: bus0: Bus registered
[    0.400000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.400000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.400000] msgmni has been set to 120
[    0.400000] io scheduler noop registered
[    0.400000] io scheduler deadline registered (default)
[    0.400000] Serial: 8250/16550 driver, 2 ports, IRQ sharing enabled
[    0.424000] serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 2) is a U6_16550A
[    0.892000] console [ttyS0] enabled
[    0.900000] bcm47xx_pflash: flash init: 0x1c000000 0x02000000
[    0.904000] Physically mapped flash: Found 1 x16 devices at 0x0 in 8-bit bank. Manufacturer ID 0x0000c2 Chip ID 0x0000cb
[    0.916000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.924000]   Amd/Fujitsu Extended Query version 1.1.
[    0.928000] number of CFI chips: 1
[    0.932000] bcm47xx_pflash: Flash device: 0x2000000 at 0x1fc00000
[    0.936000] bcm47xx_part: bootloader size: 262144
[    0.944000] bcm47xx_part: Looking for dual image
[    0.948000] bcm47xx_part: TRX offset : 0
[    0.952000] 4 bcm47xx partitions found on MTD device Physically mapped flash
[    0.960000] Creating 4 MTD partitions on "Physically mapped flash":
[    0.968000] 0x000000000000-0x000000040000 : "cfe"
[    0.972000] 0x000000040000-0x0000007f0000 : "linux"
[    0.980000] 0x000000137c00-0x0000007f0000 : "rootfs"
[    0.988000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    1.004000] mtd: partition "rootfs" set to be root filesystem
[    1.008000] mtd: partition "rootfs_data" created automatically, ofs=320000, len=4D0000 
[    1.016000] 0x000000320000-0x0000007f0000 : "rootfs_data"
[    1.024000] 0x0000007f0000-0x000000800000 : "nvram"
[    1.036000] bcm47xx-wdt bcm47xx-wdt.0: BCM47xx Watchdog Timer enabled (30 seconds)
[    1.044000] TCP: cubic registered
[    1.048000] NET: Registered protocol family 17
[    1.052000] 8021q: 802.1Q VLAN Support v1.8
[    1.068000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    1.076000] Freeing unused kernel memory: 164k freed
[    2.696000] diag: Detected 'Linksys E3000 V1'
[    2.968000] bgmac bcma0:1: Found PHY addr: 30 (NOREGS)
[    2.976000] bgmac bcma0:1: Support for Roboswitch not implemented
[    3.008000] bgmac: Broadcom 47xx GBit MAC driver loaded
[    3.180000] roboswitch: Probing device 'eth0'
[    3.184000] roboswitch: found a 53115! It's a 5350. at eth0
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
[    9.892000] jffs2: notice: (337) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 7 of xref (0 dead, 2 orphan) found.
switching to jffs2
- init -

Please press Enter to activate this console. [   13.184000] wl: module license 'unspecified' taints kernel.
[   13.192000] Disabling lock debugging due to kernel taint
[   13.288000] wl0: Broadcom BCM4329 802.11 Wireless Controller 5.10.56.27
[   13.296000] SSB/BCMA glue driver successfully attached
[   13.300000] bcma: PCI: Fixing up device 0000:00:01.0
[   13.332000] wl1: Broadcom BCM4322 802.11 Wireless Controller 5.10.56.27
[   13.456000] PPP generic driver version 2.4.2
[   13.532000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   13.664000] NET: Registered protocol family 24
[   13.692000] nf_conntrack version 0.5.0 (964 buckets, 3856 max)
[   17.708000] device eth0.0 entered promiscuous mode
[   17.712000] device eth0 entered promiscuous mode
[   17.720000] br-lan: port 1(eth0.0) entered forwarding state
[   17.724000] br-lan: port 1(eth0.0) entered forwarding state
[   19.728000] br-lan: port 1(eth0.0) entered forwarding state
[  236.816000] Found board: "Linksys E300"
[  237.768000] Data bus error, epc == 82c05954, ra == 82c30a48
[  237.768000] Oops[#1]:
[  237.768000] Cpu 0
[  237.768000] $ 0   : 00000000 1100dc00 000000a7 00000007
[  237.768000] $ 4   : a8000688 a8000166 00000000 a8000000
[  237.768000] $ 8   : 00000020 80133770 00000800 00000010
[  237.768000] $12   : 00000000 00000010 00000000 00ffff00
[  237.768000] $16   : 00000020 830b0000 830b0bd4 00000280
[  237.768000] $20   : 00000002 00000001 830b070c 00000000
[  237.768000] $24   : 00000008 82d40000                  
[  237.768000] $28   : 83076000 830776d0 830776e0 82c30a48
[  237.768000] Hi    : 00000000
[  237.768000] Lo    : 82d3e0e0
[  237.768000] epc   : 82c05954 osl_readw+0x4/0xc [wl]
[  237.768000]     Tainted: P           O
[  237.768000] ra    : 82c30a48 wlc_edcf_setparams+0x208/0x2f0 [wl]
[  237.768000] Status: 1100dc03    KERNEL EXL IE 
[  237.768000] Cause : 8080001c
[  237.768000] PrId  : 00019740 (MIPS 74Kc)
[  237.768000] Modules linked in: nf_nat_irc nf_nat_ftp nf_conntrack_irc nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat pppoe xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppox ipt_REJECT xt_TCPMSS xt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc wl(PO) wl_glue(O) crc_ccitt switch_robo(O) switch_core(O) bgmac b44 tg3 hwmon diag(O)
[  237.768000] Process luci (pid: 1053, threadinfo=83076000, task=8385c078, tls=77b7f440)
[  237.768000] Stack : 000001e0 00000081 83259900 830b0000 00070bc0 0007000f 00050002 01000007
        00000000 00000000 00000000 00000000 8309ce80 830b0000 00001b24 83077744
        830b070c 83077748 0000007f 00000108 0000024c 82c43c00 00000004 82c67d64
        00000004 830b070c 0000007f 00000001 00000001 00000001 00000008 2498128c
        6c6048b0 830b0000 83ab2c00 00ffff00 00000000 00000000 00000000 83077e00
        ...
[  237.768000] Call Trace:
[  237.768000] [<82c05954>] osl_readw+0x4/0xc [wl]
[  237.768000] [<82c30a48>] wlc_edcf_setparams+0x208/0x2f0 [wl]
[  237.768000] [<82c43c00>] wlc_init+0x32c/0x51c [wl]
[  237.768000] [<82c31d40>] wlc_up+0x1b0/0x294 [wl]
[  237.768000] [<82c049c4>] wl_up+0x2c/0xd4 [wl]
[  237.768000] [<82c04a24>] wl_up+0x8c/0xd4 [wl]
[  237.768000] [<801ca07c>] __dev_open+0x144/0x22c
[  237.768000] [<801ca190>] dev_open+0x2c/0x68
[  237.768000] [<82c0005c>] 0x82c0005c
[  237.768000] 
[  237.768000] 
Code: 03e00008  00000000  94820000 <03e00008> 3042ffff  90820000  03e00008  304200ff  aca40000 
[  237.996000] ---[ end trace dda044116609e575 ]---
[  238.004000] Kernel panic - not syncing: Fatal exception in interrupt
[  238.004000] ------------[ cut here ]------------
[  238.004000] WARNING: at lib/vsprintf.c:1376 vsnprintf+0x6c/0x3a4()
[  238.004000] Modules linked in: nf_nat_irc nf_nat_ftp nf_conntrack_irc nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat pppoe xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppox ipt_REJECT xt_TCPMSS xt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc wl(PO) wl_glue(O) crc_ccitt switch_robo(O) switch_core(O) bgmac b44 tg3 hwmon diag(O)
[  238.004000] Call Trace:
[  238.004000] [<80256314>] dump_stack+0x8/0x34
[  238.004000] [<80018598>] warn_slowpath_common+0x78/0xa4
[  238.004000] [<800185dc>] warn_slowpath_null+0x18/0x24
[  238.004000] [<801311f8>] vsnprintf+0x6c/0x3a4
[  238.004000] [<8005cb9c>] crashlog_printf+0x4c/0x68
[  238.004000] [<8005cc0c>] crashlog_do_dump+0x54/0x138
[  238.004000] [<8001bca8>] kmsg_dump+0x10c/0x148
[  238.004000] [<802563e4>] panic+0xa4/0x1e4
[  238.004000] [<8000b688>] die+0x138/0x140
[  238.004000] [<8000b9d0>] do_be+0x168/0x1ac
[  238.004000] [<80005c40>] ret_from_exception+0x0/0x24
[  238.004000] [<82c05954>] osl_readw+0x4/0xc [wl]
[  238.004000] [<82c30a48>] wlc_edcf_setparams+0x208/0x2f0 [wl]
[  238.004000] [<82c43c00>] wlc_init+0x32c/0x51c [wl]
[  238.004000] [<82c31d40>] wlc_up+0x1b0/0x294 [wl]
[  238.004000] [<82c049c4>] wl_up+0x2c/0xd4 [wl]
[  238.004000] [<82c04a24>] wl_up+0x8c/0xd4 [wl]
[  238.004000] [<801ca07c>] __dev_open+0x144/0x22c
[  238.004000] [<801ca190>] dev_open+0x2c/0x68
[  238.004000] [<82c0005c>] 0x82c0005c
[  238.004000] 
[  238.004000] ---[ end trace dda044116609e576 ]---
[  238.004000] Rebooting in 3 seconds..
[  238.004000] Please stand by while rebooting the system...

The issue appears after login in luci, and exacly during rendering of status / overview page. I noticed that the issue is also present displaying network page, and I found this strange network config file

root@OpenWrt:/# cat /etc/netconfig/network
#### VLAN configuration 
config switch eth0
option enable   1

config switch_vlan eth0_0
option device   "eth0"
option vlan     0
option ports    "1 2 3 4 8*"

config switch_vlan eth0_1
option device   "eth0"
option vlan     1
option ports    "0 8"

#### Loopback configuration
config interface loopback
option ifname"lo"
option protostatic
option ipaddr127.0.0.1
option netmask255.0.0.0


#### LAN configuration
config interface lan
option type bridge
option ifname"eth0.0"
option protostatic
option ipaddr192.168.1.1
option netmask255.255.255.0


#### WAN configuration
config interfacewan
option ifname"eth0.1"
option protodhcp
root@OpenWrt:/# 

This file appears malformed in serial console log output. It also contains "strange" comments that it's the first time I saw in this. And this is not mine, it's the result of factory default reset. For what I can see the file contains tab letter instead of spaces. Replacing the file with one with spaces I resolved the issue. This is the "fixed" file

config switch 'eth0'
        option enable '1'

config switch_vlan 'eth0_0'
        option device 'eth0'
        option vlan '0'
        option ports '1 2 3 4 8*'

config switch_vlan 'eth0_1'
        option device 'eth0'
        option vlan '1'
        option ports '0 8'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

I attach the malformed file

Thanks
Daniele Buffa

Attachments (2)

network (661 bytes) - added by d.buffa@… 5 years ago.
malformed network config file
913-avoid-dbe-on-ifs_ctl-readw-hack.patch (262 bytes) - added by nlh 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by d.buffa@…

malformed network config file

comment:1 Changed 5 years ago by anonymous

EDIT: the config file with spaces doesn't resolve the issue.

comment:2 Changed 5 years ago by nlh

You can add "option wmm 0" to the wl1 wireless device, or you can try adding the attached patch (hack) to "broadcom-wl" that worked around the problem for me.

See http://www.spinics.net/lists/linux-wireless/msg100095.html

comment:3 Changed 5 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to accepted

comment:4 Changed 5 years ago by hauke

Does this hack fix the problem for you?

comment:5 Changed 5 years ago by anonymous

The ""option wmm 0" fix for me, i have to test the submitted patch?

comment:6 Changed 5 years ago by hauke

  • Resolution set to fixed
  • Status changed from accepted to closed

Thank you for the patch, it was applied in r35767.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.