Modify

Opened 5 years ago

Closed 5 years ago

#12910 closed defect (fixed)

resolv.conf.auto empty when setting DNS and default gateway

Reported by: roecker@… Owned by: nbd
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Setting a gateway and a custom DNS server on an interface with static address (using luci) results in an empty /tmp/resolv.conf.auto.

Since the configuration is written to /etc/config/network correctly, a "network restart" or system reboot leads to a correctly written resolv.conf.auto. Also changing/setting only the DNS server works fine. I can reproduce this on [35323] and a old system running [31853]

To make sure I made myself clear here is what I do:

  1. Navigate to Network --> Interfaces using luci
  2. Click "Edit" on your WAN Interface
  3. Choose Protocol: "Static address" and push "Switch protocol"
  4. Enter an "IPv4 address"
  5. Enter an "IPv4 netmask"
  6. Enter an "IPv4 gateway"
  7. Enter an "Use custom DNS servers"
  8. Click "Save & Apply"

==> /tmp/resolv.conf.auto is empty

  1. /etc/init.d/network restart (or reboot)

==> /tmp/resolv.conf.auto written correctly

If you need more information please let me know!

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by jow

  • Owner changed from developers to nbd
  • Status changed from new to assigned

LuCI issues an /etc/init.d/network reload after the config has been written.

comment:2 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r35383

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.