Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#12909 closed defect (fixed)

pptpd stoped working on latest trunk

Reported by: finas@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

pptp client cannot connect and the logged error is:
Jan 28 13:41:03 gateway daemon.err pppd[5395]: unrecognized option '???????????????92.168.88.220'

pertinent option on /etc/pptpd.conf is:

remoteip 192.168.88.220-230

Attachments (0)

Change History (12)

comment:1 Changed 5 years ago by dgolle@…

As PPtP was widely replaced by L2TP, pptpd is obsolete and was last touched more than two years ago. I put some effort into porting accel-pptp some time ago (r32197), however, as my main goal was to provide client-side backward-compatibility I ended up using the pppd-plugin client-only implementation as the base for my work.
I recommend you to migrate to xl2tpd (+strongswan to provide IPSec IKE where security is needed).
Adapting
http://agit8.turbulent.ca/bwp/2011/01/setting-up-a-vpn-server-with-ubuntu-1004-and-strongswan/
to OpenWrt should be straight forward regarding both, the xl2tpd and strongswan part.
Just as when using pptp you'll still need to add rules for the ppp+ interfaces to /etc/firewall.user
In this way you can provide an L2TP + IPSec (IKEv1) server which native Mac OS and Windows clients can connect to.

comment:2 Changed 5 years ago by finas@…

Hi dgolle,

thanks for the tips on L2TP. I'm going to try to get it running in a couple of days.
Also thanks for the accell-pptp. I'm using a OpenWRT box to connect to several PPTP conections at the same time, and the diference in speed is noticiable.

Regarding PPTP, I have an old unixware machine that connects to me via PPTP and that I really don't want to touch. I'm hopping that you can took some time to look at it. Maybe it's a trivial fix!

Thanks
Pedro

comment:3 Changed 5 years ago by anonymous

I have got similar message with svn r36370:
pppd[26281]: unrecognized option '???????????????168.1.1'
The funny thing is I do not even have a remoteip/localip line in /etc/pptpd.conf or and ppp/pptp related config files, and my lan ip is not 192.168.1.0/24. If I add remoteip in to pptpd.conf, the error message will change and complain the new line I added.
I used the same config files on an older router running Attitude Adjustment, (some svn version after rc1), I can connect to the older one without any glitch. but even after I copied the pppd binary to the new route the error message is still the same.

comment:4 follow-up: Changed 5 years ago by anonymous

Just tried the trunk yesterday, it seems the bug is fixed and pptp is working again (r36815)

comment:5 Changed 5 years ago by finas

not for me. tried latest trunk just now and the problem is still there. :(

comment:6 in reply to: ↑ 4 Changed 5 years ago by finas

Replying to anonymous:

Just tried the trunk yesterday, it seems the bug is fixed and pptp is working again (r36815)

Can you tell me the steps taken to build the image, menuconfig options that are not default and that may afect the build?

thanks

comment:7 Changed 5 years ago by anonymous

I just followed the official howto:
http://wiki.openwrt.org/doc/howto/build
I use a baffulo WZR-600DHP, so I only have .config file for this model, and I also added a few packages from the feeds and the web, if you want I can paste the config somewhere, but I doubt it would help. You can start with just enable pptp related options and keep everything else to default

comment:8 Changed 5 years ago by finas

I found the problem:

selecting gcc 4.8.0 or gcc 4.8.0 with linaro extensions ( on toolchain options ) will trigger the problem. gcc 4.6.3 or gcc 4.6.3 with linaro extensions works fine, pptp works with no errors.

I tried messing with the target optimizations, namely, changing -Os to -O1, -O2, -O3, with no luck. Also tried enabeling "Stack-Smashing Protection support" and "Use setjump()/longjump() exceptions" and the problem remains. As long as gcc 4.8.0 is used, pptp doesn't work.

comment:9 Changed 4 years ago by anonymous

solved in latest trunk. can be closed.

comment:10 Changed 4 years ago by finas

solved in latest trunk

comment:11 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed some time ago or in r40671.

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.