Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12877 closed defect (invalid)

Cannot install kernel modules due to incompatible versions (unsatisfied dependency)

Reported by: mkletzan@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

When I install Attitude Adjustment (both betas, rc1) or latest Barrier Breaker (2013-01-22), the kernel version installed is incompatible with kernel module versions, so for example no usb support etc. can be installed. I tried various package lists.

The device is TP-Link WDR4300.

The information provided here should be enough to describe the situation:

root@gw0:~# opkg update
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-beta2/ar71xx/generic/packages/Packages.gz.
Inflating http://downloads.openwrt.org/attitude_adjustment/12.09-beta2/ar71xx/generic/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment_beta2.
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-beta/ar71xx/generic/packages/Packages.gz.
Inflating http://downloads.openwrt.org/attitude_adjustment/12.09-beta/ar71xx/generic/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment_beta.
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/Packages.gz.
Inflating http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment_rc1.
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/barrier_breaker.
root@gw0:~# opkg list kmod-usb2
kmod-usb2 - 3.3.8-1 - Kernel support for USB2 (EHCI) controllers
kmod-usb2 - 3.7.3-1 - Kernel support for USB2 (EHCI) controllers
root@gw0:~# uname -r
3.6.11
root@gw0:~# head /etc/openwrt_*
==> /etc/openwrt_release <==
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r34812"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker r34812"

==> /etc/openwrt_version <==
r34812

In case I missed anything, feel free to ask.

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

Kernel module packages are only compatible with the specific firmware image that they were built with. Changing .config can be enough to make the resulting modules incompatible with a previous build. Stick to using packages from the same build that you flashed on your system.

comment:2 Changed 5 years ago by mkletzan@…

That is exactly what I am doing.

Kernel in both trunk and 12.09-rc1 is 3.6.11, but the modules are built for 3.7.3-1 (trunk) and 3.3.8-1 (12.09-rc1). The reason I modified the configurations is that I just wanted to show that it is broken in beta, beta2, rc1 and trunk.

I realized this when I updated to trunk and (without any changes) wanted to install usb storage support, so I believe this is not invalid.

If you want me to re-flash and try anything else, just tell me, but it is not possible to install it (on ar71xx at least) right now.

comment:3 Changed 5 years ago by nbd

My point is, you cannot do your own build and expect to be able to install kernel modules from the snapshot or release build repository.
If you flash 12.09-rc1 binaries from the site, they are compatible with kmod-* packages from the same location.
If you flash snapshot binaries, they will be compatible as long as no new snapshot with a changed kernel config comes along. After that, you cannot install from it anymore.

comment:4 Changed 5 years ago by mkletzan@…

I haven't done my own build (even though I'm thinking about it since that should make it work). I can flash it cleanly (again) and show you that it doesn't work even then. Would that help?

comment:5 Changed 5 years ago by nbd

You say that you've flashed latest Barrier Breaker, but the revision number r34812 indicates that you've either flashed something from December, or that there are some leftover files on your rootfs overlay that break the system.
Maybe a clean reflash (without keeping any config) will fix your issues.

comment:6 Changed 5 years ago by mkletzan@…

I'm not sure which was the latest one I tried. I was trying different (official) builds to get to the point where it will hopefully work. I'll re-flash it without keeping the configs and in case it won't help, I'll reopen this ticket with new information.

Thanks for spending the time on this issue.

comment:7 Changed 5 years ago by mkletzan@…

I had to re-flash to original TP-Link firmware and than flash again with squashfs-factory image. No other things I've tried helped, since all of them kept the old kernel in place. That is most probably the reason why I had r34812 with 3.6.11 even though I sysupgraded the device many times. Since then, I must say I'm not sure how the sysupgrade should work and why it didn't, but because I finally have the device up, running and configured, I don't want to try reproducing that.

Sorry for taking your time with this issue, have a nice day.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.