Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12876 closed defect (fixed)

Selecting ipv6 functionality breaks ipv4 WAN

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Router: WNDR3700
svn version: 35300

Built from source.
When I select certain packages (see diff) after flashing sysupgrade
my WAN connection breaks (Destination Host unreachable from LAN clients, ping from WNDR3700 doesnt work too).
Restoring via sysupgrade to previous version fixes it.

in case of build issues:
the working image was compiled from a clean svn
nonworking was by selecting the packages and simple "make" (no clean before)
working was by copying .config and running make again (no clean before)

See attached diff

Attachments (6)

diff-config.txt (1.9 KB) - added by anonymous 5 years ago.
.config patch file
error.ifconfig.txt (2.5 KB) - added by anonymous 5 years ago.
error.ping.txt (821 bytes) - added by anonymous 5 years ago.
login with nonworking ping
error.route.txt (358 bytes) - added by anonymous 5 years ago.
error.ubus.wan.status.txt (1.3 KB) - added by anonymous 5 years ago.
.config (139.7 KB) - added by anonymous 5 years ago.
nonworking config

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by anonymous

.config patch file

comment:1 Changed 5 years ago by anonymous

Looks like you using the "old style" ipv6. You have radvd and 6scripts. Espcially 6scripts looks unnecessary, but radvd functionality ahs been implemented more compatibly with the new ipv6-support module.

You should drop radvd, luci-app-radvd and 6scripts, and select ipv6-support instead.

comment:2 Changed 5 years ago by cyrus

  • Resolution set to too_vague
  • Status changed from new to closed

Please provide more information about your issue (output of "ifconfig", "route", "ubus call network.inteface.wan status") and our configuration and other relevant information.

Also the packages you are using for IPv6 are deprecated. Please deselect them and use ipv6-support, 6in4 and luci-proto-ipv6 instead.

comment:3 Changed 5 years ago by cyrus

You can find examples and documentation about the new IPv6 features here:
http://wiki.openwrt.org/doc/uci/network6
http://wiki.openwrt.org/doc/uci/network

comment:4 Changed 5 years ago by anonymous

@cyrus:
should developers remove the deprecated packages from svn? E.g. 6scripts and 6tunnel contain mostly 3-5 year old code, so I wonder if they are compatible with netifd. People may use them by accident and end up in trouble...
https://dev.openwrt.org/browser/packages/ipv6/6scripts
https://dev.openwrt.org/browser/packages/ipv6/6tunnel

Changed 5 years ago by anonymous

Changed 5 years ago by anonymous

login with nonworking ping

Changed 5 years ago by anonymous

Changed 5 years ago by anonymous

Changed 5 years ago by anonymous

nonworking config

comment:5 follow-up: Changed 5 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

Thank you for your advice.

I added logs and the build .config file that generates a nonworking image at my end.

I couldn't replicate the problem with a trunk image and installing the packages via opkg that broke my build.

comment:6 in reply to: ↑ 5 Changed 5 years ago by hnyman <hannu.nyman@…>

Replying to anonymous:

Thank you for your advice.

apparently you did not follow the advice, as you are still using old deprecated modules like 6scripts and you did not select the current "ipv6-support" module. Drop 6scripts, radvd and luci-app-radvd, use ipv6-support and luci-proto-ipv6 instead.

If you want a working wndr3700 build with ipv6 support, you might try either my build or its .config. Available here: https://forum.openwrt.org/viewtopic.php?id=28392

comment:7 Changed 5 years ago by anonymous

I just wanted to report a bug(?) in those packages (or the build) that are still available in SVN.

I did follow the advice. I use those recommended packages now and have working IPv6 connectivity.

I did select them (deprecated packages), because they are available and not marked as broken/deprecated/removed in the SVN. My previous old image was a self compiled one, where I used these packages.

I just opened the ticked to provide some information about a potential issue.
I don't have enough time or knowledge/power to delve into the issue any further and fix/remove those packages that might be deprecated anyway.

comment:8 Changed 5 years ago by cyrus

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r35313

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.