Modify

Opened 5 years ago

Closed 5 years ago

#12855 closed defect (fixed)

SNMPd requires non-exsisting dependencies

Reported by: nakebod@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: snmpd, argp-standalone Cc:

Description

For what it matters, I'm running hnymans IPv6 trunk build on my Netgear WNDR3800.

Installing snmpd (5.4.2.1-5) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/snmpd_5.4.2.1-5_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for snmpd:
  • argp-standalone *
  • opkg_install_cmd: Cannot install package snmpd.

I think this problem started at/near 5-Jan-2013, I believe I saw a new date of all the packages around that time. Current date of the packages is 19-Jan-2013. I forgot about this problem, until I flashed a new IPv6 build today and needed to install SNMPd again.

Before that date it wasn't a problem to install SNMPd.
I found an older SNMPd .ipk file, although the filename/version is exactly the same. The date for this package is unknown, but if I unzip the ipk file, there are files dated 14-Nov-2011.

If I install the following 3 packages manually, SNMPd works fine:
libelf_0.8.13-1_ar71xx.ipk, libnetsnmp_5.4.2.1-5_ar71xx.ipk, snmpd_5.4.2.1-5_ar71xx.ipk

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

This dependency comes from libelf1, fixed with r35261

comment:2 Changed 5 years ago by christian@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

For me this problem still exists.

Tried to install snmpd today (4.2.13, libelf1 seems to be build yesterday):

root@ap1:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
root@ap1:~# opkg install snmpd
Installing snmpd (5.4.2.1-5) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/snmpd_5.4.2.1-5_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for snmpd:
 * 	argp-standalone * 
 * opkg_install_cmd: Cannot install package snmpd.

comment:3 Changed 5 years ago by BeefEater

The dependency on argp-standalone comes from libelf1. However, libelf.so does not appear to contain any reference to "argp" or even "arg". It looks like this dependency was introduced by mistake; therefore, it should be safe to force-install libelf1.

comment:4 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with r35557

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.