Modify

Opened 5 years ago

Last modified 4 years ago

#12823 new defect

Installation on Ubiquiti Unifi fails with invalid version

Reported by: chris@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: unifi installlation SSH Cc:

Description

Hi,

Attempting to install via the documented method using the SSH terminal fails with an invalid version error, Have tried builds for the last few days as well as on from a while back. Have seen similar errors posted on the net with include editing files that I'm assuming is something that needs to be done pre-build. Also the edits prescribed seem to vary depending on the build revision so I offer this as a ticket for the very latest builds.

Output:

BZ.v2.3.9# fwupdate.real -m openwrt-ar71xx-generic-ubnt-unifi-squashfs-factory.bin -d
Found mtd block: /dev/mtd0(u-boot)
Found mtd block: /dev/mtd1(u-boot-env)
Found mtd block: /dev/mtd2(kernel)
Found mtd block: /dev/mtd3(rootfs)
Found mtd block: /dev/mtd4(cfg)
Found mtd block: /dev/mtd5(EEPROM)
Got U-Boot variable: mtdparts = mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),1024k(kernel),6528k(rootfs),256k(cfg),64k(EEPROM)
Adding U-Boot partition: u-boot 9F000000 00040000
Adding U-Boot partition: u-boot-env 9F040000 00010000
Adding U-Boot partition: kernel 9F050000 00100000
Adding U-Boot partition: rootfs 9F150000 00660000
Adding U-Boot partition: cfg 9F7B0000 00040000
Adding U-Boot partition: EEPROM 9F7F0000 00010000
Calculating flash size:
Adding block: /dev/mtd0("u-boot") - size: 00040000
Adding block: /dev/mtd1("u-boot-env") - size: 00010000
Adding block: /dev/mtd2("kernel") - size: 00100000
Adding block: /dev/mtd3("rootfs") - size: 00660000
Adding block: /dev/mtd4("cfg") - size: 00040000
Adding block: /dev/mtd5("EEPROM") - size: 00010000
Total flash size: 00800000
Flash start: 9F000000
Flash end: 9F800000
Header MAGIC 'OPEN'
Current: BZ.ar7240.v2.3.9.1693.121221.1336
New ver: XM.ar7240.v6.0.0-OpenWrt-r35162
Invalid version 'XM.ar7240.v6.0.0-OpenWrt-r35162'
BZ.v2.3.9#

Thanks,
Chris

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

Got the same error ending with XM.ar7240.v6.0.0-OpenWrt-r35181

comment:2 Changed 5 years ago by Seikku.OpenWRT@…

Same error, Invalid version 'XM.ar7240.v6.0.0-OpenWrt-r36088'

My guess is the Ubiquiti loader disqualifies the image 'XM' as an image for wrong hardware. Same happens on trying wrong prefix Ubiquiti image for upgrade using Ubiquiti GUI on other models (such as trying XM5 image for XS5 hardware). I guess the Unifi prefix could be BZ, unfortunately I could not find any image file for Unifi "fire alarm" device to check it.

Anyone with development environment already set up willing to give it a try?

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.