Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#1282 closed defect (worksforme)

Openswan compile error on brcm-2.4

Reported by: szsoftware Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

Since some revisions I'm not able to build kamikaze with openswan.

echo "Description: Openswan (kernel module)\\ Openswan is an IPsec implementation for Linux. \ \ This package contains the Openswan kernel module." | sed -e 's,\\,\n,g' | sed -e 's,^[[:space:]]*$, .,g' >> /home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/ipkg/kmod-openswan/CONTROL/control
chmod 644 /home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/ipkg/kmod-openswan/CONTROL/control
(cd /home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/ipkg/kmod-openswan/CONTROL; var2file "V_Package_kmod_openswan_conffiles" conffiles; var2file "V_Package_kmod_openswan_preinst" preinst; var2file "V_Package_kmod_openswan_postinst" postinst; var2file "V_Package_kmod_openswan_prerm" prerm; var2file "V_Package_kmod_openswan_postrm" postrm; )
mkdir -p /home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/ipkg/kmod-openswan/lib/modules/2.4.34
cp -fpR /home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/modobj*/ipsec.o /home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/ipkg/kmod-openswan/lib/modules/2.4.34/
cp: will not overwrite just-created `/home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/ipkg/kmod-openswan/lib/modules/2.4.34/ipsec.o' with `/home/sven/openWrt/kamikaze/trunk/build_mipsel/openswan-2.4.7/modobj26/ipsec.o'
make[4]: *** [/home/sven/openWrt/kamikaze/trunk/bin/packages/kmod-openswan_2.4.34+2.4.7-brcm-1_mipsel.ipk] Error 1
make[4]: Leaving directory `/home/sven/openWrt/kamikaze/trunk/package/openswan'
make[3]: *** [openswan-compile] Error 2
make[3]: Leaving directory `/home/sven/openWrt/kamikaze/trunk/package'
make[2]: *** [compile] Error 2
make[2]: Leaving directory `/home/sven/openWrt/kamikaze/trunk/package'
make[1]: *** [package/compile] Error 2
make[1]: Leaving directory `/home/sven/openWrt/kamikaze/trunk'

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by szsoftware

This happens even with PACKAGE_openswan [=n]

comment:2 Changed 11 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

Should be fixed now, I cannot reproduce the bug.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.