Modify

Opened 5 years ago

Last modified 4 years ago

#12815 new defect

Generating image failed

Reported by: wjguo.openwrt@… Owned by: developers
Priority: lowest Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by florian)

I built it with CONFIG_TARGET_ramips. The progress will be stop at generating image files.

Log as the following:

 mkimage -A mips -O linux -T kernel -C lzma -a 0x80000000 -e  0x80000000 -n "MIPS OpenWrt Linux-3.7.2" -d /home/bruce/project/openwrt/trunk_dir/build_dir/target-mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk-w300nh2.bin.lzma  /home/bruce/project/openwrt/trunk_dir/build_dir/target-mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk-w300nh2.uImage
 Image Name:   MIPS OpenWrt Linux-3.7.2
 Created:      Tue Jan 15 10:32:14 2013
 Image Type:   MIPS Linux Kernel Image (lzma compressed)
 Data Size:    857328 Bytes = 837.23 kB = 0.82 MB
 Load Address: 80000000
 Entry Point:  80000000
 if [ `stat -c%s   "/home/bruce/project/openwrt/trunk_dir/build_dir/target-mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk-w300nh2.uImage"` -gt 851968 ]; then echo "Warning: /home/bruce/project/openwrt/trunk_dir/build_dir/target-mipsel_r
2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk-w300nh2.uImage is too big"; else if [ `stat -c%s /home/bruce/project/ope
nwrt/trunk_dir/build_dir/target-mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs` -gt 2883584 ]; then echo "War
ning: /home/bruce/project/openwrt/trunk_dir/build_dir/target-mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs i
s too big"; else ( dd   if=/home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt3
 05x/vmlinux-mzk-w300nh2.uImage bs=851968 conv=sync; dd  if=/home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs ) >  /home/bruce/project/openwrt/trunk_dir/bin/ramips/openwrt-ramips-rt3
 05x-mzk-w300nh2-squashfs-sysupgrade.bin; fi; fi
 Warning: /home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk-w300nh2.uImage is too big
 if [ `stat -c%s  "/home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk-w300nh2.uImage"` -gt `expr 851968 - 20` ]; then echo  "Warning: /home/bruce/project/openwrt/trunk_dir/build_dir/tar
 get-mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk- w300nh2.uImage is too big"; else if [ `stat -c%s /home/bruce 
 /project/openwrt/trunk_dir/build_dir/target-mipsel_r2_uClibc- 0.9.33.2/linux-ramips_rt305x/root.squashfs` -gt 2883584 ]; then   echo "Warning:  /home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs is too  big"; else ( dd  if=/home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk- w300nh2.uImage bs=`expr 851968 - 20` conv=sync; dd  if=/home/bruce/project/openwrt/trunk_dir/build_dir/target- mipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/root.squashfs ) >  /home/bruce/project/openwrt/trunk_dir/bin/ramips/openwrt-ramips- rt305x-mzk-w300nh2-squashfs-factory.bin; fi; fi
 Warning: /home/bruce/project/openwrt/trunk_dir/build_dir/target-m ipsel_r2_uClibc-0.9.33.2/linux-ramips_rt305x/vmlinux-mzk- w300nh2.uImage is too big
 mkedimaximg -i  /home/bruce/project/openwrt/trunk_dir/bin/ramips/openwrt-ramips- rt305x-mzk-w300nh2-squashfs-factory.bin -o  /home/bruce/project/openwrt/trunk_dir/bin/ramips/openwrt-ramips-rt305x-mzk-w300nh2-squashfs-factory.bin -s CSYS -m RN52 -f 0x50000  -S 0xc0000;
 stat failed on  /home/bruce/project/openwrt/trunk_dir/bin/ramips/openwrt-ramips- rt305x-mzk-w300nh2-squashfs-factory.bin
 Usage: mkedimaximg [OPTIONS...]
 
 Options:
  -s <sig>        set image signature to <sig>
  -m <model>      set model to <model>
  -i <file>       read input from file <file>
  -o <file>       write output to file <file>
  -f <flash>      set flash address to <flash>
  -S <start>      set start address to <start>
 make[5]: *** [install] Error 1
 make[5]: Leaving directory  `/home/bruce/project/openwrt/trunk_dir/target/linux/ramips/image'
 make[4]: *** [install] Error 2
 make[4]: Leaving directory  `/home/bruce/project/openwrt/trunk_dir/target/linux/ramips'
 make[3]: *** [install] Error 2
 make[3]: Leaving directory  `/home/bruce/project/openwrt/trunk_dir/target/linux'
 make[2]: *** [target/linux/install] Error 2
 make[2]: Leaving directory  `/home/bruce/project/openwrt/trunk_dir'
 make[1]: ***  [/home/bruce/project/openwrt/trunk_dir/staging_dir/target- mipsel_r2_uClibc-0.9.33.2/stamp/.target_install] Error 2
 make[1]: Leaving directory `/home/bruce/project/openwrt/trunk_dir'
 make: *** [world] Error 2

I tried to mark some function in target/linux/ramips/image/Makefile and it works well. Hope this information helpful to you.

254 #define BuildFirmware/Edimax
255 # if [ -e "$(call sysupname,$(1),$(2))" ]; then \
256 # mkedimaximg -i $(call sysupname,$(1),$(2)) \
257 # -o $(call imgname,$(1),$(2))-factory.bin \
258 # -s $(3) -m $(4) -f $(5) -S $(6); \
259 # fi
260 #endef
...
421 #define BuildFirmware/MZKW300NH2
422 # $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_mzkw300nh2))
423 # $(call CatFiles,$(KDIR)/vmlinux-$(2).uImage,expr $(kernel_size_mzkw300nh2) - 20,$(KDIR)/root.$(1),$(rootfs_size_
424 # mkedimaximg -i $(call imgname,$(1),$(2))-factory.bin \
425 # -o $(call imgname,$(1),$(2))-factory.bin \
426 # -s CSYS -m RN52 -f 0x50000 -S 0xc0000;
427 #endef
428
429 #define BuildFirmware/MZKW300NH2/initramfs
430 # $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_mz
431 #endef

Attachments (1)

config (70.8 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by anonymous

comment:1 Changed 5 years ago by Amit Mendapara <mendapara.amit@…>

I am seeing the same error. I have also tried with the image builder package from the latest snapshot build (ramips). It complains about big kernel size. The expected kernel size for GENERIC_8M devices is 917504 but it's bigger.

comment:2 Changed 5 years ago by florian

  • Description modified (diff)

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.