Modify

Opened 5 years ago

Last modified 4 years ago

#12779 new defect

LAN not working with current AR7 on DSL-2640T (ADM6996M)

Reported by: jasmine.aura@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: AR7 ADM6996M DSL-2640T Cc:

Description

Unable to ping router from any computer connected to any of the LAN ports (and assigned static IP in same default subnet 192.168.1.x).

Tried with prebuilt Attitude Adjustment RC1 for AR7
And built OpenWRT r34879 (built with gargoyle 1.5.x, f73df29)

Also tried changing /etc/config/network as described in #11771 , but that doesn't seem to help either. Return to default network config, same.

The PHY seems to be initialized, connecting ethernet cable lights up the port and shows connected on the PC, but cannot ping router.

If I remove /etc/config/network , reboot router , ifconfig eth0 192.168.1.1 , I can then ping router.

Attached is boot log of r34879, with only 1 computer connected to port 4.

Is there any other information I could provide to help solve this?

Attachments (1)

r34879.log.txt (10.5 KB) - added by jasmine.aura@… 5 years ago.
Bootlog over serial for build r34879

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by jasmine.aura@…

Bootlog over serial for build r34879

comment:1 Changed 5 years ago by jasmine.aura@…

Another way to be able to ping the router:

In /etc/config/network, under "config interface lan"

Changing:
option ifname "eth0 eth1 eth0.1 eth0.2"

to:
option ifname "eth0 eth1"

then
/etc/init.d/network restart

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.