Modify

Opened 5 years ago

Closed 5 years ago

#12761 closed defect (fixed)

gpio-nxp-74hc153 support not built in ar71xx trunk anymore

Reported by: anonymous Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

gpio-nxp-74hc153 support is not compiled into latest ar71xx kernels though it was previously bundled into kernel up to r34411 (see buildbot log for working 3.3 kernel)

DMESG excerpt for latest working r34411:

[    0.090000] gpiochip_add: registered GPIOs 0 to 21 on device: ath79
[    0.100000] MIPS: machine is Buffalo WZR-HP-G300NH
[    0.100000] Found an RTL8366S switch
[    0.560000] bio: create slab <bio-0> at 0
[    0.570000] gpiochip_add: registered GPIOs 32 to 39 on device: nxp-74hc153

Issue might be related to ticket:12690 and ticket:12549 and probably caused by incomplete patches in these changesets

trunk/target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch@33983
trunk/target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch@34920

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

450-gpio-nxp-74hc153-gpio-chip-driver.patch for 3.3 ar71xx kernel appears to include gpio-nxp-74hc153.o

comment:2 Changed 5 years ago by anonymous

nxp-74hc153 support is seemingly missing since r34414

comment:3 Changed 5 years ago by juhosg

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r35035.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.