Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12756 closed defect (fixed)

SE505v2: roboswitch: timeout in robo_reg with trunk/r35016

Reported by: freifunk@… Owned by: hauke
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: roboswitch, se505v2 Cc:

Description

Hi,

there seems to be a problem with current trunk (r35016) on SE505v2 (ram upgraded to 32 MB). In dmesg there are a LOT (starting at about 7 seconds after power on) of these lines:

[   60.252000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1.                                                                                                 
[   60.260000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1.                                                                                                 
[   60.268000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1.                                                                                                 
[   60.308000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1.                                                                                                 
[   60.316000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1.                                                                                                 
[   60.324000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1.                                                                                                 
[   60.380000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1.                                                                                                 
[   60.388000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1.                                                                                                 
[   60.396000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1.                                                                                                 
[   60.452000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1.                                                                                                 
[   60.460000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1.                                                                                                 
[   60.468000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1.                                                                                                 
[   60.524000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1. 
[   60.532000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1. 
[   60.540000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1. 
[   60.644000] roboswitch: timeout in robo_reg on page 52 and reg 16 with op 1.
[   60.652000] roboswitch: timeout in robo_reg on page 52 and reg 18 with op 1.
[   60.660000] roboswitch: timeout in robo_reg on page 52 and reg 20 with op 1.
[   60.668000] roboswitch: timeout in robo_reg on page 52 and reg 22 with op 1.
[   60.676000] roboswitch: timeout in robo_reg on page 52 and reg 26 with op 1.
[   60.684000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1. 
[   60.688000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1. 
[   60.696000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1. 
[   60.740000] roboswitch: timeout in robo_reg on page 52 and reg 24 with op 1.          
[   60.748000] roboswitch: timeout in robo_reg on page 52 and reg 26 with op 1.                                                                                                
[   60.756000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1.                                                                                                 
[   60.764000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1. 
[   60.772000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1. 
[   72.648000] b44 ssb0:1: eth0: powering down PHY                             
[   72.720000] b44 ssb0:1: eth0: Link is up at 100 Mbps, full duplex           
[   72.724000] b44 ssb0:1: eth0: Flow control is off for TX and off for RX     
[   72.784000] device eth0.0 entered promiscuous mode                          
[   72.788000] device eth0 entered promiscuous mode                            
[   72.804000] br-lan: port 1(eth0.0) entered forwarding state                 
[   72.808000] br-lan: port 1(eth0.0) entered forwarding state                 
[   74.812000] br-lan: port 1(eth0.0) entered forwarding state


This results in both lan and wan interface disfunctional, they do not receive any traffic:

br-lan    Link encap:Ethernet  HWaddr 00:01:E3:0E:95:C4  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:1536 (1.5 KiB)

eth0      Link encap:Ethernet  HWaddr 00:01:E3:0E:95:C4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:151 errors:0 dropped:1 overruns:0 frame:0
          TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:15620 (15.2 KiB)  TX bytes:13148 (12.8 KiB)
          Interrupt:5 

eth0.0    Link encap:Ethernet  HWaddr 00:01:E3:0E:95:C4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:1536 (1.5 KiB)

eth0.1    Link encap:Ethernet  HWaddr 00:01:E3:0E:95:C4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:3537 (3.4 KiB)

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by joykicer@…

same with above.
trunk r35016, bcm63xx arch, 6328 + 4313 wifi + mx25L128

[  128.720000] roboswitch: timeout in robo_reg on page 52 and reg 8 with op 1.
[  128.728000] roboswitch: timeout in robo_reg on page 52 and reg 10 with op 1.
[  128.736000] roboswitch: timeout in robo_reg on page 52 and reg 8 with op 1.
[  128.740000] roboswitch: timeout in robo_reg on page 52 and reg 10 with op 1.
[  128.748000] roboswitch: timeout in robo_reg on page 52 and reg 8 with op 1.
[  128.756000] roboswitch: timeout in robo_reg on page 52 and reg 10 with op 1.
[  128.764000] roboswitch: timeout in robo_reg on page 52 and reg 8 with op 1.
[  128.772000] roboswitch: timeout in robo_reg on page 52 and reg 10 with op 1.
[  128.780000] roboswitch: timeout in robo_reg on page 52 and reg 8 with op 1.
[  128.788000] roboswitch: timeout in robo_reg on page 0 and reg 0 with op 1.
[  128.796000] roboswitch: timeout in robo_reg on page 52 and reg 16 with op 1.
[  128.800000] roboswitch: timeout in robo_reg on page 0 and reg 1 with op 1.
[  128.808000] roboswitch: timeout in robo_reg on page 52 and reg 18 with op 1.
[  128.816000] roboswitch: timeout in robo_reg on page 0 and reg 2 with op 1.
[  128.824000] roboswitch: timeout in robo_reg on page 52 and reg 20 with op 1.
[  128.832000] roboswitch: timeout in robo_reg on page 0 and reg 3 with op 1.
[  128.840000] roboswitch: timeout in robo_reg on page 52 and reg 22 with op 1.
[  128.848000] roboswitch: timeout in robo_reg on page 0 and reg 4 with op 1.
[  128.852000] roboswitch: timeout in robo_reg on page 52 and reg 24 with op 1.
[  128.860000] roboswitch: timeout in robo_reg on page 0 and reg 8 with op 1.
[  128.868000] roboswitch: timeout in robo_reg on page 52 and reg 26 with op 1.
[  128.876000] roboswitch: timeout in robo_reg on page 0 and reg 0 with op 1.
[  128.884000] roboswitch: timeout in robo_reg on page 52 and reg 28 with op 1.
[  128.892000] roboswitch: timeout in robo_reg on page 0 and reg 0 with op 1.
[  128.900000] roboswitch: timeout in robo_reg on page 52 and reg 30 with op 1.
[  128.904000] roboswitch: timeout in robo_reg on page 0 and reg 0 with op 1.
[  128.912000] roboswitch: timeout in robo_reg on page 52 and reg 32 with op 1.
[  128.920000] roboswitch: timeout in robo_reg on page 0 and reg 11 with op 2.
[  128.928000] roboswitch: timeout in robo_reg on page 0 and reg 11 with op 1.
[  128.936000] roboswitch: timeout in robo_reg on page 52 and reg 0 with op 1.
[  128.944000] roboswitch: timeout in robo_reg on page 52 and reg 1 with op 1.
[  128.952000] roboswitch: timeout in robo_reg on page 52 and reg 16 with op 1.
[  128.960000] roboswitch: timeout in robo_reg on page 52 and reg 18 with op 1.
[  128.968000] roboswitch: timeout in robo_reg on page 52 and reg 20 with op 1.
[  128.972000] roboswitch: timeout in robo_reg on page 52 and reg 22 with op 1.
[  128.980000] roboswitch: timeout in robo_reg on page 52 and reg 24 with op 1.
[  128.988000] roboswitch: timeout in robo_reg on page 52 and reg 26 with op 1.
[  128.996000] roboswitch: timeout in robo_reg on page 5 and reg 99 with op 1.
[  129.004000] roboswitch: timeout in robo_reg on page 5 and reg 97 with op 1.
[  129.012000] roboswitch: timeout in robo_reg on page 5 and reg 96 with op 1.
[  131.648000] Compat-drivers backport release: compat-drivers-2012-12-04

LAN traffic work as normal,no vlan wan support now.

br-lan    Link encap:Ethernet  HWaddr 02:10:01:12:13:14  
          inet addr:192.168.95.117  Bcast:192.168.95.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:384689 errors:0 dropped:332 overruns:0 frame:0
          TX packets:1523 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:18589403 (17.7 MiB)  TX bytes:1139656 (1.0 MiB)
 
eth0      Link encap:Ethernet  HWaddr 02:10:18:00:00:00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:430634 errors:0 dropped:62 overruns:0 frame:0
          TX packets:1532 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:26847602 (25.6 MiB)  TX bytes:1146619 (1.0 MiB)

comment:2 Changed 5 years ago by nlh

There have been several recent changes to package/switch. You could try reverting to previous versions to determine if one of those is the cause.

svn up -r 34991 package/switch

or further

svn up -r 34988 package/switch

Backing out 34988 would take a little more work, as it affects a lot more than just package/switch.

comment:3 Changed 5 years ago by anonymous

OK, i tested r34991 first, still the same problem here. After that i reverted the whole tree to r34987. With this everything works as before. So my guess is that r34988 was the change that broke it.

comment:4 Changed 5 years ago by nbd

  • Owner changed from developers to hauke
  • Status changed from new to assigned

comment:5 Changed 5 years ago by hauke

Does this problem still occur with a recent trunk build?

comment:6 Changed 5 years ago by anonymous

No, i just tested r35816 (trunk) and the switch works again on my se505. thanks.

comment:7 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.