Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12699 closed defect (duplicate)

SubversionException: 24 - Can't open file '/var/svn/openwrt/db/revs/15756': Too many open files

Reported by: fabio.rossoni@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Come riprodurre il problema

Effettuando una operazione "GET" su /changeset/34905/trunk, Trac ha
generato un errore interno.

(per favore aggiungi ulteriori dettagli qui di seguito)

Parametri della request:

{'format': u'zip', 'new': u'34905', 'new_path': u'/trunk', 'old_path': u'/'}

User agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0

Informazioni sul sistema

Informazioni di sistema non disponibili

Componenti aggiuntivi abilitati

Informazioni sui prodotti aggiuntivi non disponibili

Traceback di Python

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 350, in process_request
    self._render_zip(req, filename, repos, data)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 784, in _render_zip
    content = new_node.get_content().read()
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 757, in get_content
    self.pool()))
  File "/usr/lib/python2.7/dist-packages/libsvn/fs.py", line 637, in svn_fs_file_contents
    return _fs.svn_fs_file_contents(*args)
SubversionException: 24 - Can't open file '/var/svn/openwrt/db/revs/15756': Too many open files

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by hnyman

Duplicate of: #12467, #12499, #12606, #12608, #12640

Can't open file '/var/svn/openwrt/db/revs/15756': Too many open files

That looks like a temporary server problem in the communication between the bug tracker and the actual svn server. Not a real bug of the Openwrt itself.

Perhaps that bug should be filed either at the Subversion bug tracker or the Trac bug tracker. But probably not here.

comment:2 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

please don't open duplicate tickets again and again...

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.