Modify

Opened 5 years ago

Closed 5 years ago

#12624 closed defect (fixed)

Compile Error with recent trunk

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Compile Error, Trunk Cc:

Description

pppd/plugins/pppoatm/Makefile <= pppd/plugins/pppoatm/Makefile.linux
pppd/plugins/pppol2tp/Makefile <= pppd/plugins/pppol2tp/Makefile.linux
pppd/plugins/pptp/Makefile <= pppd/plugins/pptp/Makefile.linux

mkdir -p /home/test/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/ppp-default/ppp-2.4.5/pppd/plugins/pppoatm/linux
cp /home/test/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.6.10/include/linux/compiler.h /home/test/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.6.10/include/uapi/linux/atm*.h /home/test/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/ppp-default/ppp-2.4.5/pppd/plugins/pppoatm/linux/
cp: cannot stat `/home/test/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.6.10/include/uapi/linux/atm*.h': No such file or directory
make[3]: * /home/test/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/ppp-default/ppp-2.4.5/.configured_ Error 1
make[3]: Leaving directory `/home/test/openwrt/trunk/package/network/services/ppp'
make[2]:
* [package/network/services/ppp/compile] Error 2
make[2]: Leaving directory `/home/test/openwrt/trunk'
make[1]: * /home/test/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/test/openwrt/trunk'

I get this reproducable error the whole time. It come with the most recent trunk from before 2 hours.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by hnyman <hannu.nyman@…>

Duplicate of #12620.

Reason is r34684. Reverting the changes made by it fixes things. Probably the change works with new kernel 3.7, but not with the older 3.6, which ar71xx still uses.

comment:2 Changed 5 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.