Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12612 closed defect (fixed)

ifdown: Command failed: Request timed out

Reported by: brian@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

I have found on several occasions after having a router up on AA-rc1 ifup/ifdown seem to be unable to reach something, netifd perhaps?. The symptom is:

# ifdown wan0

Command failed: Request timed out

and yes, wan0 is not a typo. I have two WAN interfaces here.

The only remedy that I have found is to reboot the router -- blech.

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by brian@…

Yes, indeed. It doesn't seem to take many iterations of ifup/ifdown for this situation to arise. Ultimately the problem seems to be with contacting ubusd but it is still running:

# ubus call network.interface.wan0 status
Command failed: Request timed out
# ps  | grep ubus
  941 root       872 S    /sbin/ubusd

comment:2 Changed 5 years ago by nbd

does it create a core file in /tmp?

comment:3 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:4 Changed 5 years ago by brian@…

Apologies for not responding to the request. I forgot there was an open request for info on this.

As it turns out, I seem unable to reproduce this any more.

I will re-open if I see it again.

comment:5 Changed 5 years ago by brian@…

  • Resolution no_response deleted
  • Status changed from closed to reopened

So, it seems I was able to reproduce this this morning. No core files in /tmp.

comment:6 Changed 5 years ago by nbd

any messages in syslog when this happens?

comment:7 Changed 5 years ago by brian@…

Nope. Nothing.

comment:8 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r35383

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.