Modify

Opened 5 years ago

Last modified 4 years ago

#12609 new defect

ar71xx, radvd not assign ipv6 address.

Reported by: xinglp <xinglp@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

My config script is below:

uci set network.6rd=interface
uci set network.6rd.proto=6to4
uci set network.6rd.adv_subnet=1
uci commit network
ifup 6rd

Now, I got ipv6 address.

uci rename radvd.@interface[0]=lan
uci set radvd.lan.ignore=0
uci commit radvd
/etc/init.d/radvd enable
/etc/init.d/radvd start

Now, the radvd started, but other machine get no ipv6 address. It worked well not long before.

The final config file:

/etc/config/network

config interface '6rd'
        option proto '6to4'
        option adv_subnet '1'

/etc/config/radvd

config interface 'lan'
        option interface 'lan'
        option AdvSendAdvert '1'
        option AdvManagedFlag '0'
        option AdvOtherConfigFlag '0'
        list client ''
        option ignore '0'

config prefix
        option interface 'lan'
        list prefix ''
        option AdvOnLink '1'
        option AdvAutonomous '1'
        option AdvRouterAddr '0'
        option ignore '1'

config route
        option interface 'lan'
        list prefix ''
        option ignore '1'

config rdnss
        option interface 'lan'
        list addr ''
        option ignore '1'

config dnssl
        option interface 'lan'
        list suffix ''
        option ignore '1'

The output of "logread|grep radvd", seems less than before, but I'm not sure.

Jan  1 08:00:27 tew-01 daemon.info radvd[1311]: version 1.9.1 started

Thanks.

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 5 years ago by hnyman <hannu.nyman@…>

This looks like a radvd config error:

config prefix
        option interface 'lan'
...
        option ignore '1'

In essence, you tell radvd to ignore the lan for prefix distribution.

comment:2 in reply to: ↑ 1 Changed 5 years ago by xinglp <xinglp@…>

Replying to hnyman <hannu.nyman@…>:

This looks like a radvd config error:

config prefix
        option interface 'lan'
...
        option ignore '1'

In essence, you tell radvd to ignore the lan for prefix distribution.

Still not work.

comment:3 follow-up: Changed 5 years ago by KillaB

I just upgraded to trunk r34939 and found that rdisc6 was unable to detect any neighbors. This was on an Ubuntu machine and the router itself.

Modified the startup script from 50 to 60 seconds which appears to have fixed the issue.

comment:4 in reply to: ↑ 3 Changed 5 years ago by xinglp <xinglp@…>

Replying to KillaB:

I just upgraded to trunk r34939 and found that rdisc6 was unable to detect any neighbors. This was on an Ubuntu machine and the router itself.

Modified the startup script from 50 to 60 seconds which appears to have fixed the issue.

I use 6to4, tried the "60 seconds" and even 80 with r35181, and still not work.
I notice that the question may be the br-lan not get a "2002:xxx" like ipv6 address.
and radvd assign "fe80::xxx" address on br-lan to my subnet.

comment:5 follow-up: Changed 5 years ago by KillaB

For reference, here's my working config:

config interface
	option interface	'lan'
	option AdvSendAdvert	1
	option AdvManagedFlag	0
	option AdvOtherConfigFlag 0
	option AdvLinkMTU	1280
	list client		''
	option ignore		0

config prefix
	option interface	'lan'
	# If not specified, a non-link-local prefix of the interface is used
	list prefix		'2001:xxx:xxx:xxxx::/64'
	option AdvOnLink	1
	option AdvAutonomous	1
	option AdvRouterAddr	0
	option ignore		0

config route
	option interface	'lan'
	list prefix		'2001:xxx:xxx:xxxx::/64'
	option ignore		1

config rdnss
	option interface	'lan'
	# If not specified, the link-local address of the interface is used
	list addr		'2001:xxx:xx::2'
	option ignore		1

config dnssl
	option interface	'lan'
	list suffix		''
	option ignore		1

comment:6 in reply to: ↑ 5 Changed 5 years ago by xinglp <xinglp@…>

Replying to KillaB:

For reference, here's my working config:

config interface
	option interface	'lan'
	option AdvSendAdvert	1
	option AdvManagedFlag	0
	option AdvOtherConfigFlag 0
	option AdvLinkMTU	1280
	list client		''
	option ignore		0

config prefix
	option interface	'lan'
	# If not specified, a non-link-local prefix of the interface is used
	list prefix		'2001:xxx:xxx:xxxx::/64'
	option AdvOnLink	1
	option AdvAutonomous	1
	option AdvRouterAddr	0
	option ignore		0

config route
	option interface	'lan'
	list prefix		'2001:xxx:xxx:xxxx::/64'
	option ignore		1

config rdnss
	option interface	'lan'
	# If not specified, the link-local address of the interface is used
	list addr		'2001:xxx:xx::2'
	option ignore		1

config dnssl
	option interface	'lan'
	list suffix		''
	option ignore		1

These still not work for me when I use 6to4.
Finally I use "ipv6-support".
See this https://forum.openwrt.org/viewtopic.php?id=41674
I just run /rom/etc/uci-defaults/enable-ipv6 and edit /etc/config/network wan6 section to use 6to4 instead of dhcp.
Everythings got to work.

comment:7 follow-up: Changed 5 years ago by xinglp <xinglp@…>

radvd works again after r35204, r35205, good old days come back.

My config is like this:

uci -q batch <<-EOF
set network.globals=globals
set network.globals.ula_prefix=auto
set network.wan6=interface
set network.wan6.proto=6to4 #or dhcpv6
set network.wan6.ifname=@wan
set network.lan.ip6assign=64 #  THIS IS THE POINT WHY IT DIDN'T WORK BEFORE.
set network.wan.ipv6=1
commit network
EOF

uci -q batch <<-EOF
set firewall.zone_wan.network='wan wan6'
commit firewall
EOF

uci rename radvd.@interface[0]=if_lan
uci set radvd.if_lan.ignore=0
uci rename radvd.@prefix[0]=prefix_lan
uci set radvd.prefix_lan.ignore=0
uci commit radvd

Please close this ticket.

comment:8 in reply to: ↑ 7 Changed 5 years ago by xinglp <xinglp@…>

Replying to xinglp <xinglp@…>:

radvd works again after r35204, r35205, good old days come back.

My config is like this:

uci -q batch <<-EOF
set network.globals=globals
set network.globals.ula_prefix=auto
set network.wan6=interface
set network.wan6.proto=6to4 #or dhcpv6
set network.wan6.ifname=@wan
set network.lan.ip6assign=64 #  THIS IS THE POINT WHY IT DIDN'T WORK BEFORE.
set network.wan.ipv6=1
commit network
EOF

uci -q batch <<-EOF
set firewall.zone_wan.network='wan wan6'
commit firewall
EOF

uci rename radvd.@interface[0]=if_lan
uci set radvd.if_lan.ignore=0
uci rename radvd.@prefix[0]=prefix_lan
uci set radvd.prefix_lan.ignore=0
uci commit radvd

Please close this ticket.

set firewall.zone_wan.network='wan wan6'

Should be

set firewall.@zone[1].network='wan wan6'

for you.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.