Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12595 closed defect (fixed)

Gateworks Laguna GW 2388 issue

Reported by: d.buffa@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I'm experiencing some issues with Gateworks Laguna hardware, using latest trunk sources.

The issue is random error and consequent laguna hang.

[    1.690000] dwc_otg dwc_otg.0: DWC OTG Controller
[    1.700000] dwc_otg dwc_otg.0: new USB bus registered, assigned bus number 1
[    1.700000] dwc_otg dwc_otg.0: irq 63, io mem 0x00000000
[    1.710000] DWC_otg: Init: Port Power? op_state=1
[    1.710000] DWC_otg: Init: Power Port (0)
[    1.720000] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.720000] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=                                                                      1
[    1.730000] usb usb1: Product: DWC OTG Controller
[    1.740000] usb usb1: Manufacturer: Linux 3.3.8 dwc_otg_hcd
[    1.740000] usb usb1: SerialNumber: gadget
[    1.750000] hub 1-0:1.0: USB hub found
[    1.750000] hub 1-0:1.0: 1 port detected
[    1.760000] cns3xxx-ohci cns3xxx-ohci.0: CNS3XXX OHCI Host controller
[    1.760000] cns3xxx-ohci cns3xxx-ohci.0: new USB bus registered, assigned bus                                                                       number 2
[    1.770000] cns3xxx-ohci cns3xxx-ohci.0: irq 91, io mem 0x88000000
[    1.840000] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    1.850000] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=                                                                      1
[    1.850000] usb usb2: Product: CNS3XXX OHCI Host controller
[    1.860000] usb usb2: Manufacturer: Linux 3.3.8 ohci_hcd
[    1.860000] usb usb2: SerialNumber: cns3xxx-ohci.0
[    1.870000] hub 2-0:1.0: USB hub found
[    1.870000] hub 2-0:1.0: 1 port detected
[    1.880000] mmc0: SDHCI controller on sdhci-cns3xxx.0 [sdhci-cns3xxx.0] using                                                                       PIO
[    1.890000] serial8250.0: ttyS0 at MMIO 0x78000000 (irq = 45) is a 16550A
[    1.890000] serial8250.0: ttyS1 at MMIO 0x78400000 (irq = 46) is a 16550A
[    1.900000] serial8250.0: ttyS2 at MMIO 0x78800000 (irq = 47) is a 16550A
[    1.910000] physmap platform flash device: 01000000 at 10000000
[    1.920000] physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank. Manuf                                                                      acturer ID 0x000001 Chip ID 0x002101
[    1.930000] Amd/Fujitsu Extended Query Table at 0x0040
[    1.930000]   Amd/Fujitsu Extended Query version 1.3.
[    1.940000] number of CFI chips: 1
[    1.940000] Creating 4 MTD partitions on "physmap-flash.0":
[    1.950000] 0x000000000000-0x000000040000 : "uboot"
[    1.950000] 0x000000040000-0x000000060000 : "params"
[    1.960000] 0x000000060000-0x000000260000 : "kernel"
[    1.970000] 0x000000260000-0x000001000000 : "rootfs"
[    1.970000] mtd: partition "rootfs" set to be root filesystem
[    1.980000] mtd: partition "rootfs_data" created automatically, ofs=4A0000, l                                                                      en=B60000
[    1.990000] 0x0000004a0000-0x000001000000 : "rootfs_data"
[    1.990000] cns3xxx_spi_probe: setup CNS3XXX SPI Controller
[    2.000000] m25p80 spi1.0: found m25p32, expected m25p80
[    2.010000] m25p80 spi1.0: m25p32 (4096 Kbytes)
[    2.010000] Creating 4 MTD partitions on "spi1.0":
[    2.010000] 0x000000000000-0x000000040000 : "uboot"
[    2.020000] 0x000000040000-0x000000080000 : "params"
[    2.030000] 0x000000080000-0x000000200000 : "kernel"
[    2.030000] 0x000000200000-0x000000400000 : "rootfs"
[    2.040000] split_squashfs: no squashfs found in "spi1.0"
[    2.060000] rtc-ds1672 0-0068: setting system clock to 1970-01-31 23:18:53 UT                                                                      C (2675933)
[    2.070000] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[    2.080000] Freeing init memory: 152K
[    2.450000] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    2.680000] usb 1-1: New USB device found, idVendor=0480, idProduct=a009
[    2.690000] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.690000] usb 1-1: Product: External USB 3.0
[    2.700000] usb 1-1: Manufacturer: TOSHIBA
[    2.700000] usb 1-1: SerialNumber: 222229202315
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
[    6.480000] JFFS2 notice: (579) jffs2_build_xattr_subsystem: complete buildin                                                                      g xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 6 of xref (0 dead, 2                                                                       orphan) found.
[    7.040000] Initializing USB Mass Storage driver...
[    7.040000] scsi0 : usb-storage 1-1:1.0
[    7.050000] usbcore: registered new interface driver usb-storage
[    7.050000] USB Mass Storage support registered.
[    8.050000] scsi 0:0:0:0: Direct-Access     TOSHIBA  External USB 3.0 0201 PQ                                                                      : 0 ANSI: 6
[    8.060000] sd 0:0:0:0: [sda] 976773164 512-byte logical blocks: (500 GB/465                                                                       GiB)
[    8.070000] sd 0:0:0:0: [sda] Write Protect is off
[    8.070000] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doe                                                                      sn't support DPO or FUA
[    8.110000]  sda: sda1 sda2 sda3
[    8.120000] sd 0:0:0:0: [sda] Attached SCSI disk
[   27.880000] EXT4-fs (sda2): recovery complete
[   27.880000] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts:                                                                       (null)
switching to external rootfs
- init -

Please press Enter to activate this console. [   28.930000] sd 0:0:0:0: [sda] Un                                                                      handled sense code
[   28.930000] sd 0:0:0:0: [sda]  Result: hostbyte=0x10 driverbyte=0x08
[   28.940000] sd 0:0:0:0: [sda]  Sense Key : 0x3 [current]
[   28.940000] sd 0:0:0:0: [sda]  ASC=0x11 ASCQ=0xc
[   28.950000] sd 0:0:0:0: [sda] CDB: cdb[0]=0x2a: 2a 00 00 cf 07 b5 00 00 f0 00
[   28.960000] end_request: critical target error, dev sda, sector 13567925
[   29.050000] Compat-drivers backport release: compat-drivers-2012-12-04
[   29.060000] Backport based on wireless-testing.git master-2012-12-06
[   29.060000] compat.git: wireless-testing.git
[   29.150000] cfg80211: Calling CRDA to update world regulatory domain
[   29.160000] cfg80211: World regulatory domain updated:
[   29.160000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gai                                                                      n, max_eirp)
[   29.170000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 20                                                                      00 mBm)
[   29.180000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 20                                                                      00 mBm)
[   29.190000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 20                                                                      00 mBm)
[   29.200000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 20                                                                      00 mBm)
[   29.200000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 20                                                                      00 mBm)
[   29.660000] PCI: enabling device 0000:02:0e.0 (0340 -> 0342)
[   29.670000] ath5k 0000:02:0e.0: registered as 'phy0'
[   30.320000] ath5k: phy0: Atheros AR5414 chip found (MAC: 0xa5, PHY: 0x61)
[   30.330000] PCI: enabling device 0000:02:0f.0 (0340 -> 0342)
[   30.330000] ath5k 0000:02:0f.0: registered as 'phy1'
[   30.340000] cfg80211: Calling CRDA for country: US
[   30.340000] cfg80211: Regulatory domain changed to country: US
[   30.350000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gai                                                                      n, max_eirp)
[   30.360000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 27                                                                      00 mBm)
[   30.360000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 17                                                                      00 mBm)
[   30.370000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 20                                                                      00 mBm)
[   30.380000] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 20                                                                      00 mBm)
[   30.390000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 20                                                                      00 mBm)
[   30.390000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 30                                                                      00 mBm)
[   31.060000] ath5k: phy1: Atheros AR5414 chip found (MAC: 0xa5, PHY: 0x61)
[   31.490000] PPP generic driver version 2.4.2
[   31.680000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   31.860000] NET: Registered protocol family 24
[   31.880000] nf_conntrack version 0.5.0 (4009 buckets, 16036 max)
[   32.230000] xt_time: kernel timezone is -0000
[   32.450000] usbcore: registered new interface driver ums-alauda
[   32.470000] usbcore: registered new interface driver ums-cypress
[   32.480000] usbcore: registered new interface driver ums-datafab
[   32.500000] usbcore: registered new interface driver ums-freecom
[   32.520000] usbcore: registered new interface driver ums-isd200
[   32.540000] usbcore: registered new interface driver ums-jumpshot
[   32.560000] usbcore: registered new interface driver ums-karma
[   32.580000] usbcore: registered new interface driver ums-sddr09
[   32.600000] usbcore: registered new interface driver ums-sddr55
[   32.620000] usbcore: registered new interface driver ums-usbat
[   32.790000] u32 classifier
[   32.790000]     Performance counters on
[   32.800000]     input device check on
[   32.800000]     Actions configured
[   32.960000] Mirror/redirect action on
[   35.020000] Adding 489944k swap on /dev/sda1.  Priority:-1 extents:1 across:4                                                                      89944k
[   35.640000] EXT4-fs (sda3): recovery complete
[   35.640000] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts:                                                                       (null)
[   36.700000] eth0: link up, speed 100 Mb/s, full duplex
[   36.700000] device eth0 entered promiscuous mode
[   36.700000] br-lan: port 1(eth0) entered forwarding state
[   36.700000] br-lan: port 1(eth0) entered forwarding state
[   37.640000] eth0: link down
[   38.640000] br-lan: port 1(eth0) entered disabled state
[   39.230000] eth0: link up, speed 100 Mb/s, full duplex
[   39.230000] eth0: link down
[  100.580000] INFO: rcu_sched detected stalls on CPUs/tasks: { 0} (detected by                                                                       1, t=6002 jiffies)
[  100.580000] Backtrace:
[  100.580000] Function entered at [<c0011034>] from [<c02814dc>]
[  100.580000]  r6:c0313350 r5:c031a580 r4:c055c5f8 r3:00000001
[  100.580000] Function entered at [<c02814c4>] from [<c005e0b0>]
[  100.580000] Function entered at [<c005de80>] from [<c005f190>]
[  100.580000] Function entered at [<c005f0cc>] from [<c0027208>]
[  100.580000]  r4:00000000 r3:c0346720
[  100.580000] Function entered at [<c00271c8>] from [<c004fb28>]
[  100.580000]  r6:ce813c78 r5:c055c530 r4:c0348428 r3:20000113
[  100.580000] Function entered at [<c004f95c>] from [<c003940c>]
[  100.580000] Function entered at [<c00393a8>] from [<c0039c14>]
[  100.580000]  r7:00000001 r6:c055c3c0 r5:00000000 r4:c055c3f0
[  100.580000] Function entered at [<c0039af8>] from [<c00132bc>]
[  100.580000] Function entered at [<c0013284>] from [<c005b668>]
[  100.580000]  r4:c030ef80 r3:c0013284
[  100.580000] Function entered at [<c005b5e0>] from [<c0057e90>]
[  100.580000]  r8:00000000 r7:c0313520 r6:c030aa34 r5:0000001d r4:ce812000
[  100.580000] r3:c005b5e0
[  100.580000] Function entered at [<c0057e60>] from [<c000e6a4>]
[  100.580000] Function entered at [<c000e620>] from [<c00084c4>]
[  100.580000]  r8:c03132b8 r7:ce813c78 r6:fee00100 r5:c03132b8 r4:00000000
[  100.580000] r3:0000001d
[  100.580000] Function entered at [<c0008440>] from [<c000daa0>]
[  100.580000] Exception stack(0xce813c78 to 0xce813cc0)
[  100.580000] 3c60:                                                       00000                                                                      002 00000002
[  100.580000] 3c80: 00000000 00000001 c0555160 ce813cfc c0555160 c030b160 c0555                                                                      168 00000001
[  100.580000] 3ca0: 00000000 ce813cec 00000001 ce813cc0 c001824c c0053a48 20000                                                                      113 ffffffff
[  100.580000]  r8:c0555168 r7:ce813cac r6:ffffffff r5:20000113 r4:c0053a48
[  100.580000] r3:c001824c
[  100.580000] Function entered at [<c00539c8>] from [<c0053bd8>]
[  100.580000] Function entered at [<c0053a60>] from [<c0053d3c>]
[  100.580000] Function entered at [<c0053c08>] from [<c0012dd4>]
[  100.580000] Function entered at [<c0012da8>] from [<c0012f64>]
[  100.580000]  r6:2ec9375f r5:00000001 r4:cf3d21b8 r3:cf10b2e0
[  100.580000] Function entered at [<c0012f0c>] from [<c00854e4>]
[  100.580000] Function entered at [<c0085474>] from [<c0078cac>]
[  100.580000]  r8:cf17cc54 r7:0006e000 r6:cf10b2e0 r5:00000000 r4:cf3d21b8
[  100.580000] r3:2ec9375f
[  100.580000] Function entered at [<c0078994>] from [<c007ab90>]
[  100.580000] Function entered at [<c007a56c>] from [<c007aca8>]
[  100.580000] Function entered at [<c007ac10>] from [<c0014358>]
[  100.580000] Function entered at [<c0014248>] from [<c0008344>]
[  100.580000] Function entered at [<c0008308>] from [<c000dbd8>]
[  100.580000] Exception stack(0xce813fb0 to 0xce813ff8)
[  100.580000] 3fa0:                                     00920528 00000002 0006e                                                                      718 00000000
[  100.580000] 3fc0: 00920528 00920534 ffffffff 0006f908 ffffffff 00923d74 00000                                                                      005 00000000
[  100.580000] 3fe0: 00920528 bef80d98 000252bc 000240b4 20000010 ffffffff
[  100.580000]  r7:0006f908 r6:ffffffff r5:20000010 r4:000240b4

Laguna is equipped with one Ubiquiti XR2 and one Ubiquiti XR5 card. There is a 500 Gb hard disk attached on the usb port (512 mb swap / 10 Gb ext4 extroot / 480 Gb ext4 space). During tests I saw io corrupted error message on console log, and sometime after reboot extroot was in disabled status. The disk is new and perfectly working, now I removed it in order to understand if this is the cause...

Available for other information
D.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by d.buffa@…

Sorry, the component is not "packages", my mistake... I ask administrators to fix it, thanks
D.

comment:2 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

works in current trunk/AA

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.