Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#1259 closed defect (invalid)

kmod-net-ipw2200 is not built at brcm2.4 on kamikaze.

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version:
Keywords: Cc:

Description

Hi, developers.
It seems that kmod-net-ipw2200 is not built when selecting brcm2.4.

owrt@localhost ~/kamikaze/snapshot/trunk $ ls bin/packages/
Packages                                    kmod-switch_2.4.34-brcm-1_mipsel.ipk
base-files-brcm-2.4_8-6200_mipsel.ipk       kmod-wlcompat_2.4.34+brcm-4_mipsel.ipk
bridge_1.0.6-1_mipsel.ipk                   libgcc_3.4.6-8_mipsel.ipk
busybox_1.3.1-1_mipsel.ipk                  mtd_5_mipsel.ipk
dnsmasq_2.35-1_mipsel.ipk                   nas_4.80.53.0-1_mipsel.ipk
dropbear_0.48.1-1_mipsel.ipk                nvram_1_mipsel.ipk
iptables_1.3.5-1_mipsel.ipk                 uclibc_0.9.28-8_mipsel.ipk
kernel_2.4.34-brcm-1_mipsel.ipk             wireless-tools_28-1_mipsel.ipk
kmod-brcm-wl_2.4.34+4.80.53.0-1_mipsel.ipk  wlc_4.80.53.0-1_mipsel.ipk
kmod-diag_1+2.4.34-brcm-1_mipsel.ipk

wireless drivers config in .config

#
# Wireless Drivers
#
# CONFIG_PACKAGE_kmod-hostap is not set
CONFIG_PACKAGE_kmod-ieee80211=m
CONFIG_PACKAGE_kmod-ieee80211-softmac=m
# CONFIG_PACKAGE_kmod-madwifi is not set
# CONFIG_PACKAGE_kmod-net-airo is not set
# CONFIG_PACKAGE_kmod-net-bcm43xx is not set
# CONFIG_PACKAGE_kmod-net-hermes is not set
# CONFIG_PACKAGE_kmod-net-ipw2100 is not set
CONFIG_PACKAGE_kmod-net-ipw2200=m
# CONFIG_PACKAGE_kmod-net-prism54 is not set
# CONFIG_PACKAGE_kmod-net-zd1211rw is not set
# CONFIG_PACKAGE_kmod-rt2500 is not set
# CONFIG_PACKAGE_kmod-rt2570 is not set
# CONFIG_PACKAGE_kmod-rt61 is not set

It's built when selecting brcm2.6.

owrt@localhost ~/kamikaze/snapshot/trunk $ ls bin/packages/
Packages                                kmod-ieee80211-softmac_2.6.19.2-brcm-1_mipsel.ipk
base-files-brcm-2.6_8-6200_mipsel.ipk   kmod-ieee80211_2.6.19.2-brcm-1_mipsel.ipk
bridge_1.0.6-1_mipsel.ipk               kmod-net-ipw2200_2.6.19.2-brcm-1_mipsel.ipk
busybox_1.3.1-1_mipsel.ipk              kmod-switch_2.6.19.2-brcm-1_mipsel.ipk
dnsmasq_2.35-1_mipsel.ipk               libgcc_3.4.6-8_mipsel.ipk
dropbear_0.48.1-1_mipsel.ipk            mtd_5_mipsel.ipk
iptables_1.3.5-1_mipsel.ipk             uclibc_0.9.28-8_mipsel.ipk
kernel_2.6.19.2-brcm-1_mipsel.ipk       wireless-tools_28-1_mipsel.ipk
kmod-diag_1+2.6.19.2-brcm-1_mipsel.ipk

cheers,

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by florian

  • Resolution set to invalid
  • Status changed from new to closed

ipw2200 is only available with 2.6 kernels, you have probably switched between brcm-2.6 and/or brcm-2.4 without using make distclean, which resulted in "seeing" drivers in menuconfig, even if those drivers are 2.6 specific.

comment:2 Changed 11 years ago by anonymous

OK, I understand.
But I wouldn't want to "make distclean" when possible. It operates "rm -rf dl/" finally.
I try not to care for seeing them.

Thank you very much.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.